aboutsummaryrefslogtreecommitdiff
path: root/mail/py-milter
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2004-04-29 13:20:26 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2004-04-29 13:20:26 +0000
commitef9850210c4026372422a8e5fc97f130efa207d5 (patch)
tree68994b97cc810d4c203a250c83f95afd00d7d04c /mail/py-milter
parent7db1a6158f8f6697ac6d4f1ac6fececbc4dbfdd9 (diff)
downloadports-ef9850210c4026372422a8e5fc97f130efa207d5.tar.gz
ports-ef9850210c4026372422a8e5fc97f130efa207d5.zip
Notes
Diffstat (limited to 'mail/py-milter')
-rw-r--r--mail/py-milter/Makefile2
-rw-r--r--mail/py-milter/distinfo4
-rw-r--r--mail/py-milter/files/patch-aa10
-rw-r--r--mail/py-milter/files/patch-ab28
4 files changed, 8 insertions, 36 deletions
diff --git a/mail/py-milter/Makefile b/mail/py-milter/Makefile
index 28ecbbcb7414..048cac9952b2 100644
--- a/mail/py-milter/Makefile
+++ b/mail/py-milter/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= milter
-PORTVERSION= 0.6.0
+PORTVERSION= 0.6.9
CATEGORIES= mail python
MASTER_SITES= http://www.bmsi.com/python/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/mail/py-milter/distinfo b/mail/py-milter/distinfo
index 4893e969a0f4..ac5f9be0b465 100644
--- a/mail/py-milter/distinfo
+++ b/mail/py-milter/distinfo
@@ -1,2 +1,2 @@
-MD5 (python/milter-0.6.0.tar.gz) = aeca5c3200ce8be1b6520057b60d440c
-SIZE (python/milter-0.6.0.tar.gz) = 69791
+MD5 (python/milter-0.6.9.tar.gz) = e0d66c37952c2fa96091173db5583412
+SIZE (python/milter-0.6.9.tar.gz) = 89590
diff --git a/mail/py-milter/files/patch-aa b/mail/py-milter/files/patch-aa
index 69dfad11885c..42a0119d5e23 100644
--- a/mail/py-milter/files/patch-aa
+++ b/mail/py-milter/files/patch-aa
@@ -1,11 +1,11 @@
---- setup.py.orig Tue Jul 1 15:36:23 2003
-+++ setup.py Tue Jul 1 15:36:54 2003
-@@ -2,7 +2,7 @@
+--- setup.py Tue Apr 20 00:15:07 2004
++++ setup.py Fri Apr 23 10:59:26 2004
+@@ -3,7 +3,7 @@
from distutils.core import setup, Extension
# FIXME: on some versions of sendmail, smutil is renamed to sm
-libs = ["milter", "smutil"]
+libs = ["milter"]
- setup(name = "milter", version = "0.5.5",
- description="Python interface to sendmail-8.1x milter API",
+ # patch distutils if it can't cope with the "classifiers" or
+ # "download_url" keywords
diff --git a/mail/py-milter/files/patch-ab b/mail/py-milter/files/patch-ab
deleted file mode 100644
index c8d868bf8b41..000000000000
--- a/mail/py-milter/files/patch-ab
+++ /dev/null
@@ -1,28 +0,0 @@
---- miltermodule.c.orig Tue Jun 24 21:57:04 2003
-+++ miltermodule.c Wed Sep 24 15:30:04 2003
-@@ -110,6 +110,7 @@
-
- #include <pthread.h>
- #include <netinet/in.h>
-+#include <arpa/inet.h>
- #include <Python.h>
- #include <libmilter/mfapi.h>
-
-@@ -503,7 +504,7 @@
- static PyObject *
- makeip6addr(struct sockaddr_in6 *addr) {
- char buf[100]; /* must be at least INET6_ADDRSTRLEN + 1 */
-- char * s;
-+ const char * s;
- s = inet_ntop(AF_INET6, &addr->sin6_addr, buf, sizeof(buf));
- if( s )
- return PyString_FromString(buf);
-@@ -987,7 +988,7 @@
- static char milter_quarantine__doc__[] =
- "quarantine(string) -> None\n\
- Place the message in quarantine. A string with a description of the reason\n\
--is the only argument.
-+is the only argument.\
- ";
-
- static PyObject *