aboutsummaryrefslogtreecommitdiff
path: root/mail/py-milter
diff options
context:
space:
mode:
authorJason Unovitch <junovitch@FreeBSD.org>2016-12-01 23:41:24 +0000
committerJason Unovitch <junovitch@FreeBSD.org>2016-12-01 23:41:24 +0000
commitfc7645d0eff5aa6252e13f04d78a642bb14cf24e (patch)
treefb45ea8b309f4b47bb0d7a778ff2d127f7ca423a /mail/py-milter
parent9bbc91bba2f0335c07316c662f44411f5dfd01cf (diff)
downloadports-fc7645d0eff5aa6252e13f04d78a642bb14cf24e.tar.gz
ports-fc7645d0eff5aa6252e13f04d78a642bb14cf24e.zip
Notes
Diffstat (limited to 'mail/py-milter')
-rw-r--r--mail/py-milter/Makefile6
-rw-r--r--mail/py-milter/files/patch-miltermodule.c11
2 files changed, 14 insertions, 3 deletions
diff --git a/mail/py-milter/Makefile b/mail/py-milter/Makefile
index 5931acf01c41..f6433c7be63d 100644
--- a/mail/py-milter/Makefile
+++ b/mail/py-milter/Makefile
@@ -3,13 +3,14 @@
PORTNAME= milter
PORTVERSION= 1.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= mail python
MASTER_SITES= SF/${PYPORTNAME}/${PYPORTNAME}/${DISTNAME}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= ${PYPORTNAME}-${PORTVERSION}
+DIST_SUBDIR= python
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= estartu@augusta.de
COMMENT= Python interface to Sendmail milter API
LICENSE= GPLv2+
@@ -22,7 +23,6 @@ CFLAGS+= -I${LOCALBASE}/include
PYPORTNAME= ${PKGNAMEPREFIX:C/[0-9]+-//}${PORTNAME}
-DIST_SUBDIR= python
USES= python:2
USE_PYTHON= distutils autoplist
diff --git a/mail/py-milter/files/patch-miltermodule.c b/mail/py-milter/files/patch-miltermodule.c
new file mode 100644
index 000000000000..fbfae9df0559
--- /dev/null
+++ b/mail/py-milter/files/patch-miltermodule.c
@@ -0,0 +1,11 @@
+--- miltermodule.c.orig 2013-03-15 20:50:01 UTC
++++ miltermodule.c
+@@ -285,7 +285,7 @@ $ python setup.py help
+ * published. Unfortunately I know of no good way to do this
+ * other than with OS-specific tests.
+ */
+-#if defined(__FreeBSD_kernel__) || defined(__linux__)
++#if defined(__FreeBSD__) || defined(__linux__)
+ #define HAVE_IPV6_RFC2553
+ #include <arpa/inet.h>
+ #endif