aboutsummaryrefslogtreecommitdiff
path: root/mail/py-notmuch2
diff options
context:
space:
mode:
authorDanilo G. Baio <dbaio@FreeBSD.org>2020-08-12 21:00:47 +0000
committerDanilo G. Baio <dbaio@FreeBSD.org>2020-08-12 21:00:47 +0000
commitb58fe376834cfdd53a33e72afe0f63991083ba4d (patch)
tree50da0cd8156484c8d8c5adabbc54ffa6e35abcfe /mail/py-notmuch2
parent0f00dde1d815ffdf1d3d40fbc8cc0ac0e6da89f0 (diff)
downloadports-b58fe376834cfdd53a33e72afe0f63991083ba4d.tar.gz
ports-b58fe376834cfdd53a33e72afe0f63991083ba4d.zip
Add mail/py-notmuch2: Pythonic bindings for the notmuch mail database using CFFI
Pythonic bindings for the notmuch mail database using CFFI. This module makes the functionality of the notmuch library (https://notmuchmail.org) available to python using CFFI WWW: https://notmuchmail.org/
Notes
Notes: svn path=/head/; revision=544770
Diffstat (limited to 'mail/py-notmuch2')
-rw-r--r--mail/py-notmuch2/Makefile24
-rw-r--r--mail/py-notmuch2/pkg-descr5
2 files changed, 29 insertions, 0 deletions
diff --git a/mail/py-notmuch2/Makefile b/mail/py-notmuch2/Makefile
new file mode 100644
index 000000000000..6916fb4579f1
--- /dev/null
+++ b/mail/py-notmuch2/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+CATEGORIES= mail python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+PKGNAMESUFFIX= 2
+
+COMMENT= Pythonic bindings for the notmuch mail database using CFFI
+
+LICENSE= GPLv3
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=1.0.0:devel/py-cffi@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=1.0.0:devel/py-cffi@${PY_FLAVOR}
+LIB_DEPENDS= libnotmuch.so:mail/notmuch
+
+USES= python:3.5+ uniquefiles:dirs
+USE_PYTHON= autoplist distutils
+
+MASTERDIR= ${.CURDIR}/../notmuch
+WRKSRC_SUBDIR= bindings/python-cffi
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/notmuch2/_capi.abi3.so
+
+.include "${MASTERDIR}/Makefile"
diff --git a/mail/py-notmuch2/pkg-descr b/mail/py-notmuch2/pkg-descr
new file mode 100644
index 000000000000..fb2e642185fd
--- /dev/null
+++ b/mail/py-notmuch2/pkg-descr
@@ -0,0 +1,5 @@
+Pythonic bindings for the notmuch mail database using CFFI. This module makes
+the functionality of the notmuch library (https://notmuchmail.org) available to
+python using CFFI
+
+WWW: https://notmuchmail.org/