aboutsummaryrefslogtreecommitdiff
path: root/mail/py-pyspf
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-01-02 16:16:44 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-01-02 16:16:44 +0000
commit0f7549958048d14b9f7bfaaac8c283bc52ef0fa4 (patch)
tree262607291bfdf1b136e077a66ab9ac7fea7aeeb0 /mail/py-pyspf
parente1c750d1b59576d90d6902dcaa506cac6394049b (diff)
downloadports-0f7549958048d14b9f7bfaaac8c283bc52ef0fa4.tar.gz
ports-0f7549958048d14b9f7bfaaac8c283bc52ef0fa4.zip
Update to 2.0.14
Notes
Notes: svn path=/head/; revision=521839
Diffstat (limited to 'mail/py-pyspf')
-rw-r--r--mail/py-pyspf/Makefile21
-rw-r--r--mail/py-pyspf/distinfo6
-rw-r--r--mail/py-pyspf/files/patch-spf.py13
3 files changed, 10 insertions, 30 deletions
diff --git a/mail/py-pyspf/Makefile b/mail/py-pyspf/Makefile
index f3a65dcc4bc0..f4bad5e1db39 100644
--- a/mail/py-pyspf/Makefile
+++ b/mail/py-pyspf/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= pyspf
-PORTVERSION= 2.0.13
-PORTREVISION= 1
+PORTVERSION= 2.0.14
CATEGORIES= mail python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,25 +12,19 @@ COMMENT= SPF (Sender Policy Framework) implemented in Python
LICENSE= PSFL
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}authres>=0:mail/py-authres@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}authres>=0:mail/py-authres@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dnspython>=1.16.0:dns/py-dnspython@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}yaml>=0:devel/py-yaml@${PY_FLAVOR}
-NO_ARCH= yes
-USE_PYTHON= autoplist concurrent distutils
USES= python shebangfix
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
PLIST_FILES= bin/spf.py
SHEBANG_FILES= spf.py
-.include <bsd.port.pre.mk>
-
-.if ${PYTHON_REL} >= 3000
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}py3dns>=0:dns/py-py3dns@${PY_FLAVOR}
-.else
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}dns>=0:dns/py-dns@${PY_FLAVOR}
-.endif
-
# Make the tests run as a module
post-patch:
@${TOUCH} ${WRKSRC}/test/__init__.py
@@ -43,4 +36,4 @@ post-install:
do-test:
cd ${WRKSRC}/ && ${PYTHON_CMD} -m test.testspf
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/py-pyspf/distinfo b/mail/py-pyspf/distinfo
index f7a269d177b2..0bbc2133fc8e 100644
--- a/mail/py-pyspf/distinfo
+++ b/mail/py-pyspf/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1572806140
-SHA256 (pyspf-2.0.13.tar.gz) = 62dc1be39519e343202d480da7ef93d834b5a50cd4f217bef9335ed15292929b
-SIZE (pyspf-2.0.13.tar.gz) = 65960
+TIMESTAMP = 1577977078
+SHA256 (pyspf-2.0.14.tar.gz) = 57a7ef01bda090173aafb6af0106251686ed73f03db4e911fcd34c57fc347186
+SIZE (pyspf-2.0.14.tar.gz) = 69446
diff --git a/mail/py-pyspf/files/patch-spf.py b/mail/py-pyspf/files/patch-spf.py
deleted file mode 100644
index cd1459e9e30a..000000000000
--- a/mail/py-pyspf/files/patch-spf.py
+++ /dev/null
@@ -1,13 +0,0 @@
-Obtained from: https://github.com/sdgathman/pyspf/commit/4744deeec4a2c10987aae72989d7137156ed4151
-
---- spf.py.orig
-+++ spf.py
-@@ -91,7 +91,7 @@
- print('ipaddr module required: http://code.google.com/p/ipaddr-py/')
-
-
--def DNSLookup_pydns(name, qtype, tcpfallback=True, timeout=30):
-+def DNSLookup_pydns(name, qtype, strict=True, timeout=20):
-
- try:
- req = DNS.DnsRequest(name, qtype=qtype, timeout=timeout)