aboutsummaryrefslogtreecommitdiff
path: root/mail/qmail-mysql
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2005-05-05 20:03:10 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2005-05-05 20:03:10 +0000
commitf49371e1f646299c9b5d80fa3c9c0e6d633fb2b9 (patch)
tree5da22119a8396948aecc14b7493114bc3f83615a /mail/qmail-mysql
parent56ba17e54e205c9de3e77df697b7f3caa9b4a6c0 (diff)
downloadports-f49371e1f646299c9b5d80fa3c9c0e6d633fb2b9.tar.gz
ports-f49371e1f646299c9b5d80fa3c9c0e6d633fb2b9.zip
o Pacify a lot of portlint WARN and FATAL messages
o Change ${PERL} to ${SED} or ${REINPLACE_CMD} o Added patch patch-qmail-1.03-rfc2821.diff to search other MX servers when the first return a code > 500 and < 599 o Install mkaliasdir script on ${PREFIX}/scripts directory o Remove targets to disable-qmail and enable-sendmail and put it on a shell script that is installed on /var/qmail/scripts. Change messages reflect this. o Organize better pkg-plist o Remove thereal-post-patch target and put all on post-post-patch target o Add [0-9] to CONFLICTS on qmail-ldap port o Change LIB_DEPENDS to USE_MYSQL=yes on qmail-mysql port o Change qmail-spamcontrol to don't need more to apply patches mannualy PR: ports/79094 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=134675
Diffstat (limited to 'mail/qmail-mysql')
-rw-r--r--mail/qmail-mysql/Makefile26
-rw-r--r--mail/qmail-mysql/pkg-message9
2 files changed, 13 insertions, 22 deletions
diff --git a/mail/qmail-mysql/Makefile b/mail/qmail-mysql/Makefile
index a5f3cdcc55e1..981ce9cc1702 100644
--- a/mail/qmail-mysql/Makefile
+++ b/mail/qmail-mysql/Makefile
@@ -17,7 +17,8 @@ PATCHFILES+= qmail-mysql-${MYSQL_PATCH_VERSION}.patch:mysql
MAINTAINER= freebsd@galle.com.br
COMMENT= A SECURE, reliable, and FAST MTA for UNIX systems WITH MySQL support
-LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
+USE_MYSQL= yes
+USE_REINPLACE= yes
# patches from the master port that brake this one are now allowed
MAIN_QMAIL_PORT_WITH_QMAILQUEUE_PATCH_BARRIER= yes
@@ -26,30 +27,25 @@ MYSQL_PATCH_VERSION= 1.1.8
# Using default from master port, i.e., /var/qmail
PREFIX?= ${QMAIL_PORT_PREFIX}
-#PREFIX= /var/qmail-mysql
-.if !defined(PRE_MK_INCLUDED)
+.if !defined(_PREMKINCLUDED)
.include <bsd.port.pre.mk>
.endif
-#QMAIL_PORT= ${PORTSDIR}/mail/qmail
-QMAIL_PORT= ${.CURDIR}/../qmail
-QMAIL_PORT_PREFIX!= cd ${QMAIL_PORT} && ${MAKE} -V PREFIX
+# Local overrides
+MASTERDIR= ${.CURDIR}/../qmail
+PKGDIR_LOCAL= ${.CURDIR}
+DESCR= ${PKGDIR_LOCAL}/pkg-descr
+PKGMESSAGE= ${PKGDIR_LOCAL}/pkg-message
+
+QMAIL_PORT_PREFIX!= cd ${MASTERDIR} && ${MAKE} -V PREFIX
# Yet anther ugly hack (works due to code inside the main qmail port)
slaveport-post-patch: qmail-mysql-post-patch
qmail-mysql-post-patch:
- @${PERL} -pi -ne \
+ @${REINPLACE_CMD} \
's|/opt/mysql|${LOCALBASE}|' \
${WRKSRC}/Makefile
-# Local overrides
-MASTERDIR= ${QMAIL_PORT}
-PKGDIR_LOCAL= ${.CURDIR}
-DESCR= ${PKGDIR_LOCAL}/pkg-descr
-PKGMESSAGE= ${PKGDIR_LOCAL}/pkg-message
-
-PRE_MK_INCLUDED= yes
-
.include "${MASTERDIR}/Makefile"
diff --git a/mail/qmail-mysql/pkg-message b/mail/qmail-mysql/pkg-message
index 3eeb0f503464..51ce1aa835ac 100644
--- a/mail/qmail-mysql/pkg-message
+++ b/mail/qmail-mysql/pkg-message
@@ -10,10 +10,5 @@ or login.conf(5)).
Do not forget to read http://iain.cx/unix/qmail/mysql.php. After all,
this is NOT our old stock qmail.
-You can enable qmail as your default mailer:
-
-# this will disable the default MTA
-1) do "make disable-sendmail"
-
-# enable qmail as your default MTA
-2) do "make enable-qmail"
+You can enable qmail as your default mailer executing:
+> /var/qmail/scripts/enable-qmail