aboutsummaryrefslogtreecommitdiff
path: root/mail/qmail-remove
diff options
context:
space:
mode:
authorMichael Gmelin <grembo@FreeBSD.org>2014-06-01 16:22:35 +0000
committerMichael Gmelin <grembo@FreeBSD.org>2014-06-01 16:22:35 +0000
commit0c7c5ef6b88764b9ab0222a904112dfd88d00f8e (patch)
tree338bb8bb9b42a6340e7923a43af1ee22502dd5c9 /mail/qmail-remove
parentd4dc724ad8a0810aa669746a57b03900f5d2bc16 (diff)
downloadports-0c7c5ef6b88764b9ab0222a904112dfd88d00f8e.tar.gz
ports-0c7c5ef6b88764b9ab0222a904112dfd88d00f8e.zip
Stagify. Shebangfix. Also renamed populate.pl to
populate-qmail-queue.pl, since it lives in $PREFIX/bin. Bumped PORTREVISION due to this change. Since I don't expect many people to use populate.pl I did not add USES= perl5 Reviewed by: flo (mentor) Approved by: flo (mentor)
Notes
Notes: svn path=/head/; revision=356147
Diffstat (limited to 'mail/qmail-remove')
-rw-r--r--mail/qmail-remove/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/mail/qmail-remove/Makefile b/mail/qmail-remove/Makefile
index 9e60b0dd0e2d..559e6d067f5a 100644
--- a/mail/qmail-remove/Makefile
+++ b/mail/qmail-remove/Makefile
@@ -3,16 +3,19 @@
PORTNAME= qmail-remove
PORTVERSION= 0.95
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= http://www.linuxmagic.com/opensource/qmail/qmail-remove/
MAINTAINER= ports@FreeBSD.org
COMMENT= Removes messages from your qmail queue based on a particular string
-PLIST_FILES= sbin/qmail-remove bin/populate.pl
+PLIST_FILES= sbin/qmail-remove bin/populate-qmail-queue.pl
PORTDOCS= INSTALL LICENSE README
-NO_STAGE= yes
+USES= shebangfix
+SHEBANG_FILES= populate.pl
+
do-build:
@(cd ${WRKSRC} ;\
${ECHO_MSG} "Compiling ${PORTNAME}:" ; \
@@ -20,12 +23,13 @@ do-build:
${CC} ${CFLAGS} ${LDFLAGS} ${PORTNAME}.c -o ${PORTNAME} )
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/sbin
- @${INSTALL_SCRIPT} ${WRKSRC}/populate.pl ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/sbin
+ @${INSTALL_SCRIPT} ${WRKSRC}/populate.pl \
+ ${STAGEDIR}${PREFIX}/bin/populate-qmail-queue.pl
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
- @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
.endif