aboutsummaryrefslogtreecommitdiff
path: root/mail/qmail-scanner
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2006-01-21 17:37:14 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2006-01-21 17:37:14 +0000
commit01c588a6357d8452a3e0af157e9c1250c067db2f (patch)
treefb26bf418ea8791ab4d308a7931c623124611c3c /mail/qmail-scanner
parentf484c99df79f169bf954fc4b0ed83e59279a596a (diff)
downloadports-01c588a6357d8452a3e0af157e9c1250c067db2f.tar.gz
ports-01c588a6357d8452a3e0af157e9c1250c067db2f.zip
Notes
Diffstat (limited to 'mail/qmail-scanner')
-rw-r--r--mail/qmail-scanner/Makefile16
-rw-r--r--mail/qmail-scanner/pkg-plist30
2 files changed, 25 insertions, 21 deletions
diff --git a/mail/qmail-scanner/Makefile b/mail/qmail-scanner/Makefile
index 3ce416e540a2..caf6915735ca 100644
--- a/mail/qmail-scanner/Makefile
+++ b/mail/qmail-scanner/Makefile
@@ -7,7 +7,7 @@
PORTNAME= qmail-scanner
PORTVERSION= 1.25
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -17,14 +17,10 @@ EXTRACT_SUFX= .tgz
MAINTAINER= freebsd@simplerezo.com
COMMENT= Content/Anti-virus Scanner for qmail
-BUILD_DEPENDS= ${QMAIL_QUEUE}:${PORTSDIR}/mail/qmail \
- reformime:${PORTSDIR}/mail/maildrop \
+BUILD_DEPENDS= reformime:${PORTSDIR}/mail/maildrop \
${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
-# A normal qmail installation puts everything into /var/qmail/.
-# Must match your qmail installation
-QMAIL_DIR?= /var/qmail
-QMAIL_QUEUE= ${QMAIL_DIR}/bin/qmail-queue
+QMAIL_QUEUE= ${QMAIL_PREFIX}/bin/qmail-queue
USE_PERL5= yes
NO_BUILD= yes
@@ -79,12 +75,14 @@ CONFIGURE_ARGS+= --spams-tosuffix "${QMAILSCAN_SPAMSTOSUFFIX}"
RUN_DEPENDS= ${BUILD_DEPENDS}
+USE_QMAIL= yes
+
SPOOLDIR= ${PREFIX}/qmailscan
PLIST_SUB= SPOOLDIR="${SPOOLDIR:S,${PREFIX}/,,}"
HAS_CONFIGURE= yes
CONFIGURE_ARGS+= \
- --qmaildir "${QMAIL_DIR}" --spooldir "${SPOOLDIR}" \
+ --qmaildir "${QMAIL_PREFIX}" --spooldir "${SPOOLDIR}" \
--bindir "${PREFIX}/bin" --qmail-queue-binary "${QMAIL_QUEUE}" \
--admin "${QMAILSCAN_ADMIN}" --notify "${QMAILSCAN_NOTIFY}" \
--silent-viruses "${QMAILSCAN_SILENTVIRUSES}" \
@@ -137,7 +135,7 @@ pre-configure:
@PKG_PREFIX=${PREFIX} ${SH} ${PKGDIR}/pkg-install ${PKGNAME} PRE-INSTALL
@if ! ${TEST} -f ${QMAIL_QUEUE}; then \
${ECHO_MSG} "Unable to found qmail-queue binary trying '${QMAIL_QUEUE}'."; \
- ${ECHO_MSG} "Please set QMAIL_DIR to your qmail installation directory !"; \
+ ${ECHO_MSG} "Please set QMAIL_PREFIX to your qmail installation directory !"; \
exit 1; \
fi
diff --git a/mail/qmail-scanner/pkg-plist b/mail/qmail-scanner/pkg-plist
index 4eaf88befb04..f7e3018df384 100644
--- a/mail/qmail-scanner/pkg-plist
+++ b/mail/qmail-scanner/pkg-plist
@@ -2,16 +2,22 @@
bin/qmail-scanner-queue.pl
bin/qs2mrtg.pl
share/examples/qs2mrtg/mrtg-qmail-scanner.cfg
+@dirrm share/examples/qs2mrtg
+@unexec if cmp -s %D/%%SPOOLDIR%%/quarantine-attachments.txt %D/%%SPOOLDIR%%/quarantine-attachments.sample; then rm -f %D/%%SPOOLDIR%%/quarantine-attachments.txt && rm -f %D/%%SPOOLDIR%%/quarantine-attachments.db; fi
%%SPOOLDIR%%/quarantine-attachments.sample
-@unexec if cmp -s %%SPOOLDIR%%/quarantine-attachments.txt %%SPOOLDIR%%/quarantine-attachments.sample; then rm -f %%SPOOLDIR%%/quarantine-attachments.txt; fi
-@unexec rmdir share/examples/qs2mrtg 2>/dev/null || true
-@unexec rmdir %%SPOOLDIR%%/archives/cur 2>/dev/null || true
-@unexec rmdir %%SPOOLDIR%%/archives/new 2>/dev/null || true
-@unexec rmdir %%SPOOLDIR%%/archives/tmp 2>/dev/null || true
-@unexec rmdir %%SPOOLDIR%%/archives 2>/dev/null || true
-@unexec rmdir %%SPOOLDIR%%/quarantine/cur 2>/dev/null || true
-@unexec rmdir %%SPOOLDIR%%/quarantine/new 2>/dev/null || true
-@unexec rmdir %%SPOOLDIR%%/quarantine/tmp 2>/dev/null || true
-@unexec rmdir %%SPOOLDIR%%/quarantine 2>/dev/null || true
-@unexec rmdir %%SPOOLDIR%%/tmp 2>/dev/null || true
-@unexec rmdir %%SPOOLDIR%% 2>/dev/null || true
+@exec [ ! -f %D/%%SPOOLDIR%%/quarantine-attachments.txt ] && cp %D/%%SPOOLDIR%%/quarantine-attachments.sample %D/%%SPOOLDIR%%/quarantine-attachments.txt
+%%SPOOLDIR%%/qmail-scanner-queue-version.txt
+@unexec rmdir %D/%%SPOOLDIR%%/archives/cur 2>/dev/null || true
+@unexec rmdir %D/%%SPOOLDIR%%/archives/new 2>/dev/null || true
+@unexec rmdir %D/%%SPOOLDIR%%/archives/tmp 2>/dev/null || true
+@unexec rmdir %D/%%SPOOLDIR%%/archives 2>/dev/null || true
+@unexec rmdir %D/%%SPOOLDIR%%/quarantine/cur 2>/dev/null || true
+@unexec rmdir %D/%%SPOOLDIR%%/quarantine/new 2>/dev/null || true
+@unexec rmdir %D/%%SPOOLDIR%%/quarantine/tmp 2>/dev/null || true
+@unexec rmdir %D/%%SPOOLDIR%%/quarantine 2>/dev/null || true
+@unexec rmdir %D/%%SPOOLDIR%%/working/cur 2>/dev/null || true
+@unexec rmdir %D/%%SPOOLDIR%%/working/new 2>/dev/null || true
+@unexec rmdir %D/%%SPOOLDIR%%/working/tmp 2>/dev/null || true
+@unexec rmdir %D/%%SPOOLDIR%%/working 2>/dev/null || true
+@unexec rmdir %D/%%SPOOLDIR%%/tmp 2>/dev/null || true
+@unexec rmdir %D/%%SPOOLDIR%% 2>/dev/null || true