aboutsummaryrefslogtreecommitdiff
path: root/mail/qmailadmin
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2005-12-15 09:31:32 +0000
committerPeter Pentchev <roam@FreeBSD.org>2005-12-15 09:31:32 +0000
commitfa1627ade51feb9a1aab9adfc4ab8be4a49d63f0 (patch)
tree89490963b4590a1064d925c807bd951250764cdc /mail/qmailadmin
parent5fa8fc1caedce6fc5e4f395d8c9f5dfe5d740d01 (diff)
downloadports-fa1627ade51feb9a1aab9adfc4ab8be4a49d63f0.tar.gz
ports-fa1627ade51feb9a1aab9adfc4ab8be4a49d63f0.zip
Add the VPOPMAIL_DIR knob to specify a different directory where
vpopmail has previously been installed. Bump PORTREVISION. NB: change this with extreme caution! For instance, if vpopmail is not already installed in this directory, building the vpopmail port as a dependency will NOT automatically cause it to be installed there! Requested by: Jan-Erik Moon <jan@1kdigital.com>
Notes
Notes: svn path=/head/; revision=151226
Diffstat (limited to 'mail/qmailadmin')
-rw-r--r--mail/qmailadmin/Makefile15
1 files changed, 12 insertions, 3 deletions
diff --git a/mail/qmailadmin/Makefile b/mail/qmailadmin/Makefile
index 2b4cfb4683d7..61f4ae68916b 100644
--- a/mail/qmailadmin/Makefile
+++ b/mail/qmailadmin/Makefile
@@ -7,6 +7,7 @@
PORTNAME= qmailadmin
PORTVERSION= 1.2.7
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= mail www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
@@ -15,12 +16,20 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= roam@FreeBSD.org
COMMENT= CGI program for administering Qmail with vchkpw/vpopmail
+# vpopmail installation directory
+#
+# NB: change this with extreme caution! For instance, if vpopmail is not
+# already installed in this directory, building the vpopmail port as
+# a dependency will NOT automatically cause it to be installed there!
+
+VPOPMAIL_DIR?= ${LOCALBASE}/vpopmail
+
BUILD_DEPENDS= \
autorespond:${PORTSDIR}/mail/autorespond \
- ${LOCALBASE}/vpopmail/lib/libvpopmail.a:${PORTSDIR}/mail/vpopmail
+ ${VPOPMAIL_DIR}/lib/libvpopmail.a:${PORTSDIR}/mail/vpopmail
RUN_DEPENDS= \
autorespond:${PORTSDIR}/mail/autorespond \
- ${LOCALBASE}/vpopmail/lib/libvpopmail.a:${PORTSDIR}/mail/vpopmail
+ ${VPOPMAIL_DIR}/lib/libvpopmail.a:${PORTSDIR}/mail/vpopmail
.if defined(WITHOUT_IDX)
BUILD_DEPENDS+= ezmlm-send:${PORTSDIR}/mail/ezmlm
@@ -92,7 +101,7 @@ CONFIGURE_ARGS+= \
--enable-htmllibdir=${DATADIR} \
--enable-cgibindir=${PREFIX}/${CGIBINDIR}/${CGIBINSUBDIR} \
--enable-cgipath=${CGIBINURL}/${CGIBINSUBDIR}/qmailadmin \
- --enable-vpopmaildir=${LOCALBASE}/vpopmail \
+ --enable-vpopmaildir=${VPOPMAIL_DIR} \
--enable-autoresponder-path=${LOCALBASE}/bin \
--enable-ezmlmdir=${LOCALBASE}/bin
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}