aboutsummaryrefslogtreecommitdiff
path: root/mail/qsheff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2016-01-25 07:02:51 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2016-01-25 07:02:51 +0000
commit7dbd80dede4be18e66b7be3c31384f43040eebf9 (patch)
tree40e22075448d29cd3d4537f989aa8f8bae2be8ab /mail/qsheff
parenta29a1d7b25183a53fb1332aefbee0b965efed006 (diff)
downloadports-7dbd80dede4be18e66b7be3c31384f43040eebf9.tar.gz
ports-7dbd80dede4be18e66b7be3c31384f43040eebf9.zip
- Unbreak the build on 9.x (against GCC 4.2): it was failing due to -ansi
option passed by default, which does not allow C++-style comments in C source code (Clang is more forgiving): /usr/local/include/clamav.h:170: error: expected identifier or '(' before '/' token /usr/local/include/clamav.h:170: error: stray '#' in program - Really respect CFLAGS by fixing configure script - Do not hardcode DISTVERSION in MASTER_SITES - Do not install COPYING file as part of portdocs: it's installed via LICENSE_FILE already - Convert the port to use option helpers, fix a typo (VIRUSTAGSC -> VIRUSTAG_DESC), wrap overly long lines - Augment port description text while I'm at it
Notes
Notes: svn path=/head/; revision=407194
Diffstat (limited to 'mail/qsheff')
-rw-r--r--mail/qsheff/Makefile106
-rw-r--r--mail/qsheff/pkg-descr25
-rw-r--r--mail/qsheff/pkg-plist1
3 files changed, 57 insertions, 75 deletions
diff --git a/mail/qsheff/Makefile b/mail/qsheff/Makefile
index 8fcad94c2d0a..198cb84240d4 100644
--- a/mail/qsheff/Makefile
+++ b/mail/qsheff/Makefile
@@ -6,7 +6,7 @@ DISTVERSION= 2.1-r3
PORTREVISION= 7
CATEGORIES= mail
MASTER_SITES= http://www.enderunix.org/qsheff/ \
- SF/qsheff/qsheff/II-2.1-r3
+ SF/qsheff/qsheff/II-${DISTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Qmail-queue replacement to filter mail traffic
@@ -17,13 +17,11 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= ${LOCALBASE}/bin/ripmime:${PORTSDIR}/mail/ripmime
RUN_DEPENDS:= ${BUILD_DEPENDS}
-BROKEN_FreeBSD_9= does not build on FreeBSD < 10.x
-
-GNU_CONFIGURE= yes
-
USES= qmail
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-qmaildir=${QMAIL_PREFIX}
-DOCS= README COPYING AUTHORS ChangeLog INSTALL THANKS TODO
+DOCS= README AUTHORS ChangeLog INSTALL THANKS TODO
EXAMPLES= sample-OK.msg sample-SPAM.msg sample-VIRUS.msg
CONTRIB= README qq-custom-error-patch.diff qq-patch.diff \
qsheff-patch.diff
@@ -31,72 +29,52 @@ FILES= handbook.en.txt handbook.tr.txt spamass-qsheff.en.html
ETCFILES= install-wrapper.sh uninstall-wrapper.sh qsheff.attach-default \
qsheff.conf-default qsheff.ignore-default qsheff.rules-default
-CONFIGURE_ARGS+= --with-qmaildir=${QMAIL_PREFIX}
-
-OPTIONS_DEFINE= CLAMAV SPAMTAG VIRUSTAG DISABLELOCAL SYSLOG BACKUP CUSTOMERROR DEBUG DOCS EXAMPLES
+OPTIONS_DEFINE= CLAMAV SPAMTAG VIRUSTAG DISABLELOCAL SYSLOG BACKUP \
+ CUSTOMERROR DEBUG DOCS EXAMPLES
OPTIONS_DEFAULT= CLAMAV
-CLAMAV_DESC= Integrate with Clam AntiVirus
-SPAMTAG_DESC= Spam Tagging
-VIRUSTAGSC= Virus Tagging
-DISABLELOCAL_DESC= Disable Filters For Local Users
-BACKUP_DESC= Logging Incoming/Outgoing Mail
-CUSTOMERROR_DESC= Custom Error Patch
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MCLAMAV}
-RUN_DEPENDS+= ${LOCALBASE}/bin/clamdscan:${PORTSDIR}/security/clamav
-BUILD_DEPENDS+= ${LOCALBASE}/bin/clamdscan:${PORTSDIR}/security/clamav
-CONFIGURE_ARGS+= --with-clamav
-CONFIGURE_ARGS+= --with-clamd-socket=/var/run/clamav/clamd
-.endif
-
-.if ${PORT_OPTIONS:MSPAMTAG}
-CONFIGURE_ARGS+= --enable-spam-tag
-.endif
-
-.if ${PORT_OPTIONS:MVIRUSTAG}
-CONFIGURE_ARGS+= --enable-virus-tag
-.endif
-
-.if ${PORT_OPTIONS:MSYSLOG}
-CONFIGURE_ARGS+= --enable-syslog
-.endif
-
-.if ${PORT_OPTIONS:MDISABLELOCAL}
-CONFIGURE_ARGS+= --disable-local-users
-.endif
-
-.if ${PORT_OPTIONS:MBACKUP}
-CONFIGURE_ARGS+= --enable-backup
-.endif
-
-.if ${PORT_OPTIONS:MCUSTOMERROR}
-CONFIGURE_ARGS+= --enable-custom-error
-.endif
-
-.if ${PORT_OPTIONS:MDEBUG}
-CONFIGURE_ARGS+= --enable-debug
-.endif
+
+CLAMAV_DESC= Integrate with ClamAV
+SPAMTAG_DESC= Spam tagging
+VIRUSTAG_DESC= Virus tagging
+DISABLELOCAL_DESC= Disable filters for local users
+BACKUP_DESC= Logging of incoming/outgoing mail
+CUSTOMERROR_DESC= Custom error patch
+
+CLAMAV_BUILD_DEPENDS= ${LOCALBASE}/bin/clamdscan:${PORTSDIR}/security/clamav
+CLAMAV_RUN_DEPENDS= ${CLAMAV_BUILD_DEPENDS}
+CLAMAV_CONFIGURE_ON= --with-clamav --with-clamd-socket=/var/run/clamav/clamd
+
+SPAMTAG_CONFIGURE_ON= --enable-spam-tag
+VIRUSTAG_CONFIGURE_ON= --enable-virus-tag
+SYSLOG_CONFIGURE_ON= --enable-syslog
+DISABLELOCAL_CONFIGURE_ON=--disable-local-users
+BACKUP_CONFIGURE_ON= --enable-backup
+CUSTOMERROR_CONFIGURE_ON=--enable-custom-error
+DEBUG_CONFIGURE_ON= --enable-debug
post-patch:
- @${REINPLACE_CMD} -e "s|^CFLAGS =|CFLAGS +=|" ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e '/^CFLAGS=""/d' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's/ -ansi//' ${WRKSRC}/src/Makefile.in
-post-build:
-.if ! ${PORT_OPTIONS:MCLAMAV}
- @${REINPLACE_CMD} -e 's|enable_virus_prog = 1|enable_virus_prog = 0|g' \
+post-build-CLAMAV-off:
+ @${REINPLACE_CMD} -e '/enable_clamd/s|1|0|' \
${WRKSRC}/etc/qsheff.conf-default
-.endif
do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/qsheff ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${ETCDIR}
+ ${INSTALL_DATA} ${ETCFILES:S,^,${WRKSRC}/etc/,} ${STAGEDIR}${ETCDIR}
+
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}/doc
- ${INSTALL_DATA} ${DOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}/
- ${INSTALL_DATA} ${FILES:S,^,${WRKSRC}/doc/,} ${STAGEDIR}${DOCSDIR}/doc/
+ ${INSTALL_DATA} ${DOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${FILES:S,^,${WRKSRC}/doc/,} ${STAGEDIR}${DOCSDIR}/doc
+
+do-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/contrib
- ${INSTALL_DATA} ${EXAMPLES:S,^,${WRKSRC}/samples/,} ${STAGEDIR}${EXAMPLESDIR}/
- ${INSTALL_DATA} ${CONTRIB:S,^,${WRKSRC}/contrib/,} ${STAGEDIR}${EXAMPLESDIR}/contrib
- @${MKDIR} ${STAGEDIR}${ETCDIR}
- ${INSTALL_DATA} ${ETCFILES:S,^,${WRKSRC}/etc/,} ${STAGEDIR}${ETCDIR}/
- ${INSTALL_PROGRAM} ${WRKSRC}/src/qsheff ${STAGEDIR}${PREFIX}/bin/qsheff
+ ${INSTALL_DATA} ${EXAMPLES:S,^,${WRKSRC}/samples/,} \
+ ${STAGEDIR}${EXAMPLESDIR}/
+ ${INSTALL_DATA} ${CONTRIB:S,^,${WRKSRC}/contrib/,} \
+ ${STAGEDIR}${EXAMPLESDIR}/contrib
.include <bsd.port.mk>
diff --git a/mail/qsheff/pkg-descr b/mail/qsheff/pkg-descr
index 3b3c5e84fca2..ee2bdbbc0914 100644
--- a/mail/qsheff/pkg-descr
+++ b/mail/qsheff/pkg-descr
@@ -1,11 +1,16 @@
-A qmail-queue replacement to filter mail traffic and more.
-It supports:
- * Antivirus executing
- * body filtering
- * subject filtering
- * attachment blocking
- * quarantine
- * white/black list
- * single line logging for qmail and many features.
+qSheff is a wrapper for the qmail queue that scans email for viruses and
+spam. Infected messages are rejected before they reach the queue, so the
+server doesn't perform any job for them. After checking the message, it
+will wake the qmail queue. Some of the supported features:
-WWW: http://www.enderunix.org/qsheff
+ - Antivirus executing (ClamAV)
+ - Header and body filtering
+ - Subject filtering
+ - Attachment blocking
+ - Quarantine support
+ - White/black lists
+ - Single line logging for qmail
+ - Basic DoS attack prevention
+ - And much more...
+
+WWW: http://www.enderunix.org/qsheff/
diff --git a/mail/qsheff/pkg-plist b/mail/qsheff/pkg-plist
index 997e45e1d79d..387a01fc8b9e 100644
--- a/mail/qsheff/pkg-plist
+++ b/mail/qsheff/pkg-plist
@@ -13,7 +13,6 @@ bin/qsheff
%%ETCDIR%%/install-wrapper.sh
%%ETCDIR%%/uninstall-wrapper.sh
%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/INSTALL