aboutsummaryrefslogtreecommitdiff
path: root/mail/qtools/Makefile
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2014-04-03 01:36:21 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2014-04-03 01:36:21 +0000
commitd2d3ffa1cf595529f520f35b9ce0e88a8e8e9d8e (patch)
tree4645d9277c5ff829635a2322ac177f4eb0894880 /mail/qtools/Makefile
parentb3b307ce17e57aa778e952488e11401af3ac82d6 (diff)
downloadports-d2d3ffa1cf595529f520f35b9ce0e88a8e8e9d8e.tar.gz
ports-d2d3ffa1cf595529f520f35b9ce0e88a8e8e9d8e.zip
Notes
Diffstat (limited to 'mail/qtools/Makefile')
-rw-r--r--mail/qtools/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/mail/qtools/Makefile b/mail/qtools/Makefile
index b0725d719e62..2d22afb8c65b 100644
--- a/mail/qtools/Makefile
+++ b/mail/qtools/Makefile
@@ -13,9 +13,8 @@ COMMENT= Tools to use in .qmail files
RUN_DEPENDS= ${EZMLM_DIR}/bin/ezmlm-weed:${PORTSDIR}/mail/ezmlm
USES= qmail:vars
-NO_STAGE= yes
-ALL_TARGET= it
+ALL_TARGET= prog
INSTALL_TARGET= setup check
RESTRICTED= Possibly restricted binary distribution of modified versions
@@ -32,4 +31,14 @@ do-configure:
@${ECHO_CMD} "${QMAIL_PREFIX}" > ${WRKSRC}/conf-qmail
@${ECHO_CMD} "${EZMLM_DIR}/bin/ezmlm" > ${WRKSRC}/conf-ezmlm
+# Do a dance to stage and keep out of resulting binaries (see r346769
+# and r349241)
+pre-install:
+ @${MV} -f ${WRKSRC}/conf-home ${WRKSRC}/conf-home.sav
+ @${ECHO_CMD} "${STAGEDIR}${PREFIX}" > ${WRKSRC}/conf-home
+ @cd ${WRKSRC} ; ${RM} -f install instcheck install.o instcheck.o hier.o auto_home.o
+ @cd ${WRKSRC} ; ${MAKE_CMD} install instcheck
+ @${TOUCH} ${WRKSRC}/replier-config
+ @${MV} -f ${WRKSRC}/conf-home.sav ${WRKSRC}/conf-home
+
.include <bsd.port.mk>