aboutsummaryrefslogtreecommitdiff
path: root/mail/queue-fix
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2013-09-14 15:33:03 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2013-09-14 15:33:03 +0000
commit20e947a006da27244f9f9d19a4dc6aa28d27f9d9 (patch)
tree373edc885f33f515e038b5cb547a72a431a87693 /mail/queue-fix
parent7a490201e89b2c49a4496be941eaaa510342d0a9 (diff)
downloadports-20e947a006da27244f9f9d19a4dc6aa28d27f9d9.tar.gz
ports-20e947a006da27244f9f9d19a4dc6aa28d27f9d9.zip
- Fix build on head without gcc
Reported by: pkg-fallout
Notes
Notes: svn path=/head/; revision=327295
Diffstat (limited to 'mail/queue-fix')
-rw-r--r--mail/queue-fix/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/mail/queue-fix/Makefile b/mail/queue-fix/Makefile
index 89585e38618d..114a4d82dd67 100644
--- a/mail/queue-fix/Makefile
+++ b/mail/queue-fix/Makefile
@@ -41,6 +41,10 @@ PATCHFILES+= queue-fix-todo.patch
PATCH_DIST_STRIP+= -p1
.endif
+post-patch:
+ ${ECHO_CMD} "${CC} ${CFLAGS}" > ${WRKSRC}/conf-cc
+ ${ECHO_CMD} "${CC} ${STRIP} ${LDFLAGS}" > ${WRKSRC}/conf-ld
+
do-install:
@${MKDIR} ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/queue-fix ${PREFIX}/bin