aboutsummaryrefslogtreecommitdiff
path: root/mail/queue-repair
diff options
context:
space:
mode:
authorNeil Blakey-Milner <nbm@FreeBSD.org>2002-10-08 14:19:44 +0000
committerNeil Blakey-Milner <nbm@FreeBSD.org>2002-10-08 14:19:44 +0000
commitb18c0056d8f2874c85e6ded2e45a4b8a47121d34 (patch)
tree4416b3e39475c3e42c1f3640c4d99c01a08b3ebc /mail/queue-repair
parent4173c41acee38ae91c2aa218e4be1d5b6d1d453a (diff)
downloadports-b18c0056d8f2874c85e6ded2e45a4b8a47121d34.tar.gz
ports-b18c0056d8f2874c85e6ded2e45a4b8a47121d34.zip
Add queue-repair 0.8.6, a qmail queue diagnostic and repair tool.
PR: 41889 Submitted by: Sergei Kolobov <sergei@kolobov.com>
Notes
Notes: svn path=/head/; revision=67643
Diffstat (limited to 'mail/queue-repair')
-rw-r--r--mail/queue-repair/Makefile33
-rw-r--r--mail/queue-repair/distinfo1
-rw-r--r--mail/queue-repair/pkg-comment1
-rw-r--r--mail/queue-repair/pkg-descr19
-rw-r--r--mail/queue-repair/pkg-plist7
5 files changed, 61 insertions, 0 deletions
diff --git a/mail/queue-repair/Makefile b/mail/queue-repair/Makefile
new file mode 100644
index 000000000000..3968684716d8
--- /dev/null
+++ b/mail/queue-repair/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: queue-repair
+# Date created: 22 Aug 2002
+# Whom: Sergei Kolobov <sergei@kolobov.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= queue-repair
+PORTVERSION= 0.8.6
+CATEGORIES= mail python
+MASTER_SITES= http://www.qcc.ca/~charlesc/software/queue_repair/
+
+MAINTAINER= sergei@kolobov.com
+
+USE_PYTHON= yes
+USE_REINPLACE= yes
+
+DOCS= BLURB CHANGELOG COPYING TODO docs.txt
+
+do-build:
+ ${REINPLACE_CMD} -e 's,^#!/usr/bin/python,#!${PYTHON_CMD},' \
+ ${WRKSRC}/queue_repair.py
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/queue_repair.py ${PREFIX}/bin/queue-repair
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for file in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/mail/queue-repair/distinfo b/mail/queue-repair/distinfo
new file mode 100644
index 000000000000..ce86d1d9f727
--- /dev/null
+++ b/mail/queue-repair/distinfo
@@ -0,0 +1 @@
+MD5 (queue-repair-0.8.6.tar.gz) = 257734fdbdd2315448198bfe7e063a1c
diff --git a/mail/queue-repair/pkg-comment b/mail/queue-repair/pkg-comment
new file mode 100644
index 000000000000..30fe719ce7a5
--- /dev/null
+++ b/mail/queue-repair/pkg-comment
@@ -0,0 +1 @@
+A qmail queue diagnostic and repair tool
diff --git a/mail/queue-repair/pkg-descr b/mail/queue-repair/pkg-descr
new file mode 100644
index 000000000000..f9af281c9fca
--- /dev/null
+++ b/mail/queue-repair/pkg-descr
@@ -0,0 +1,19 @@
+queue_repair features include:
+- automatic, dynamic determination of UIDs and GIDs.
+
+- automatic, dynamic determination of conf-split; can be overridden on the
+ commandline to change the conf-split of an existing queue without running a
+ parallel, temporary instance of qmail for queuelifetime. Just recompile and
+ stop qmail, run queue-repair, and restart qmail.
+
+- automatic, dynamic determination of use of big-todo; can be overridden on the
+ commandline to change an existing queue as above.
+
+- handles basic tasks like fixing a queue restored from backups, incorrect
+ ownership or permissions of directories and files, missing or extra split
+ subdirectories, unexpected files or other direntries, or creating a valid
+ queue from scratch.
+
+- can run in repair or test (report-only) modes. The default is test mode.
+
+WWW: http://www.qcc.ca/~charlesc/software/queue_repair/
diff --git a/mail/queue-repair/pkg-plist b/mail/queue-repair/pkg-plist
new file mode 100644
index 000000000000..db516b0aa207
--- /dev/null
+++ b/mail/queue-repair/pkg-plist
@@ -0,0 +1,7 @@
+bin/queue-repair
+%%PORTDOCS%%share/doc/queue-repair/BLURB
+%%PORTDOCS%%share/doc/queue-repair/CHANGELOG
+%%PORTDOCS%%share/doc/queue-repair/COPYING
+%%PORTDOCS%%share/doc/queue-repair/TODO
+%%PORTDOCS%%share/doc/queue-repair/docs.txt
+%%PORTDOCS%%@dirrm share/doc/queue-repair