aboutsummaryrefslogtreecommitdiff
path: root/mail/razor-agents
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
committerMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
commiteee58d187e2c55fca6f53b9e482d33cf5346fe81 (patch)
tree0d350fe6ad6a2fe3222d838f3c72856c78cd449f /mail/razor-agents
parent3f1df82a16a1e89db9a69b36ade7342f34095ab4 (diff)
downloadports-eee58d187e2c55fca6f53b9e482d33cf5346fe81.tar.gz
ports-eee58d187e2c55fca6f53b9e482d33cf5346fe81.zip
Change the way Perl modules are installed, update the default Perl to 5.18.
Before, we had: site_perl : lib/perl5/site_perl/5.18 site_perl/perl_arch : lib/perl5/site_perl/5.18/mach perl_man3 : lib/perl5/5.18/man/man3 Now we have: site_perl : lib/perl5/site_perl site_arch : lib/perl5/site_perl/mach/5.18 perl_man3 : lib/perl5/site_perl/man/man3 Modules without any .so will be installed at the same place regardless of the Perl version, minimizing the upgrade when the major Perl version is changed. It uses a version dependent directory for modules with compiled bits. As PERL_ARCH is no longer needed in plists, it has been removed from PLIST_SUB. The USE_PERL5=fixpacklist keyword is removed, the .packlist file is now always removed, as is perllocal.pod. The old site_perl and site_perl/arch directories have been kept in the default Perl @INC for all Perl ports, and will be phased out as these old Perl versions expire. PR: 194969 Differential Revision: https://reviews.freebsd.org/D1019 Exp-run by: antoine Reviewed by: perl@ Approved by: portmgr
Notes
Notes: svn path=/head/; revision=373448
Diffstat (limited to 'mail/razor-agents')
-rw-r--r--mail/razor-agents/Makefile1
-rw-r--r--mail/razor-agents/pkg-plist57
2 files changed, 24 insertions, 34 deletions
diff --git a/mail/razor-agents/Makefile b/mail/razor-agents/Makefile
index f6970cfad526..a6dfe2e99006 100644
--- a/mail/razor-agents/Makefile
+++ b/mail/razor-agents/Makefile
@@ -3,6 +3,7 @@
PORTNAME= razor-agents
PORTVERSION= 2.84
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= SF/razor/${PORTNAME}/${PORTVERSION}
diff --git a/mail/razor-agents/pkg-plist b/mail/razor-agents/pkg-plist
index b17ef499fab8..9fb953204757 100644
--- a/mail/razor-agents/pkg-plist
+++ b/mail/razor-agents/pkg-plist
@@ -13,37 +13,26 @@ man/man1/razor-revoke.1.gz
man/man5/razor-agent.conf.5.gz
man/man5/razor-agents.5.gz
man/man5/razor-whitelist.5.gz
-%%SITE_PERL%%/%%PERL_ARCH%%/Razor2/Client/Agent.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/Razor2/Client/Config.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/Razor2/Client/Core.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/Razor2/Client/Engine.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/Razor2/Client/Version.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/Razor2/Engine/VR8.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/Razor2/Errorhandler.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/Razor2/Logger.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/Razor2/Preproc/Manager.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/Razor2/Preproc/deBase64.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/Razor2/Preproc/deHTML.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/Razor2/Preproc/deHTML_comment.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/Razor2/Preproc/deHTMLxs.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/Razor2/Preproc/deNewline.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/Razor2/Preproc/deQP.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/Razor2/Preproc/enBase64.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/Razor2/Signature/Ephemeral.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/Razor2/Signature/Whiplash.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/Razor2/String.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/Razor2/Syslog.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Razor2/Preproc/deHTMLxs/autosplit.ix
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Razor2/Preproc/deHTMLxs/deHTMLxs.so
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Razor2/Syslog/autosplit.ix
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/razor-agents/.packlist
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Razor2/Client
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Razor2/Preproc
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Razor2/Signature
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Razor2/Engine
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Razor2
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Razor2/Preproc/deHTMLxs
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Razor2/Preproc
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Razor2/Syslog
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Razor2
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/razor-agents
+%%SITE_ARCH%%/Razor2/Client/Agent.pm
+%%SITE_ARCH%%/Razor2/Client/Config.pm
+%%SITE_ARCH%%/Razor2/Client/Core.pm
+%%SITE_ARCH%%/Razor2/Client/Engine.pm
+%%SITE_ARCH%%/Razor2/Client/Version.pm
+%%SITE_ARCH%%/Razor2/Engine/VR8.pm
+%%SITE_ARCH%%/Razor2/Errorhandler.pm
+%%SITE_ARCH%%/Razor2/Logger.pm
+%%SITE_ARCH%%/Razor2/Preproc/Manager.pm
+%%SITE_ARCH%%/Razor2/Preproc/deBase64.pm
+%%SITE_ARCH%%/Razor2/Preproc/deHTML.pm
+%%SITE_ARCH%%/Razor2/Preproc/deHTML_comment.pm
+%%SITE_ARCH%%/Razor2/Preproc/deHTMLxs.pm
+%%SITE_ARCH%%/Razor2/Preproc/deNewline.pm
+%%SITE_ARCH%%/Razor2/Preproc/deQP.pm
+%%SITE_ARCH%%/Razor2/Preproc/enBase64.pm
+%%SITE_ARCH%%/Razor2/Signature/Ephemeral.pm
+%%SITE_ARCH%%/Razor2/Signature/Whiplash.pm
+%%SITE_ARCH%%/Razor2/String.pm
+%%SITE_ARCH%%/Razor2/Syslog.pm
+%%SITE_ARCH%%/auto/Razor2/Preproc/deHTMLxs/autosplit.ix
+%%SITE_ARCH%%/auto/Razor2/Preproc/deHTMLxs/deHTMLxs.so
+%%SITE_ARCH%%/auto/Razor2/Syslog/autosplit.ix