aboutsummaryrefslogtreecommitdiff
path: root/mail/roundcube-veximaccountadmin/Makefile
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2012-11-03 13:34:05 +0000
committerSteve Wills <swills@FreeBSD.org>2012-11-03 13:34:05 +0000
commit380799393923163a6e438e566a42ceca4a5cebc5 (patch)
treed04dd0986b3815ec2de78539e109c2c57322ddd5 /mail/roundcube-veximaccountadmin/Makefile
parentd9e422f244d1e0943ebb61f25f9d5a132a8e4234 (diff)
downloadports-380799393923163a6e438e566a42ceca4a5cebc5.tar.gz
ports-380799393923163a6e438e566a42ceca4a5cebc5.zip
Notes
Diffstat (limited to 'mail/roundcube-veximaccountadmin/Makefile')
-rw-r--r--mail/roundcube-veximaccountadmin/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/mail/roundcube-veximaccountadmin/Makefile b/mail/roundcube-veximaccountadmin/Makefile
new file mode 100644
index 000000000000..2dccca4e92f2
--- /dev/null
+++ b/mail/roundcube-veximaccountadmin/Makefile
@@ -0,0 +1,36 @@
+# Created by: Mark Felder <feld@feld.me>
+# $FreeBSD$
+
+PORTNAME= veximaccountadmin
+PORTVERSION= 0.1
+CATEGORIES= mail
+MASTER_SITES= http://axel.sjostedt.no/misc/files/
+PKGNAMEPREFIX= roundcube-
+DISTNAME= rcube_plg_veximaccountadmin
+
+MAINTAINER= feld@feld.me
+COMMENT= Roundcube vexim account admin plugin
+
+LICENSE= GPLv3
+
+RUN_DEPENDS= roundcube>=0.5:${PORTSDIR}/mail/roundcube
+
+NO_BUILD= yes
+
+WWWDIR= ${PREFIX}/www/roundcube/plugins/veximaccountadmin
+WRKSRC= ${WRKDIR}/veximaccountadmin
+
+# This target is only meant to be used by the port maintainer.
+x-generate-plist: build
+ cd ${WRKSRC}; \
+ ${FIND} . ! -type d ! -name '*.orig' | ${SORT} | \
+ ${SED} -e "s,^\.,%%WWWDIR%%," >${.CURDIR}/pkg-plist.tmp ; \
+ ${FIND} . -type d | ${SORT} -r | ${SED} \
+ -e "s,^\.$$,@dirrmtry %%WWWDIR%%," \
+ -e "s,^\.,@dirrm %%WWWDIR%%," >>${.CURDIR}/pkg-plist.tmp
+
+do-install:
+ ${MKDIR} ${WWWDIR}
+ cd ${WRKSRC} && ${PAX} -r -w . ${WWWDIR}
+
+.include <bsd.port.mk>