aboutsummaryrefslogtreecommitdiff
path: root/mail/roundcube-yubikey_auth
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2018-07-27 05:14:51 +0000
committerKurt Jaeger <pi@FreeBSD.org>2018-07-27 05:14:51 +0000
commit216f0758fa0fc1d50df6aaf87ffb5a0d6c415e81 (patch)
tree42bafa53119dcedd9fc10021870b96479e098c93 /mail/roundcube-yubikey_auth
parent38f2aea3466335c2496e7bcba270cadd5309c62a (diff)
downloadports-216f0758fa0fc1d50df6aaf87ffb5a0d6c415e81.tar.gz
ports-216f0758fa0fc1d50df6aaf87ffb5a0d6c415e81.zip
New port: mail/roundcube-yubikey_auth
This plugin adds the option to use a YubiKey as second-factor authentication. The YubiKey is a USB key emulating a generic keyboard and make use of One-time Passwords to provide two factor authentication. Activate the plugin by adding the following to Roundcube's config/config.inc.php: $config['plugins'] = array('roundcube_yubikey_authentication'); WWW: https://github.com/northox/roundcube-yubikey-plugin PR: 222318 Submitted by: Vidar Karlsen <vidar@karlsen.tech>
Notes
Notes: svn path=/head/; revision=475412
Diffstat (limited to 'mail/roundcube-yubikey_auth')
-rw-r--r--mail/roundcube-yubikey_auth/Makefile46
-rw-r--r--mail/roundcube-yubikey_auth/distinfo3
-rw-r--r--mail/roundcube-yubikey_auth/pkg-descr11
-rw-r--r--mail/roundcube-yubikey_auth/pkg-plist11
4 files changed, 71 insertions, 0 deletions
diff --git a/mail/roundcube-yubikey_auth/Makefile b/mail/roundcube-yubikey_auth/Makefile
new file mode 100644
index 000000000000..acbe244651c5
--- /dev/null
+++ b/mail/roundcube-yubikey_auth/Makefile
@@ -0,0 +1,46 @@
+# Created by: Vidar Karlsen <vidar@karlsen.tech>
+# $FreeBSD$
+
+PORTNAME= yubikey_auth
+PORTVERSION= g20180404
+CATEGORIES= mail
+PKGNAMEPREFIX= roundcube-
+PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
+
+MAINTAINER= vidar@karlsen.tech
+COMMENT= Roundcube yubikey auth plugin
+
+LICENSE= GPLv2
+
+BUILD_DEPENDS= roundcube${PHP_PKGNAMESUFFIX}>=1.0:mail/roundcube@${PHP_FLAVOR}
+RUN_DEPENDS= roundcube${PHP_PKGNAMESUFFIX}>=1.0:mail/roundcube@${PHP_FLAVOR}
+
+USES= php:flavors
+
+USE_PHP= curl
+
+USE_GITHUB= yes
+GH_ACCOUNT= northox
+GH_PROJECT= roundcube-yubikey-plugin
+GH_TAGNAME= 383bbb3
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+WWWDIR= ${PREFIX}/www/roundcube/plugins/roundcube_yubikey_authentication
+
+post-patch:
+ ${REINPLACE_CMD} -e 's/roundcube_yubikey_plugin/YubiKey OTP/g' \
+ ${WRKSRC}/yubikey.js
+ ${REINPLACE_CMD} \
+ -e "s/array('yubikey_authentication')/array('roundcube_yubikey_authentication')/g" \
+ -e 's,plugins/yubikey_authentication,plugins/roundcube_yubikey_authentication,g' \
+ ${WRKSRC}/README.md
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${WWWDIR}
+ cd ${WRKSRC} && ${PAX} -r -w . ${STAGEDIR}${WWWDIR}
+ cd ${STAGEDIR}${WWWDIR} && \
+ ${MV} config.inc.php config.inc.php.sample
+
+.include <bsd.port.mk>
diff --git a/mail/roundcube-yubikey_auth/distinfo b/mail/roundcube-yubikey_auth/distinfo
new file mode 100644
index 000000000000..639ecfff1283
--- /dev/null
+++ b/mail/roundcube-yubikey_auth/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1532637571
+SHA256 (northox-roundcube-yubikey-plugin-g20180404-383bbb3_GH0.tar.gz) = 48cd088db1058ae3c416576f73e369e20c2384bc81c78b118cb5f13efe4adc2c
+SIZE (northox-roundcube-yubikey-plugin-g20180404-383bbb3_GH0.tar.gz) = 14111
diff --git a/mail/roundcube-yubikey_auth/pkg-descr b/mail/roundcube-yubikey_auth/pkg-descr
new file mode 100644
index 000000000000..7f95e61b10cf
--- /dev/null
+++ b/mail/roundcube-yubikey_auth/pkg-descr
@@ -0,0 +1,11 @@
+This plugin adds the option to use a YubiKey as second-factor
+authentication.
+
+The YubiKey is a USB key emulating a generic keyboard and make
+use of One-time Passwords to provide two factor authentication.
+
+Activate the plugin by adding the following to Roundcube's
+config/config.inc.php:
+$config['plugins'] = array('roundcube_yubikey_authentication');
+
+WWW: https://github.com/northox/roundcube-yubikey-plugin
diff --git a/mail/roundcube-yubikey_auth/pkg-plist b/mail/roundcube-yubikey_auth/pkg-plist
new file mode 100644
index 000000000000..5fec8e257f42
--- /dev/null
+++ b/mail/roundcube-yubikey_auth/pkg-plist
@@ -0,0 +1,11 @@
+%%WWWDIR%%/LICENSE
+%%WWWDIR%%/README.md
+%%WWWDIR%%/composer.json
+@sample %%WWWDIR%%/config.inc.php.sample
+%%WWWDIR%%/lib/Yubico.php
+%%WWWDIR%%/localization/cs_CZ.inc
+%%WWWDIR%%/localization/de_DE.inc
+%%WWWDIR%%/localization/en_US.inc
+%%WWWDIR%%/localization/fr_FR.inc
+%%WWWDIR%%/yubikey.js
+%%WWWDIR%%/roundcube_yubikey_authentication.php