aboutsummaryrefslogtreecommitdiff
path: root/mail/roundcube
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2015-02-19 16:12:49 +0000
committerAlex Dupre <ale@FreeBSD.org>2015-02-19 16:12:49 +0000
commit35ea321822a04db9011e8b6f800cbee3638c4195 (patch)
tree1256ea930f08c477e418e47776638a48b73e2d42 /mail/roundcube
parentc73a7391d6f48ab205d1996de53195dbf13ceaa5 (diff)
downloadports-35ea321822a04db9011e8b6f800cbee3638c4195.tar.gz
ports-35ea321822a04db9011e8b6f800cbee3638c4195.zip
Update to 1.1.0 release.
Notes
Notes: svn path=/head/; revision=379350
Diffstat (limited to 'mail/roundcube')
-rw-r--r--mail/roundcube/Makefile7
-rw-r--r--mail/roundcube/distinfo4
-rw-r--r--mail/roundcube/files/patch-INSTALL12
-rw-r--r--mail/roundcube/files/patch-program_lib_Roundcube_rcube_session.php26
4 files changed, 25 insertions, 24 deletions
diff --git a/mail/roundcube/Makefile b/mail/roundcube/Makefile
index b8c589963b35..1857ca6635ed 100644
--- a/mail/roundcube/Makefile
+++ b/mail/roundcube/Makefile
@@ -1,11 +1,11 @@
# $FreeBSD$
PORTNAME= roundcube
-DISTVERSION= 1.0.5
+DISTVERSION= 1.1.0
PORTEPOCH= 1
CATEGORIES?= mail www
MASTER_SITES= SF/${PORTNAME}mail/${PORTNAME}mail/${DISTVERSION:tu}
-DISTNAME= ${PORTNAME}mail-${DISTVERSION}
+DISTNAME= ${PORTNAME}mail-${DISTVERSION}-complete
MAINTAINER?= ale@FreeBSD.org
COMMENT= Fully skinnable XHTML/CSS webmail written in PHP
@@ -13,8 +13,9 @@ COMMENT= Fully skinnable XHTML/CSS webmail written in PHP
LICENSE= GPLv3
NO_BUILD= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}mail-${DISTVERSION}
-RCUBECOMP= SQL config index.php installer logs plugins program robots.txt skins temp
+RCUBECOMP= SQL config index.php installer logs plugins program robots.txt skins temp vendor
PORTDOCS= CHANGELOG INSTALL README.md UPGRADING
WANT_PHP_WEB= yes
diff --git a/mail/roundcube/distinfo b/mail/roundcube/distinfo
index 65ce7476f04f..336454cc49a9 100644
--- a/mail/roundcube/distinfo
+++ b/mail/roundcube/distinfo
@@ -1,2 +1,2 @@
-SHA256 (roundcubemail-1.0.5.tar.gz) = 22af84480f2c543884b17c9b0196ed105d2ea7f429bfcc34a6fb7c96dd712792
-SIZE (roundcubemail-1.0.5.tar.gz) = 4056852
+SHA256 (roundcubemail-1.1.0-complete.tar.gz) = e5d85967348263661f31a56e07ee8a91e973e1f13ee552fd5ed42432aedb120d
+SIZE (roundcubemail-1.1.0-complete.tar.gz) = 4570117
diff --git a/mail/roundcube/files/patch-INSTALL b/mail/roundcube/files/patch-INSTALL
index b56d02d04f54..38f27df0aded 100644
--- a/mail/roundcube/files/patch-INSTALL
+++ b/mail/roundcube/files/patch-INSTALL
@@ -1,10 +1,10 @@
---- INSTALL.orig 2010-12-13 17:37:36.000000000 +0100
-+++ INSTALL 2010-12-13 17:37:44.000000000 +0100
-@@ -25,7 +25,6 @@
+--- INSTALL.orig 2015-02-08 13:43:29.000000000 +0000
++++ INSTALL 2015-02-19 12:22:34.259436291 +0000
+@@ -29,7 +29,6 @@
+ - memory_limit > 16MB (increase as suitable to support large attachments)
- file_uploads enabled (for attachment upload features)
- session.auto_start disabled
- - zend.ze1_compatibility_mode disabled
- - suhosin.session.encrypt disabled
- mbstring.func_overload disabled
- * PHP compiled with OpenSSL to connect to IMAPS and to use the spell checker
- * A MySQL (4.0.8 or newer), PostgreSQL, MSSQL database engine
+ - magic_quotes_runtime disabled
+ - magic_quotes_sybase disabled
diff --git a/mail/roundcube/files/patch-program_lib_Roundcube_rcube_session.php b/mail/roundcube/files/patch-program_lib_Roundcube_rcube_session.php
index 3ead718ea678..e54cc724572e 100644
--- a/mail/roundcube/files/patch-program_lib_Roundcube_rcube_session.php
+++ b/mail/roundcube/files/patch-program_lib_Roundcube_rcube_session.php
@@ -1,5 +1,5 @@
---- program/lib/Roundcube/rcube_session.php.orig 2014-04-06 14:13:10.000000000 +0000
-+++ program/lib/Roundcube/rcube_session.php 2014-04-10 09:21:36.955091803 +0000
+--- program/lib/Roundcube/rcube_session.php.orig 2015-02-08 13:43:28.000000000 +0000
++++ program/lib/Roundcube/rcube_session.php 2015-02-19 13:43:29.477065794 +0000
@@ -35,7 +35,6 @@
private $time_diff = 0;
private $reloaded = false;
@@ -8,7 +8,7 @@
private $gc_handlers = array();
private $cookiename = 'roundcube_sessauth';
private $vars;
-@@ -176,7 +175,7 @@
+@@ -184,7 +183,7 @@
$this->time_diff = time() - strtotime($sql_arr['ts']);
$this->changed = strtotime($sql_arr['changed']);
$this->ip = $sql_arr['ip'];
@@ -17,7 +17,7 @@
$this->key = $key;
return !empty($this->vars) ? (string) $this->vars : '';
-@@ -214,12 +213,12 @@
+@@ -224,12 +223,12 @@
}
if ($oldvars !== null) {
@@ -25,23 +25,23 @@
+ $newvars = $vars;
if ($newvars !== $oldvars) {
- $this->db->query("UPDATE $table "
- . "SET changed = $now, vars = ? WHERE sess_id = ?",
+ $this->db->query("UPDATE {$this->table_name} "
+ . "SET `changed` = $now, `vars` = ? WHERE `sess_id` = ?",
- base64_encode($newvars), $key);
+ $newvars, $key);
}
else if ($ts - $this->changed + $this->time_diff > $this->lifetime / 2) {
- $this->db->query("UPDATE $table SET changed = $now"
-@@ -229,7 +228,7 @@
- else {
- $this->db->query("INSERT INTO $table (sess_id, vars, ip, created, changed)"
+ $this->db->query("UPDATE {$this->table_name} SET `changed` = $now"
+@@ -240,7 +239,7 @@
+ $this->db->query("INSERT INTO {$this->table_name}"
+ . " (`sess_id`, `vars`, `ip`, `created`, `changed`)"
. " VALUES (?, ?, ?, $now, $now)",
- $key, base64_encode($vars), (string)$this->ip);
+ $key, $vars, (string)$this->ip);
}
return true;
-@@ -237,40 +236,6 @@
+@@ -248,40 +247,6 @@
/**
@@ -82,7 +82,7 @@
* Handler for session_destroy()
*
* @param string Session ID
-@@ -332,7 +297,7 @@
+@@ -342,7 +307,7 @@
else // else read data again
$oldvars = $this->mc_read($key);
@@ -91,7 +91,7 @@
if ($newvars !== $oldvars || $ts - $this->changed > $this->lifetime / 3) {
return $this->memcache->set($key, serialize(array('changed' => time(), 'ip' => $this->ip, 'vars' => $newvars)),
-@@ -470,8 +435,6 @@
+@@ -480,8 +445,6 @@
return $this->destroy(session_id());
}