aboutsummaryrefslogtreecommitdiff
path: root/mail/rspamd/files
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@FreeBSD.org>2015-09-21 13:24:24 +0000
committerVsevolod Stakhov <vsevolod@FreeBSD.org>2015-09-21 13:24:24 +0000
commit1c94ac5149393a5d41943c75e0be60c3c131d8da (patch)
tree4cb5565f6659996153be84eae6efc5c33df547e7 /mail/rspamd/files
parent7537f9bef042a7e9f34f21a5b1ada7278513d37a (diff)
downloadports-1c94ac5149393a5d41943c75e0be60c3c131d8da.tar.gz
ports-1c94ac5149393a5d41943c75e0be60c3c131d8da.zip
Notes
Diffstat (limited to 'mail/rspamd/files')
-rw-r--r--mail/rspamd/files/patch-CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/mail/rspamd/files/patch-CMakeLists.txt b/mail/rspamd/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..2ec964da1760
--- /dev/null
+++ b/mail/rspamd/files/patch-CMakeLists.txt
@@ -0,0 +1,29 @@
+--- ./CMakeLists.txt.orig 2015-09-01 16:28:36.000000000 +0300
++++ ./CMakeLists.txt 2015-09-21 14:10:42.046330451 +0300
+@@ -1042,6 +1042,19 @@
+ ENDIF(WANT_SYSTEMD_UNITS MATCHES "ON")
+ IF(BUILD_PORT)
+ INSTALL_IF_NOT_EXISTS(${MAIN_CONF} ${CONFDIR} "rspamd.conf" ".sample")
++ INSTALL_IF_NOT_EXISTS("conf/common.conf" ${CONFDIR} "common.conf" ".sample")
++ INSTALL_IF_NOT_EXISTS("conf/logging.inc" ${CONFDIR} "logging.inc" ".sample")
++ INSTALL_IF_NOT_EXISTS("conf/options.inc" ${CONFDIR} "options.inc" ".sample")
++ INSTALL_IF_NOT_EXISTS("conf/worker-controller.inc" ${CONFDIR} "worker-controller.inc" ".sample")
++ INSTALL_IF_NOT_EXISTS("conf/worker-normal.inc" ${CONFDIR} "worker-normal.inc" ".sample")
++ INSTALL_IF_NOT_EXISTS("conf/2tld.inc" ${CONFDIR} "2tld.inc" ".sample")
++ INSTALL_IF_NOT_EXISTS("conf/composites.conf" ${CONFDIR} "composites.conf" ".sample")
++ INSTALL_IF_NOT_EXISTS("conf/metrics.conf" ${CONFDIR} "metrics.conf" ".sample")
++ INSTALL_IF_NOT_EXISTS("conf/modules.conf" ${CONFDIR} "modules.conf" ".sample")
++ INSTALL_IF_NOT_EXISTS("conf/statistic.conf" ${CONFDIR} "statistic.conf" ".sample")
++ INSTALL_IF_NOT_EXISTS("conf/surbl-whitelist.inc" ${CONFDIR} "surbl-whitelist.inc" ".sample")
++ INSTALL_IF_NOT_EXISTS("conf/dmarc_whitelist.inc" ${CONFDIR} "dmarc_whitelist.inc" ".sample")
++ INSTALL_IF_NOT_EXISTS("conf/spf_dkim_whitelist.inc" ${CONFDIR} "spf_dkim_whitelist.inc" ".sample")
+ ELSE(BUILD_PORT)
+ INSTALL_IF_NOT_EXISTS(${MAIN_CONF} ${CONFDIR} "rspamd.conf" "")
+ ENDIF(BUILD_PORT)
+@@ -1109,4 +1122,4 @@
+ IF(NOT DEBIAN_BUILD)
+ ADD_CUSTOM_TARGET(check DEPENDS rspamd-test)
+ ADD_CUSTOM_TARGET(run-test DEPENDS check COMMAND test/rspamd-test)
+-ENDIF(NOT DEBIAN_BUILD)
+\ No newline at end of file
++ENDIF(NOT DEBIAN_BUILD)