aboutsummaryrefslogtreecommitdiff
path: root/mail/rspamd
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-09-23 16:42:39 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-09-23 16:42:39 +0000
commitd0f02e351c1ac7b840be1e950467605e1d043baf (patch)
tree6bf65d815417f2452f567444a08cdf9788a3b1a1 /mail/rspamd
parent76d4c272f4c9a23c2d1aadd7b2da8d802c3b5021 (diff)
downloadports-d0f02e351c1ac7b840be1e950467605e1d043baf.tar.gz
ports-d0f02e351c1ac7b840be1e950467605e1d043baf.zip
mail/rspamd: fix build on powerpc64 elfv2, switch to luajit-openresty on powerpc64
On powerpc64, binaries with clang and LTO on powerpc64 segfault at start, use GCC instead. Enable luajit using luajit-openresty.
Notes
Notes: svn path=/head/; revision=549747
Diffstat (limited to 'mail/rspamd')
-rw-r--r--mail/rspamd/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/mail/rspamd/Makefile b/mail/rspamd/Makefile
index 001519f96d54..4e42e36758d1 100644
--- a/mail/rspamd/Makefile
+++ b/mail/rspamd/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libpcre.so:devel/pcre \
BUILD_DEPENDS= ragel:devel/ragel
RUN_DEPENDS= ca_root_nss>=3.*:security/ca_root_nss
-USES= cmake compiler:c11 gnome perl5 pkgconfig \
+USES= cmake gnome perl5 pkgconfig \
sqlite ssl
USE_LDCONFIG= yes
USE_PERL5= build run
@@ -34,6 +34,7 @@ OPTIONS_DEFAULT_amd64= LUAJIT
OPTIONS_DEFAULT_armv7= LUAJIT
OPTIONS_DEFAULT_i386= LUAJIT
OPTIONS_DEFAULT_powerpc= LUAJIT
+OPTIONS_DEFAULT_powerpc64= LUAJIT
OPTIONS_SUB= yes
BLAS_DESC= Use OpenBLAS to accelerate KANN
@@ -76,6 +77,15 @@ CGP_RUN_DEPENDS+= \
p5-EV>=0:devel/p5-EV \
p5-JSON-XS>=0:converters/p5-JSON-XS
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == powerpc64
+LUAJIT_LIB_DEPENDS= libluajit-5.1.so:lang/luajit-openresty
+USES+= compiler:gcc-c++11-lib
+.else
+USES+= compiler:c11
+.endif
+
post-install:
@${MKDIR} \
${STAGEDIR}/var/log/rspamd \