aboutsummaryrefslogtreecommitdiff
path: root/mail/rubygem-actionmailbox61
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-01-10 08:50:36 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-01-10 08:50:36 +0000
commit7f083679a48c296ebe34889688e17a932695fc16 (patch)
tree3457cfcf1dbef80f02fe4f9ef5a9d9fb9b130291 /mail/rubygem-actionmailbox61
parent67df02724b3e1c0f594ba49749f92f2cbc2e933b (diff)
downloadports-7f083679a48c296ebe34889688e17a932695fc16.tar.gz
ports-7f083679a48c296ebe34889688e17a932695fc16.zip
Add rubygem-actionmailbox61 6.1.0 (copied from rubygem-actionmailbox60)
Notes
Notes: svn path=/head/; revision=561031
Diffstat (limited to 'mail/rubygem-actionmailbox61')
-rw-r--r--mail/rubygem-actionmailbox61/Makefile30
-rw-r--r--mail/rubygem-actionmailbox61/distinfo3
-rw-r--r--mail/rubygem-actionmailbox61/pkg-descr15
3 files changed, 48 insertions, 0 deletions
diff --git a/mail/rubygem-actionmailbox61/Makefile b/mail/rubygem-actionmailbox61/Makefile
new file mode 100644
index 000000000000..cd89e877d048
--- /dev/null
+++ b/mail/rubygem-actionmailbox61/Makefile
@@ -0,0 +1,30 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= actionmailbox
+PORTVERSION= 6.1.0
+CATEGORIES= mail rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 61
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Receive and process incoming emails in Rails applications
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/MIT-LICENSE
+
+RUN_DEPENDS= rubygem-actionpack61>=${PORTVERSION}:www/rubygem-actionpack61 \
+ rubygem-activejob61>=${PORTVERSION}:devel/rubygem-activejob61 \
+ rubygem-activerecord61>=${PORTVERSION}:databases/rubygem-activerecord61 \
+ rubygem-activestorage61>=${PORTVERSION}:net/rubygem-activestorage61 \
+ rubygem-activesupport61>=${PORTVERSION}:devel/rubygem-activesupport61 \
+ rubygem-mail>=2.7.1,2:mail/rubygem-mail
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+PORTSCOUT= limit:^6\.1\.
+
+.include <bsd.port.mk>
diff --git a/mail/rubygem-actionmailbox61/distinfo b/mail/rubygem-actionmailbox61/distinfo
new file mode 100644
index 000000000000..b857d3a05e7c
--- /dev/null
+++ b/mail/rubygem-actionmailbox61/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1609179780
+SHA256 (rubygem/actionmailbox-6.1.0.gem) = 8e83134721e9659333d7bbf73baf6e2df772660d68b0f7d5504f7a41838a0c93
+SIZE (rubygem/actionmailbox-6.1.0.gem) = 22016
diff --git a/mail/rubygem-actionmailbox61/pkg-descr b/mail/rubygem-actionmailbox61/pkg-descr
new file mode 100644
index 000000000000..3cf8870e8193
--- /dev/null
+++ b/mail/rubygem-actionmailbox61/pkg-descr
@@ -0,0 +1,15 @@
+Action Mailbox routes incoming emails to controller-like mailboxes for
+processing in Rails. It ships with ingresses for Mailgun, Mandrill, Postmark,
+and SendGrid. You can also handle inbound mails directly via the built-in Exim,
+Postfix, and Qmail ingresses.
+
+The inbound emails are turned into InboundEmail records using Active Record and
+feature lifecycle tracking, storage of the original email on cloud storage via
+Active Storage, and responsible data handling with on-by-default incineration.
+
+These inbound emails are routed asynchronously using Active Job to one or
+several dedicated mailboxes, which are capable of interacting directly with the
+rest of your domain model.
+
+WWW: https://rubyonrails.org/
+WWW: https://github.com/rails/rails/tree/master/actionmailbox