aboutsummaryrefslogtreecommitdiff
path: root/mail/rubygem-actionmailer5
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-01-09 18:45:28 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-01-09 18:45:28 +0000
commit1b0593f9a2ea5275cdc29e4bd470d78d05e17506 (patch)
tree94e177f3a920da93236b1546f1ad4509addcd4b7 /mail/rubygem-actionmailer5
parent6ed1777d495645864ab892077c44638f3a3d24ea (diff)
downloadports-1b0593f9a2ea5275cdc29e4bd470d78d05e17506.tar.gz
ports-1b0593f9a2ea5275cdc29e4bd470d78d05e17506.zip
Add rubygem-actionmailer5 5.0.1 (copied from rubygem-actionmailer4)
Notes
Notes: svn path=/head/; revision=431010
Diffstat (limited to 'mail/rubygem-actionmailer5')
-rw-r--r--mail/rubygem-actionmailer5/Makefile26
-rw-r--r--mail/rubygem-actionmailer5/distinfo3
-rw-r--r--mail/rubygem-actionmailer5/pkg-descr10
3 files changed, 39 insertions, 0 deletions
diff --git a/mail/rubygem-actionmailer5/Makefile b/mail/rubygem-actionmailer5/Makefile
new file mode 100644
index 000000000000..8a381f07897c
--- /dev/null
+++ b/mail/rubygem-actionmailer5/Makefile
@@ -0,0 +1,26 @@
+# Created by: Johannes Meixner <johannes@perceivon.net>
+# $FreeBSD$
+
+PORTNAME= actionmailer
+PORTVERSION= 5.0.1
+CATEGORIES= mail rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 5
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Easy email delivery and testing for Ruby
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/MIT-LICENSE
+
+RUN_DEPENDS= rubygem-actionpack5>=${PORTVERSION}:www/rubygem-actionpack5 \
+ rubygem-actionview5>=${PORTVERSION}:devel/rubygem-actionview5 \
+ rubygem-activejob5>=${PORTVERSION}:devel/rubygem-activejob5 \
+ rubygem-mail>=2.5.4:mail/rubygem-mail \
+ rubygem-rails-dom-testing>=2.0:textproc/rubygem-rails-dom-testing
+
+NO_ARCH= yes
+USE_RUBY= yes
+USES= gem
+
+.include <bsd.port.mk>
diff --git a/mail/rubygem-actionmailer5/distinfo b/mail/rubygem-actionmailer5/distinfo
new file mode 100644
index 000000000000..26c63c5d2dcd
--- /dev/null
+++ b/mail/rubygem-actionmailer5/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1483888478
+SHA256 (rubygem/actionmailer-5.0.1.gem) = 2875da6705900bb230fd7be8f32e817115dafaaff2cb42b41c33295c0288b089
+SIZE (rubygem/actionmailer-5.0.1.gem) = 28672
diff --git a/mail/rubygem-actionmailer5/pkg-descr b/mail/rubygem-actionmailer5/pkg-descr
new file mode 100644
index 000000000000..a770f38ddf9c
--- /dev/null
+++ b/mail/rubygem-actionmailer5/pkg-descr
@@ -0,0 +1,10 @@
+Action Mailer is framework for designing email-service layers. These layers
+are used to consolidate code for sending out forgotten passwords, welcoming
+wishes on signup, invoices for billing, and any other use case that requires
+a written notification to either a person or another system.
+
+Additionally, an Action Mailer class can be used to process incoming email,
+such as allowing a weblog to accept new posts from an email (which could even
+have been sent from a phone)
+
+WWW: http://rubyonrails.org/