aboutsummaryrefslogtreecommitdiff
path: root/mail/rubygem-actionmailer60
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-02-05 18:40:32 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-02-05 18:40:32 +0000
commit93b1cbd6fabfd6b1f929e63857ca3d2aeff8762a (patch)
treee39d3f17c367664d1720dd6b508521f2ad593f68 /mail/rubygem-actionmailer60
parentc5d04f810ca686591e1f8279a0648bc2040bd194 (diff)
downloadports-93b1cbd6fabfd6b1f929e63857ca3d2aeff8762a.tar.gz
ports-93b1cbd6fabfd6b1f929e63857ca3d2aeff8762a.zip
Add rubygem-actionmailer60 6.0.2.1 (copied from rubygem-actionmailer52)
Notes
Notes: svn path=/head/; revision=525321
Diffstat (limited to 'mail/rubygem-actionmailer60')
-rw-r--r--mail/rubygem-actionmailer60/Makefile31
-rw-r--r--mail/rubygem-actionmailer60/distinfo3
-rw-r--r--mail/rubygem-actionmailer60/pkg-descr15
3 files changed, 49 insertions, 0 deletions
diff --git a/mail/rubygem-actionmailer60/Makefile b/mail/rubygem-actionmailer60/Makefile
new file mode 100644
index 000000000000..6cd09439c217
--- /dev/null
+++ b/mail/rubygem-actionmailer60/Makefile
@@ -0,0 +1,31 @@
+# Created by: Johannes Meixner <johannes@perceivon.net>
+# $FreeBSD$
+
+PORTNAME= actionmailer
+PORTVERSION= 6.0.2.1
+CATEGORIES= mail rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 60
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Easy email delivery and testing for Ruby
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/MIT-LICENSE
+
+BROKEN_RUBY24= yes
+
+RUN_DEPENDS= rubygem-actionpack60>=${PORTVERSION}:www/rubygem-actionpack60 \
+ rubygem-actionview60>=${PORTVERSION}:devel/rubygem-actionview60 \
+ rubygem-activejob60>=${PORTVERSION}:devel/rubygem-activejob60 \
+ rubygem-mail>=2.5.4,2<3,2:mail/rubygem-mail \
+ rubygem-rails-dom-testing-rails60>=2.0<3:textproc/rubygem-rails-dom-testing-rails60
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+PORTSCOUT= limit:^6\.0\.
+
+.include <bsd.port.mk>
diff --git a/mail/rubygem-actionmailer60/distinfo b/mail/rubygem-actionmailer60/distinfo
new file mode 100644
index 000000000000..4861e005c9a9
--- /dev/null
+++ b/mail/rubygem-actionmailer60/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1577687172
+SHA256 (rubygem/actionmailer-6.0.2.1.gem) = 13e6eb571bc3764859982d5b3f19f43c88969e99cf5fa4b42696d962b85d2d84
+SIZE (rubygem/actionmailer-6.0.2.1.gem) = 30720
diff --git a/mail/rubygem-actionmailer60/pkg-descr b/mail/rubygem-actionmailer60/pkg-descr
new file mode 100644
index 000000000000..6315c6fd0389
--- /dev/null
+++ b/mail/rubygem-actionmailer60/pkg-descr
@@ -0,0 +1,15 @@
+Action Mailer is a framework for designing email service layers. These layers
+are used to consolidate code for sending out forgotten passwords, welcome wishes
+on signup, invoices for billing, and any other use case that requires a written
+notification to either a person or another system.
+
+Action Mailer is in essence a wrapper around Action Controller and the Mail gem.
+It provides a way to make emails using templates in the same way that Action
+Controller renders views using templates.
+
+Additionally, an Action Mailer class can be used to process incoming email, such
+as allowing a blog to accept new posts from an email (which could even have been
+sent from a phone).
+
+WWW: https://rubyonrails.org/
+WWW: https://github.com/rails/rails/tree/master/actionmailer