aboutsummaryrefslogtreecommitdiff
path: root/mail/rubygem-tmail
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-08-22 08:36:30 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2000-08-22 08:36:30 +0000
commit5ef7fef76ea9eab2672f065cd92a8820221ba9e0 (patch)
tree832ae0f632d0e6c9e4673b80b8a0b4d04b372a2b /mail/rubygem-tmail
parentd0718f7153b077df3ab82125ec3d08fdc9239a95 (diff)
downloadports-5ef7fef76ea9eab2672f065cd92a8820221ba9e0.tar.gz
ports-5ef7fef76ea9eab2672f065cd92a8820221ba9e0.zip
Add ruby-tmail, a mail manipulating library for Ruby, with RFC822 and
MIME multipart support.
Notes
Notes: svn path=/head/; revision=31852
Diffstat (limited to 'mail/rubygem-tmail')
-rw-r--r--mail/rubygem-tmail/Makefile57
-rw-r--r--mail/rubygem-tmail/distinfo1
-rw-r--r--mail/rubygem-tmail/pkg-comment1
-rw-r--r--mail/rubygem-tmail/pkg-descr5
-rw-r--r--mail/rubygem-tmail/pkg-plist45
5 files changed, 109 insertions, 0 deletions
diff --git a/mail/rubygem-tmail/Makefile b/mail/rubygem-tmail/Makefile
new file mode 100644
index 000000000000..0445476f2636
--- /dev/null
+++ b/mail/rubygem-tmail/Makefile
@@ -0,0 +1,57 @@
+# New ports collection makefile for: Ruby-TMail
+# Date created: 22 Aug 2000
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tmail
+PORTVERSION= 0.8.12
+CATEGORIES= mail ruby
+MASTER_SITES= http://www1.u-netsurf.ne.jp/~brew/mine/soft/
+PKGNAMEPREFIX= ruby-
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+BUILD_DEPENDS= ruby:${PORTSDIR}/lang/ruby
+RUN_DEPENDS= ruby:${PORTSDIR}/lang/ruby \
+ ${RUBY_SITELIBDIR}/amstd/info.rb:${PORTSDIR}/devel/ruby-amstd \
+ ${RUBY_SITELIBDIR}/racc/parser.rb:${PORTSDIR}/devel/ruby-racc-runtime \
+ ${RUBY_SITEARCHLIBDIR}/strscan.so:${PORTSDIR}/devel/ruby-strscan
+
+PLIST_SUB= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
+
+RUBY?= ${LOCALBASE}/bin/ruby
+RUBY_VER?= 1.4
+RUBY_ARCH?= ${ARCH}-freebsd${OSREL}
+
+RUBY_SITELIBDIR?= ${LOCALBASE}/lib/ruby/site_ruby/${RUBY_VER}
+RUBY_SITEARCHLIBDIR?= ${LOCALBASE}/lib/ruby/site_ruby/${RUBY_VER}/${RUBY_ARCH}
+
+post-patch:
+ ${PERL} -i -ne '/\btmail\b/ and print' \
+ ${WRKSRC}/ext/PATHCONV ${WRKSRC}/lib/PATHCONV
+ for d in cparse strscanso; do ${RM} -rf ${WRKSRC}/ext/$$d; done
+ for d in amstd raccrt strscan; do ${RM} -rf ${WRKSRC}/lib/$$d; done
+
+do-configure:
+ @cd ${WRKSRC}; \
+ ${SETENV} ${CONFIGURE_ENV} ${RUBY} setup.rb config
+
+do-build:
+ @cd ${WRKSRC}; \
+ ${SETENV} ${MAKE_ENV} ${RUBY} setup.rb setup
+
+do-install:
+ @cd ${WRKSRC}; \
+ ${SETENV} ${MAKE_ENV} ${RUBY} setup.rb install
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/examples/ruby/tmail
+ ${CP} -R ${WRKSRC}/sample/ ${PREFIX}/share/examples/ruby/tmail/
+ ${MKDIR} ${PREFIX}/share/doc/ruby/tmail/ja
+ ${CP} -R ${WRKSRC}/README.en ${WRKSRC}/doc.en/ ${PREFIX}/share/doc/ruby/tmail/
+ ${CP} -R ${WRKSRC}/README.ja ${WRKSRC}/doc.ja/ ${PREFIX}/share/doc/ruby/tmail/ja/
+.endif
+
+.include <bsd.port.mk>
diff --git a/mail/rubygem-tmail/distinfo b/mail/rubygem-tmail/distinfo
new file mode 100644
index 000000000000..f66fa6a3de98
--- /dev/null
+++ b/mail/rubygem-tmail/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/tmail-0.8.12.tar.gz) = 8926a01462a104cebc602dac9b232d98
diff --git a/mail/rubygem-tmail/pkg-comment b/mail/rubygem-tmail/pkg-comment
new file mode 100644
index 000000000000..adce7df42fcd
--- /dev/null
+++ b/mail/rubygem-tmail/pkg-comment
@@ -0,0 +1 @@
+A mail manipulating library for Ruby, with RFC822 and MIME multipart support
diff --git a/mail/rubygem-tmail/pkg-descr b/mail/rubygem-tmail/pkg-descr
new file mode 100644
index 000000000000..ac8f1df1b963
--- /dev/null
+++ b/mail/rubygem-tmail/pkg-descr
@@ -0,0 +1,5 @@
+TMail is a mail manipulating library for Ruby, with RFC822 and MIME
+multipart support.
+
+Author: Minero Aoki <aamine@dp.u-netsurf.ne.jp>
+WWW: http://www1.u-netsurf.ne.jp/~brew/mine/en/index.html
diff --git a/mail/rubygem-tmail/pkg-plist b/mail/rubygem-tmail/pkg-plist
new file mode 100644
index 000000000000..830d169d0cff
--- /dev/null
+++ b/mail/rubygem-tmail/pkg-plist
@@ -0,0 +1,45 @@
+lib/ruby/site_ruby/%%RUBY_VER%%/%%RUBY_ARCH%%/tmail/mails.so
+@dirrm lib/ruby/site_ruby/%%RUBY_VER%%/%%RUBY_ARCH%%/tmail
+lib/ruby/site_ruby/%%RUBY_VER%%/tmail/encode.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/tmail/info.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/tmail/mailp.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/tmail/port.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/tmail/field.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/tmail/loader.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/tmail/mails.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/tmail/tmail.rb
+@dirrm lib/ruby/site_ruby/%%RUBY_VER%%/tmail
+share/examples/ruby/tmail/from-check.rb
+share/examples/ruby/tmail/hf2class.rb
+share/examples/ruby/tmail/multipart.rb
+share/examples/ruby/tmail/parse-bench.rb
+share/examples/ruby/tmail/parse-test.rb
+share/examples/ruby/tmail/sendmail.rb
+share/examples/ruby/tmail/m/normal
+share/examples/ruby/tmail/m/simple
+share/examples/ruby/tmail/m/multipart
+share/examples/ruby/tmail/m/sendtest
+@dirrm share/examples/ruby/tmail/m
+@dirrm share/examples/ruby/tmail
+share/doc/ruby/tmail/README.en
+share/doc/ruby/tmail/bugs.html
+share/doc/ruby/tmail/changes.html
+share/doc/ruby/tmail/concept.html
+share/doc/ruby/tmail/field.html
+share/doc/ruby/tmail/index.html
+share/doc/ruby/tmail/item.html
+share/doc/ruby/tmail/loader.html
+share/doc/ruby/tmail/port.html
+share/doc/ruby/tmail/tmail.html
+share/doc/ruby/tmail/ja/README.ja
+share/doc/ruby/tmail/ja/bugs.html
+share/doc/ruby/tmail/ja/changes.html
+share/doc/ruby/tmail/ja/concept.html
+share/doc/ruby/tmail/ja/field.html
+share/doc/ruby/tmail/ja/index.html
+share/doc/ruby/tmail/ja/item.html
+share/doc/ruby/tmail/ja/loader.html
+share/doc/ruby/tmail/ja/port.html
+share/doc/ruby/tmail/ja/tmail.html
+@dirrm share/doc/ruby/tmail/ja
+@dirrm share/doc/ruby/tmail