aboutsummaryrefslogtreecommitdiff
path: root/mail/sendok
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2005-10-22 22:30:00 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2005-10-22 22:30:00 +0000
commitd7b97a4ba45d5c5328e456c9cdb90029b6882c93 (patch)
tree42a325be3a3a29e4ac023c227e889aa984cec4bb /mail/sendok
parentbb9405af5650b3084c53bbb22db3758d26f2b317 (diff)
downloadports-d7b97a4ba45d5c5328e456c9cdb90029b6882c93.tar.gz
ports-d7b97a4ba45d5c5328e456c9cdb90029b6882c93.zip
Add sendok, a command line utility for generating qmail email addresses with
timed cookies. PR: 87824 Submitted by: Zak Johnson <zakj@nox.cx>
Notes
Notes: svn path=/head/; revision=146141
Diffstat (limited to 'mail/sendok')
-rw-r--r--mail/sendok/Makefile33
-rw-r--r--mail/sendok/distinfo2
-rw-r--r--mail/sendok/pkg-descr6
3 files changed, 41 insertions, 0 deletions
diff --git a/mail/sendok/Makefile b/mail/sendok/Makefile
new file mode 100644
index 000000000000..4f577e3dc8e9
--- /dev/null
+++ b/mail/sendok/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: sendok
+# Date created: 18 October 2005
+# Whom: Zak Johnson <zakj@nox.cx>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sendok
+PORTVERSION= 0.9.1
+CATEGORIES= mail
+MASTER_SITES= http://peff.net/sendok/ \
+ http://www.cs.virginia.edu/~jrk3g/sendok/
+
+MAINTAINER= zakj@nox.cx
+COMMENT= Generates qmail email addresses with timed cookies
+
+RUN_DEPENDS= ${QMAIL_DIR}/bin/qmail-send:${PORTSDIR}/mail/qmail
+
+PLIST_FILES= bin/sendok-check bin/sendok-create
+
+ALL_TARGET= it
+QMAIL_DIR?= /var/qmail
+
+post-patch:
+ @${ECHO_CMD} ${PREFIX} >${WRKSRC}/conf-home
+ @${ECHO_CMD} ${CC} ${CFLAGS} >${WRKSRC}/conf-cc
+
+do-install:
+.for f in sendok-check sendok-create
+ ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/bin
+.endfor
+
+.include <bsd.port.mk>
diff --git a/mail/sendok/distinfo b/mail/sendok/distinfo
new file mode 100644
index 000000000000..e8f5466e89bf
--- /dev/null
+++ b/mail/sendok/distinfo
@@ -0,0 +1,2 @@
+MD5 (sendok-0.9.1.tar.gz) = c40c6fb25a0bf42cf4c6d1fcdbc4f535
+SIZE (sendok-0.9.1.tar.gz) = 14988
diff --git a/mail/sendok/pkg-descr b/mail/sendok/pkg-descr
new file mode 100644
index 000000000000..d8eda46a84f6
--- /dev/null
+++ b/mail/sendok/pkg-descr
@@ -0,0 +1,6 @@
+sendok is a simple program to generate qmail email addresses with timed cookies
+in them. That is, you can give someone a generated address that will accept
+mail from a given sender for a given time period. The address contains a
+cryptographic hash so that no per-address local data needs to be stored.
+
+WWW: http://peff.net/sendok/