aboutsummaryrefslogtreecommitdiff
path: root/mail/smfsav
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-03-14 22:43:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-03-14 22:43:05 +0000
commitf1773477708ed874b7b9cfcd6eaa424f2099ec92 (patch)
treebf3608065fc01c0c0781da3919a3a083f73cb861 /mail/smfsav
parent7c3207fd94b34f4cfbefd07301fcfe99e749a50b (diff)
downloadports-f1773477708ed874b7b9cfcd6eaa424f2099ec92.tar.gz
ports-f1773477708ed874b7b9cfcd6eaa424f2099ec92.zip
- Fix build after strndup MFC
PR: 132009 Submitted by: Florian Smeets <flo@kasimir.com> Approved by: maintainer timeout
Notes
Notes: svn path=/head/; revision=230094
Diffstat (limited to 'mail/smfsav')
-rw-r--r--mail/smfsav/Makefile8
-rw-r--r--mail/smfsav/files/patch-irpmarshall.c16
2 files changed, 17 insertions, 7 deletions
diff --git a/mail/smfsav/Makefile b/mail/smfsav/Makefile
index 53b7411ff619..2104dc4bb085 100644
--- a/mail/smfsav/Makefile
+++ b/mail/smfsav/Makefile
@@ -56,10 +56,4 @@ post-install:
${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 800058 || (${OSVERSION} >= 701101 && ${OSVERSION} < 800000)
-BROKEN= does not build
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/smfsav/files/patch-irpmarshall.c b/mail/smfsav/files/patch-irpmarshall.c
new file mode 100644
index 000000000000..a8563914cfdf
--- /dev/null
+++ b/mail/smfsav/files/patch-irpmarshall.c
@@ -0,0 +1,16 @@
+--- ../src/lib/irs/irpmarshall.c.orig 2009-02-22 15:17:43.000000000 +0000
++++ ../src/lib/irs/irpmarshall.c 2009-02-22 15:25:53.000000000 +0000
+@@ -89,6 +89,12 @@
+
+ #include "port_after.h"
+
++#if defined(__FreeBSD__)
++#include <osreldate.h>
++#if __FreeBSD_version >= 800058 || __FreeBSD_version >= 701101 && __FreeBSD_version < 800000
++#define HAVE_STRNDUP 1
++#endif
++#endif
+
+ #ifndef HAVE_STRNDUP
+ static char *strndup(const char *str, size_t len);
+