aboutsummaryrefslogtreecommitdiff
path: root/mail/smtptrapd
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2020-09-14 07:44:50 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2020-09-14 07:44:50 +0000
commitcdc024ef7e090840c62eaacab5305bc54554eb5e (patch)
tree53a73a7dde6f681f3b442e21fc1a7fefe5559545 /mail/smtptrapd
parent8aa416769a0f8bc071fb129ba251c3965300e191 (diff)
downloadports-cdc024ef7e090840c62eaacab5305bc54554eb5e.tar.gz
ports-cdc024ef7e090840c62eaacab5305bc54554eb5e.zip
Use standard plist mecanism to create directories installed of a pkg-install script
Notes
Notes: svn path=/head/; revision=548591
Diffstat (limited to 'mail/smtptrapd')
-rw-r--r--mail/smtptrapd/Makefile7
-rw-r--r--mail/smtptrapd/pkg-install14
2 files changed, 6 insertions, 15 deletions
diff --git a/mail/smtptrapd/Makefile b/mail/smtptrapd/Makefile
index e64b5e355e26..32fbbd2b6f4b 100644
--- a/mail/smtptrapd/Makefile
+++ b/mail/smtptrapd/Makefile
@@ -3,6 +3,7 @@
PORTNAME= smtptrapd
PORTVERSION= 1.6
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= SF
@@ -11,7 +12,10 @@ COMMENT= RFC 2821 compliant SMTP service that always returns a 4xx soft error
USE_RC_SUBR= smtptrapd
-PLIST_FILES= bin/smtptrapd
+LICENSE= GPLv2
+
+PLIST_FILES= bin/smtptrapd \
+ "@dir(,,0755) /var/run/smtptrapd-root"
do-build:
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} \
@@ -19,5 +23,6 @@ do-build:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/smtptrapd ${STAGEDIR}${PREFIX}/bin/
+ ${MKDIR} ${STAGEDIR}/var/run/smtptrapd-root
.include <bsd.port.mk>
diff --git a/mail/smtptrapd/pkg-install b/mail/smtptrapd/pkg-install
deleted file mode 100644
index 7de34583ea65..000000000000
--- a/mail/smtptrapd/pkg-install
+++ /dev/null
@@ -1,14 +0,0 @@
-#!/bin/sh
-
-case $2 in
- PRE-INSTALL)
- ;;
- POST-INSTALL)
- install -d -m 0755 /var/run/smtptrapd-root
- ;;
- *)
- echo "Unexpected Argument $2."
- exit 1
- ;;
-esac
-exit 0