aboutsummaryrefslogtreecommitdiff
path: root/mail/spamass-rules
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-07-04 12:00:59 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-07-04 12:00:59 +0000
commitf80d14d53a25d1d8e4fc4bd847bd344395933488 (patch)
tree025f9275606fb10df2a5194fb23ec5e77e179b9f /mail/spamass-rules
parent9a2173f6e49311f75f25dbb63bb5da352d828fc4 (diff)
downloadports-f80d14d53a25d1d8e4fc4bd847bd344395933488.tar.gz
ports-f80d14d53a25d1d8e4fc4bd847bd344395933488.zip
Stage support, clean up, slightly better descriptions for some items.
Most of these files are probably outdated by now... will have to fix that.
Notes
Notes: svn path=/head/; revision=360602
Diffstat (limited to 'mail/spamass-rules')
-rw-r--r--mail/spamass-rules/Makefile206
-rw-r--r--mail/spamass-rules/files/pkg-message.in2
2 files changed, 72 insertions, 136 deletions
diff --git a/mail/spamass-rules/Makefile b/mail/spamass-rules/Makefile
index ea4237f85562..8c2128012380 100644
--- a/mail/spamass-rules/Makefile
+++ b/mail/spamass-rules/Makefile
@@ -10,151 +10,87 @@ COMMENT= Custom rulesets for SpamAssassin
RUN_DEPENDS= spamc:${PORTSDIR}/mail/spamassassin
-NO_OPTIONS_SORT= yes
-OPTIONS_DEFINE= \
- AHBL \
- AIRMAX \
- BACKHAIR \
- BOGUS_VIRUS \
- CHICKENPOX \
- CHINESE \
- DBRACKETS \
- EVILNUMBERS \
- GERMAN \
- GREEK \
- MALWARE \
- MANGLED \
- MIMEVLD \
- MSPIKE \
- NIXSPAM \
- RANDOM \
- TRIPWIRE \
- WEEDS
+USES= tar:bzip2
+
+OPTIONS_DEFINE= AIRMAX BACKHAIR BOGUS_VIRUS CHICKENPOX DBRACKETS \
+ EVILNUMBERS MANGLED MIMEVLD RANDOM TRIPWIRE
OPTIONS_SINGLE= WEEDS
-OPTIONS_SINGLE_WEEDS= WEEDS1 WEEDS2
-OPTIONS_DEFAULT= BOGUS_VIRUS DBRACKETS GERMAN GREEK MALWARE MIMEVLD MSPIKE NIXSPAM RANDOM TRIPWIRE WEEDS WEEDS2
+OPTIONS_GROUP= LANG BLACKLIST
-AHBL_DESC= Check AHBL Blacklist
-AIRMAX_DESC= Some custom rulesets
-BACKHAIR_DESC= Catch those ugly, unsightly HTML tags
-BOGUS_VIRUS_DESC= Catch 'collateral spam' caused by viruses
-CHICKENPOX_DESC= Catch spam like 'l.ooks f|or th.is garb+age'
-CHINESE_DESC= Catches spam written in Chinese
-DBRACKETS_DESC= Double-brackets around To header address
-EVILNUMBERS_DESC= Phone numbers, PO boxes, ... from spam
-GERMAN_DESC= Catches spam written in German
-GREEK_DESC= Catches spam written in Greek
-MALWARE_DESC= Malware Patrol - Block List
-MANGLED_DESC= Looks for obfuscated/gappy words
-MIMEVLD_DESC= Some mime validation rules
-MSPIKE_DESC= Check mailspike.net blacklist
-NIXSPAM_DESC= Check NiX Spam blacklist
-RANDOM_DESC= Detects spamware mistakes like: %RANDOM_WORD
-TRIPWIRE_DESC= Matches 3 chars that shouldn't be together
+OPTIONS_SINGLE_WEEDS= WEEDS1 WEEDS2
WEEDS_DESC= Looks at alphanum, hex, lower-, uppercase chars
-WEEDS1_DESC= Less restrictive rules
-WEEDS2_DESC= More restrictive rules
-
-SUB_FILES= pkg-message
-NO_BUILD= yes
-NO_WRKSUBDIR= yes
-SPAMASS_CONF= etc/mail/spamassassin
-SPAMASS_FILES=
-USE_BZIP2= yes
-INSTALL_DIR= ${PREFIX}/${SPAMASS_CONF}
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MAHBL}
-SPAMASS_FILES+= 20_dnsbl_ahbl.cf
-.endif
-
-.if ${PORT_OPTIONS:MAIRMAX}
-SPAMASS_FILES+= airmax.cf
-.endif
-
-.if ${PORT_OPTIONS:MBACKHAIR}
-SPAMASS_FILES+= backhair.cf
-.endif
-
-.if ${PORT_OPTIONS:MBOGUS_VIRUS}
-SPAMASS_FILES+= bogus-virus-warnings.cf
-.endif
-
-.if ${PORT_OPTIONS:MCHICKENPOX}
-SPAMASS_FILES+= chickenpox.cf
-.endif
-
-.if ${PORT_OPTIONS:MCHINESE}
-SPAMASS_FILES+= chinese_rules.cf
-.endif
-
-.if ${PORT_OPTIONS:MDBRACKETS}
-SPAMASS_FILES+= 99_SMF_BRACKETS_TO.cf
-.endif
-.if ${PORT_OPTIONS:MEVILNUMBERS}
-SPAMASS_FILES+= evilnumbers.cf
-.endif
+OPTIONS_GROUP_LANG= CHINESE GERMAN GREEK
+LANG_DESC= Catch spam written in...
-.if ${PORT_OPTIONS:MGERMAN}
-SPAMASS_FILES+= 70_zmi_german.cf
-.endif
+OPTIONS_GROUP_BLACKLIST=AHBL MALWARE MSPIKE NIXSPAM
+BLACKLIST= DNS Blacklists
-.if ${PORT_OPTIONS:MGREEK}
-SPAMASS_FILES+= gr_domain.cf
-.endif
-
-.if ${PORT_OPTIONS:MMALWARE}
-SPAMASS_FILES+= malwarepatrol.cf
-.endif
-
-.if ${PORT_OPTIONS:MMANGLED}
-SPAMASS_FILES+= mangled.cf
-.endif
-
-.if ${PORT_OPTIONS:MMIMEVLD}
-SPAMASS_FILES+= mime_validate.cf
-.endif
-
-.if ${PORT_OPTIONS:MMSPIKE}
-SPAMASS_FILES+= 10_dnsbl_mspike.cf
-.endif
-
-.if ${PORT_OPTIONS:MNIXSPAM}
-SPAMASS_FILES+= 20_dnsbl_nixspam.cf
-.endif
-
-.if ${PORT_OPTIONS:MRANDOM}
-SPAMASS_FILES+= random.cf
-.endif
-
-.if ${PORT_OPTIONS:MTRIPWIRE}
-SPAMASS_FILES+= 99_FVGT_Tripwire.cf
-.endif
-
-.if ${PORT_OPTIONS:MWEEDS}
-SPAMASS_FILES+= weeds.cf
-.endif
+OPTIONS_DEFAULT= BOGUS_VIRUS DBRACKETS GERMAN GREEK MALWARE MIMEVLD MSPIKE NIXSPAM RANDOM TRIPWIRE WEEDS WEEDS2
-.if ${PORT_OPTIONS:MWEEDS2}
-SPAMASS_FILES+= weeds2.cf
-.endif
+AHBL_DESC= AHBL Blacklist
+MALWARE_DESC= Malware Patrol
+MSPIKE_DESC= mailspike.net blacklist
+NIXSPAM_DESC= NiX Spam blacklist
-PLIST_FILES= ${SPAMASS_FILES:S/^/${SPAMASS_CONF}\//}
+AIRMAX_DESC= Some custom rulesets
+BACKHAIR_DESC= Catch those ugly, unsightly HTML tags
+BOGUS_VIRUS_DESC= Catch 'collateral spam' caused by viruses
+CHICKENPOX_DESC= Catch spam like 'l.ooks f|or th.is garb+age'
+DBRACKETS_DESC= Double-brackets around To header address
+EVILNUMBERS_DESC= Phone numbers, PO boxes, ... from spam
+MANGLED_DESC= Looks for obfuscated/gappy words
+MIMEVLD_DESC= Some mime validation rules
+RANDOM_DESC= Detects spamware mistakes like: %RANDOM_WORD
+TRIPWIRE_DESC= Matches 3 chars that shouldn't be together
+
+CHINESE_DESC= Chinese
+GERMAN_DESC= German
+GREEK_DESC= Greek
+
+WEEDS1_DESC= Less restrictive rules
+WEEDS2_DESC= More restrictive rules
+
+SUB_FILES= pkg-message
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+DATADIR= ${PREFIX}/etc/mail/spamassassin
+
+AHBL_CONF= 20_dnsbl_ahbl.cf
+AIRMAX_CONF= airmax.cf
+BACKHAIR_CONF= backhair.cf
+BOGUS_VIRUS_CONF= bogus-virus-warnings.cf
+CHICKENPOX_CONF= chickenpox.cf
+CHINESE_CONF= chinese_rules.cf
+DBRACKETS_CONF= 99_SMF_BRACKETS_TO.cf
+EVILNUMBERS_CONF= evilnumbers.cf
+GERMAN_CONF= 70_zmi_german.cf
+GREEK_CONF= gr_domain.cf
+MALWARE_CONF= malwarepatrol.cf
+MANGLED_CONF= mangled.cf
+MIMEVLD_CONF= mime_validate.cf
+MSPIKE_CONF= 10_dnsbl_mspike.cf
+NIXSPAM_CONF= 20_dnsbl_nixspam.cf
+RANDOM_CONF= random.cf
+TRIPWIRE_CONF= 99_FVGT_Tripwire.cf
+WEEDS1_CONF= weeds.cf
+WEEDS2_CONF= weeds2.cf
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-do-build:
- @${DO_NADA}
+.for opt in ${PORT_OPTIONS}
+. if defined(${opt}_CONF)
+PLIST_FILES+= ${DATADIR_REL}/${${opt}_CONF}
+. endif
+.endfor
do-install:
- @${MKDIR} ${INSTALL_DIR}
- @${INSTALL_DATA} ${SPAMASS_FILES:S/^/${WRKSRC}\//} ${INSTALL_DIR}
-
-post-install:
- @${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.post.mk>
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+.for opt in ${PORT_OPTIONS}
+. if defined(${opt}_CONF)
+ ${INSTALL_DATA} ${WRKSRC}/${${opt}_CONF} ${STAGEDIR}${DATADIR}
+. endif
+.endfor
+
+.include <bsd.port.mk>
diff --git a/mail/spamass-rules/files/pkg-message.in b/mail/spamass-rules/files/pkg-message.in
index 08461303d4d1..f6a013aae39b 100644
--- a/mail/spamass-rules/files/pkg-message.in
+++ b/mail/spamass-rules/files/pkg-message.in
@@ -1,6 +1,6 @@
*************************************************************************
-The custom rulesets are installed in %%PREFIX%%/etc/mail/spamassassin
+The custom rulesets are installed in %%DATADIR%%
Before running these rules please do the following: