aboutsummaryrefslogtreecommitdiff
path: root/mail/spamassassin-dqs
diff options
context:
space:
mode:
authorLarry Rosenman <ler@FreeBSD.org>2019-07-04 17:26:30 +0000
committerLarry Rosenman <ler@FreeBSD.org>2019-07-04 17:26:30 +0000
commitf5533408e532d0c7a86d767d55975585cf44b835 (patch)
treef077b427bbd21a329c100e095f4cd53b0b7cc274 /mail/spamassassin-dqs
parent0b7d577e23636ea152e928f16997d04c30011ee7 (diff)
downloadports-f5533408e532d0c7a86d767d55975585cf44b835.tar.gz
ports-f5533408e532d0c7a86d767d55975585cf44b835.zip
mail/spamassassin-dqs: new port to use SpamHaus' DQS DNSBL's with SpamAssassin
Notes
Notes: svn path=/head/; revision=505846
Diffstat (limited to 'mail/spamassassin-dqs')
-rw-r--r--mail/spamassassin-dqs/Makefile35
-rw-r--r--mail/spamassassin-dqs/distinfo3
-rw-r--r--mail/spamassassin-dqs/files/pkg-message.in23
-rw-r--r--mail/spamassassin-dqs/pkg-descr5
4 files changed, 66 insertions, 0 deletions
diff --git a/mail/spamassassin-dqs/Makefile b/mail/spamassassin-dqs/Makefile
new file mode 100644
index 000000000000..b8c715a2a89d
--- /dev/null
+++ b/mail/spamassassin-dqs/Makefile
@@ -0,0 +1,35 @@
+# Created by: Larry Rosenman <ler@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= spamassassin-dqs
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.0.1
+CATEGORIES= mail
+
+MAINTAINER= ler@FreeBSD.org
+COMMENT= Real-Time DNSBL's that catch a bunch of additional spam
+
+LICENSE= APACHE20
+
+RUN_DEPENDS= ${LOCALBASE}/bin/spamassassin:mail/spamassassin
+
+USE_GITHUB= yes
+GH_ACCOUNT= spamhaus
+
+SUB_FILES= pkg-message
+PLIST_FILES= etc/mail/spamassassin/SH.pm \
+ "@sample etc/mail/spamassassin/sh.cf.sample" \
+ etc/mail/spamassassin/sh_scores.cf
+
+NO_ARCH= yes
+NO_BUILD= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|<config_directory>|${PREFIX}/etc/mail/spamassassin|' ${WRKSRC}/sh.cf
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/etc/mail/spamassassin
+ ${INSTALL_DATA} ${WRKSRC}/sh.cf ${STAGEDIR}${PREFIX}/etc/mail/spamassassin/sh.cf.sample
+ ${INSTALL_DATA} ${WRKSRC}/SH.pm ${STAGEDIR}${PREFIX}/etc/mail/spamassassin/
+ ${INSTALL_DATA} ${WRKSRC}/sh_scores.cf ${STAGEDIR}${PREFIX}/etc/mail/spamassassin/
+.include <bsd.port.mk>
diff --git a/mail/spamassassin-dqs/distinfo b/mail/spamassassin-dqs/distinfo
new file mode 100644
index 000000000000..3a2461124633
--- /dev/null
+++ b/mail/spamassassin-dqs/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1562256350
+SHA256 (spamhaus-spamassassin-dqs-v1.0.1_GH0.tar.gz) = f1b1ffc3306aa18d02da0cc4baeedce645a5165e7893f08cdce28cfa1cf46b6d
+SIZE (spamhaus-spamassassin-dqs-v1.0.1_GH0.tar.gz) = 12545
diff --git a/mail/spamassassin-dqs/files/pkg-message.in b/mail/spamassassin-dqs/files/pkg-message.in
new file mode 100644
index 000000000000..e69f3824ef25
--- /dev/null
+++ b/mail/spamassassin-dqs/files/pkg-message.in
@@ -0,0 +1,23 @@
+[
+{
+ message: <<EOM
+you will need to configure the sh.cf file with your own
+DQS key.
+
+Follow the instructions at:
+https://www.spamhaustech.com/dqs/
+to get a key, then go to:
+https://portal.spamhaustech.com/src/manual/dqs/
+and note your key.
+
+Once you have it, run the following as root:
+
+cd %%PREFIX%%/etc/mail/spamassassin:
+sed -e 's/your_DQS_key/<your key from above>/g' sh.cf.sample >sh.cf
+
+then restart spamassassin.
+EOM
+ type: install
+}
+]
+
diff --git a/mail/spamassassin-dqs/pkg-descr b/mail/spamassassin-dqs/pkg-descr
new file mode 100644
index 000000000000..9ea1ed4b32c5
--- /dev/null
+++ b/mail/spamassassin-dqs/pkg-descr
@@ -0,0 +1,5 @@
+This port allows use of SpamHaus Technologies DQS DNSBL's
+to help spamassassin detect more spam.
+
+Data Feed License: https://www.spamhaus.org/organization/dnsblusage/
+WWW: https://github.com/spamhaus/spamassassin-dqs/