aboutsummaryrefslogtreecommitdiff
path: root/mail/spamassassin/Makefile
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2015-03-13 17:52:46 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2015-03-13 17:52:46 +0000
commite8c53e8c7287a1237c833d953408f72d665a593b (patch)
treeaa936b036dbc0b961b6ec6e3e84f259bcc0b9d4e /mail/spamassassin/Makefile
parentfc78f832cb58136084bbb032a8d9a019e1129df0 (diff)
downloadports-e8c53e8c7287a1237c833d953408f72d665a593b.tar.gz
ports-e8c53e8c7287a1237c833d953408f72d665a593b.zip
Allow depending on gpg2 instead of gpg1.
Inspired by: PR: 197837 Submitted by: bogus19@veggiechinese.net
Notes
Notes: svn path=/head/; revision=381227
Diffstat (limited to 'mail/spamassassin/Makefile')
-rw-r--r--mail/spamassassin/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/mail/spamassassin/Makefile b/mail/spamassassin/Makefile
index e52b53e4a706..f614428d87a4 100644
--- a/mail/spamassassin/Makefile
+++ b/mail/spamassassin/Makefile
@@ -46,19 +46,25 @@ CONFIGURE_ARGS= SYSCONFDIR="${PREFIX}/etc" \
LOCALSTATEDIR="${DBDIR}/spamassassin" \
BUILD_SPAMC=yes
-OPTIONS_DEFINE= AS_ROOT GNUPG SSL UPDATE_AND_COMPILE
-OPTIONS_GROUP= DATABASE PLUGINS
+OPTIONS_DEFINE= AS_ROOT SSL UPDATE_AND_COMPILE
+OPTIONS_GROUP= DATABASE GPG PLUGINS
OPTIONS_GROUP_DATABASE= MYSQL PGSQL
OPTIONS_GROUP_PLUGINS= DCC DKIM PYZOR RAZOR RELAY_COUNTRY SPF_QUERY
+OPTIONS_SINGLE= GPG
+OPTIONS_SINGLE_GPG= GNUPG_NONE GNUPG GNUPG2
OPTIONS_DEFAULT= AS_ROOT GNUPG SSL UPDATE_AND_COMPILE
AS_ROOT_DESC= Run spamd as root (recommended)
-GNUPG_DESC= Install GnuPG (for sa-update, optional)
SSL_DESC= Build spamd/spamc with SSL support
UPDATE_AND_COMPILE_DESC=Download and compile rulesets (recommended)
DATABASE_DESC= Optional user-config/bayes database backends
+GPG_DESC= GnuPG (for sa-update, optional)
+GNUPG_NONE_DESC= Do not use GnuPG
+GNUPG_DESC= GnuPG 1 (security/gnupg1)
+GNUPG2_DESC= GnuPG 2 (security/gnupg)
+
PLUGINS_DESC= Optional SpamAssassin plugins
DCC_DESC= DCC digest list support (mail/dcc-dccd)
DKIM_DESC= Verify DKIM records (mail/p5-Mail-DKIM)
@@ -77,6 +83,7 @@ DKIM_RUN_DEPENDS= p5-IO-Socket-SSL>=0:${PORTSDIR}/security/p5-IO-Socket-SSL \
p5-Mail-DKIM>=0.37:${PORTSDIR}/mail/p5-Mail-DKIM \
p5-Crypt-OpenSSL-RSA>=0.26_1:${PORTSDIR}/security/p5-Crypt-OpenSSL-RSA
GNUPG_RUN_DEPENDS= gnupg1>=1.4.7:${PORTSDIR}/security/gnupg1
+GNUPG2_RUN_DEPENDS= gpg2:${PORTSDIR}/security/gnupg
MYSQL_RUN_DEPENDS= p5-DBD-mysql>=0:${PORTSDIR}/databases/p5-DBD-mysql
PGSQL_RUN_DEPENDS= p5-DBD-Pg>=0:${PORTSDIR}/databases/p5-DBD-Pg
PYZOR_RUN_DEPENDS= pyzor:${PORTSDIR}/mail/pyzor