aboutsummaryrefslogtreecommitdiff
path: root/mail/spamcup
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2005-02-08 15:41:44 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2005-02-08 15:41:44 +0000
commit43983f6bd306ae5a1ce0fc2e58e0b945a860fd38 (patch)
treebc4977a5477ef44eb1bb01e05eaf22187355c0b7 /mail/spamcup
parent030fe20888050832a2da6bb051ba3814cb0dde97 (diff)
downloadports-43983f6bd306ae5a1ce0fc2e58e0b945a860fd38.tar.gz
ports-43983f6bd306ae5a1ce0fc2e58e0b945a860fd38.zip
Notes
Diffstat (limited to 'mail/spamcup')
-rw-r--r--mail/spamcup/Makefile27
-rw-r--r--mail/spamcup/distinfo2
-rw-r--r--mail/spamcup/pkg-descr6
3 files changed, 35 insertions, 0 deletions
diff --git a/mail/spamcup/Makefile b/mail/spamcup/Makefile
new file mode 100644
index 000000000000..2b87cc715f59
--- /dev/null
+++ b/mail/spamcup/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: spamcup
+# Date created: 07 February 2005
+# Whom: Yen-Ming Lee <leeym@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= spamcup
+PORTVERSION= 1.09
+CATEGORIES= mail
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR=${PORTNAME}
+
+MAINTAINER= leeym@FreeBSD.org
+COMMENT= A tool for automatic spam reporting via Spamcop.net
+
+RUN_DEPENDS= ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/Getopt/ArgvFile.pm:${PORTSDIR}/devel/p5-Getopt-ArgvFile
+
+PERL_CONFIGURE= yes
+
+PLIST_FILES= bin/spamcup.pl ${SITE_PERL_REL}/spamcup.pl \
+ ${SITE_PERL_REL}/${PERL_ARCH}/auto/Spamcup/.packlist
+
+PLIST_DIRS= ${SITE_PERL_REL}/${PERL_ARCH}/auto/Spamcup
+
+.include <bsd.port.mk>
diff --git a/mail/spamcup/distinfo b/mail/spamcup/distinfo
new file mode 100644
index 000000000000..8147bc886754
--- /dev/null
+++ b/mail/spamcup/distinfo
@@ -0,0 +1,2 @@
+MD5 (spamcup-1.09.tar.gz) = 47a655793ac0bcfe0ae8fd6cb407167a
+SIZE (spamcup-1.09.tar.gz) = 6801
diff --git a/mail/spamcup/pkg-descr b/mail/spamcup/pkg-descr
new file mode 100644
index 000000000000..e09d6d5303b2
--- /dev/null
+++ b/mail/spamcup/pkg-descr
@@ -0,0 +1,6 @@
+Spamcup is a tool for automatic spam reporting via Spamcop.net.
+It performs the same actions as if you were to report spam to
+spamcop.net with a Web browser, but from the commandline.
+Spamcup is written in Perl.
+
+WWW: http://sourceforge.net/projects/spamcup/