aboutsummaryrefslogtreecommitdiff
path: root/mail/spampd
diff options
context:
space:
mode:
authorMichael Gmelin <grembo@FreeBSD.org>2018-07-16 09:53:15 +0000
committerMichael Gmelin <grembo@FreeBSD.org>2018-07-16 09:53:15 +0000
commitcd38ece830513305ce5b677dff9669c233819e40 (patch)
treea97f59bdd90c8f5a120b764f91a9f375b9dfd87e /mail/spampd
parent47622c7de3a0ff1a478660eb0b955b458b5954d0 (diff)
downloadports-cd38ece830513305ce5b677dff9669c233819e40.tar.gz
ports-cd38ece830513305ce5b677dff9669c233819e40.zip
mail/spampd: Update to 2.51 and refine rc script
- Include /usr/local/bin and /usr/local/sbin to PATH (this way pyzor and razor work, which wouldn't be used otherwise [debug output would show that they're silently skipped]) - support for sockets - IPv6 support - Fix injected X-Envelope-* headers so that spamassassin actually can pick them up for SPF and other checks - support for sid (so patch-setsid not required anymore), toggled by --setsid (rc script always sets this so it doesn't break on update) - new rc var (spampd_extra_flags), so it's easy to use the default setup and just add deltas in rc.conf like in: spampd_enable="YES" spampd_extra_flags="--sef" PR: 227903 Approved by: maintainer timeout
Notes
Notes: svn path=/head/; revision=474724
Diffstat (limited to 'mail/spampd')
-rw-r--r--mail/spampd/Makefile5
-rw-r--r--mail/spampd/distinfo5
-rw-r--r--mail/spampd/files/patch-setsid11
-rw-r--r--mail/spampd/files/spampd.in8
4 files changed, 11 insertions, 18 deletions
diff --git a/mail/spampd/Makefile b/mail/spampd/Makefile
index 0ee72d979605..c533eaea889b 100644
--- a/mail/spampd/Makefile
+++ b/mail/spampd/Makefile
@@ -2,14 +2,13 @@
# $FreeBSD$
PORTNAME= spampd
-PORTVERSION= 2.42
-PORTREVISION= 2
+PORTVERSION= 2.51
CATEGORIES= mail perl5
MAINTAINER= des@FreeBSD.org
COMMENT= Spamassassin SMTP Proxy
-LICENSE= GPLv2
+LICENSE= GPLv3
RUN_DEPENDS= spamc:mail/spamassassin \
p5-Net-Server>=0:net/p5-Net-Server
diff --git a/mail/spampd/distinfo b/mail/spampd/distinfo
index ee820530091b..1ec925eb8b79 100644
--- a/mail/spampd/distinfo
+++ b/mail/spampd/distinfo
@@ -1,2 +1,3 @@
-SHA256 (mpaperno-spampd-2.42_GH0.tar.gz) = c6dcef8df0c471b3982e777bcccfe343f1f6f921113c2b369a76144724b1d15d
-SIZE (mpaperno-spampd-2.42_GH0.tar.gz) = 202504
+TIMESTAMP = 1525190858
+SHA256 (mpaperno-spampd-2.51_GH0.tar.gz) = 93cc3ef19ecff224ac00f6c7a0e028f059ec839703329f4567846b750964ac07
+SIZE (mpaperno-spampd-2.51_GH0.tar.gz) = 215462
diff --git a/mail/spampd/files/patch-setsid b/mail/spampd/files/patch-setsid
deleted file mode 100644
index d7c426f18d44..000000000000
--- a/mail/spampd/files/patch-setsid
+++ /dev/null
@@ -1,11 +0,0 @@
---- spampd.pl.orig 2013-12-08 11:34:02 UTC
-+++ spampd.pl
-@@ -961,7 +961,7 @@ my $server = bless {
- syslog_ident => 'spampd',
- syslog_facility => 'mail',
- background => $background,
-- # setsid => 1,
-+ setsid => 1,
- pid_file => $pidfile,
- user => $user,
- group => $group,
diff --git a/mail/spampd/files/spampd.in b/mail/spampd/files/spampd.in
index 26bb226c9c90..e74206334207 100644
--- a/mail/spampd/files/spampd.in
+++ b/mail/spampd/files/spampd.in
@@ -9,7 +9,11 @@
#
# spampd_enable (bool): Set it to "YES" to enable spampd
# Default is "NO"
-# spampd_flags
+# spampd_flags: Flags to spampd
+# spampd_extra_flags: Additional flags, so one can
+# keep defaults in spampd_flags, e.g.
+# spampd_extra_flags="--sef" to add
+# "X-Envelope-From" header.
. /etc/rc.subr
@@ -23,7 +27,7 @@ rcvar=spampd_enable
load_rc_config $name
command="%%PREFIX%%/sbin/$name"
-command_args="--pid=${spampd_pidfile}"
+command_args="--setsid --pid=${spampd_pidfile} ${spampd_extra_flags}"
command_interpreter="%%PERL%% -T"
pidfile="${spampd_pidfile}"