aboutsummaryrefslogtreecommitdiff
path: root/mail/sqlgrey
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2005-11-23 17:22:15 +0000
committerMathieu Arnold <mat@FreeBSD.org>2005-11-23 17:22:15 +0000
commit6156da4b83a9736f9fed432bdf15efcb60ba4744 (patch)
tree4688827497e3f61a6350845cd3bb24d153a47e33 /mail/sqlgrey
parente2365ff6abe2192e16d3dd441642f4c24972775d (diff)
downloadports-6156da4b83a9736f9fed432bdf15efcb60ba4744.tar.gz
ports-6156da4b83a9736f9fed432bdf15efcb60ba4744.zip
Notes
Diffstat (limited to 'mail/sqlgrey')
-rw-r--r--mail/sqlgrey/Makefile13
-rw-r--r--mail/sqlgrey/distinfo6
-rw-r--r--mail/sqlgrey/files/sqlgrey.sh.in10
-rw-r--r--mail/sqlgrey/pkg-plist9
4 files changed, 20 insertions, 18 deletions
diff --git a/mail/sqlgrey/Makefile b/mail/sqlgrey/Makefile
index 94030a56741d..d4e194a343f4 100644
--- a/mail/sqlgrey/Makefile
+++ b/mail/sqlgrey/Makefile
@@ -6,12 +6,12 @@
#
PORTNAME= sqlgrey
-PORTVERSION= 1.4.8
+PORTVERSION= 1.6.7
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= mat@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Greylisting policy server for Postfix using an SQL backend
RUN_DEPENDS= ${SITE_PERL}/Net/Server.pm:${PORTSDIR}/net/p5-Net-Server \
@@ -32,7 +32,7 @@ USE_BZIP2= yes
NO_BUILD= yes
USE_REINPLACE= yes
-ETCFILES= clients_fqdn_whitelist clients_ip_whitelist sqlgrey.conf
+ETCFILES= clients_fqdn_whitelist clients_ip_whitelist dyn_fqdn.regexp smtp_server.regexp sqlgrey.conf
SGY_USERNAME?= sqlgrey
SGY_GROUPNAME?= ${SGY_USERNAME}
ETCDIR?= etc/sqlgrey
@@ -48,7 +48,7 @@ PKGDEINSTALL= ${PKGINSTALL}
MAN1= sqlgrey.1
.if !defined(NOPORTDOCS)
-PORTDOCS= Changelog FAQ HOWTO README TODO db_performance_reports
+PORTDOCS= Changelog FAQ HOWTO README TODO
.endif
pre-everything::
@@ -59,14 +59,15 @@ post-patch:
@${REINPLACE_CMD} -e 's-#!/usr/bin/perl-#!${PERL}-' -e 's!/etc/sqlgrey!${PREFIX}/${ETCDIR}!g' ${WRKSRC}/sqlgrey
do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/sqlgrey-logstats.pl ${PREFIX}/bin
@${INSTALL_SCRIPT} ${WRKSRC}/sqlgrey ${PREFIX}/sbin
- @${INSTALL_SCRIPT} ${WRKSRC}/update_sqlgrey_whitelists ${PREFIX}/sbin
+ @${INSTALL_SCRIPT} ${WRKSRC}/update_sqlgrey_config ${PREFIX}/sbin
@${INSTALL_SCRIPT} ${WRKDIR}/sqlgrey.sh ${PREFIX}/etc/rc.d
@cd ${WRKSRC} && perldoc -u sqlgrey | pod2man sqlgrey > ${MANPREFIX}/man/man1/sqlgrey.1
@${MKDIR} ${PREFIX}/${ETCDIR}
.for i in ${ETCFILES}
@${INSTALL_DATA} ${WRKSRC}/etc/${i} ${PREFIX}/${ETCDIR}/${i}.dist
- @[ "${i}" = "sqlgrey.conf" ] || ${TOUCH} ${PREFIX}/${ETCDIR}/${i}.local
+ @[ "${i}" = "dyn_fqdn.regexp" ] || [ "${i}" = "smtp_server.regexp" ] || [ "${i}" = "sqlgrey.conf" ] || ${TOUCH} ${PREFIX}/${ETCDIR}/${i}.local
@[ -f ${PREFIX}/${ETCDIR}/${i} ] || ${INSTALL_DATA} ${WRKSRC}/etc/${i} ${PREFIX}/${ETCDIR}/${i}
.endfor
.if !defined(NOPORTDOCS)
diff --git a/mail/sqlgrey/distinfo b/mail/sqlgrey/distinfo
index e920032fb534..118fbf540d0c 100644
--- a/mail/sqlgrey/distinfo
+++ b/mail/sqlgrey/distinfo
@@ -1,3 +1,3 @@
-MD5 (sqlgrey-1.4.8.tar.bz2) = 09be0d578b7f6ad7099403654441ee49
-SHA256 (sqlgrey-1.4.8.tar.bz2) = 508fb4eb771816c0adcdff27e7e3924a0cb7d89dcefaa65c067e52f5d6b58fac
-SIZE (sqlgrey-1.4.8.tar.bz2) = 31068
+MD5 (sqlgrey-1.6.7.tar.bz2) = 3490567366eee97248eb9416067b79a4
+SHA256 (sqlgrey-1.6.7.tar.bz2) = f67b76799af93617f09a16bd7d5141b607d9952067fbb669f25bc3aa17bd7df5
+SIZE (sqlgrey-1.6.7.tar.bz2) = 42633
diff --git a/mail/sqlgrey/files/sqlgrey.sh.in b/mail/sqlgrey/files/sqlgrey.sh.in
index b755237cf1b2..20b9a282ea3a 100644
--- a/mail/sqlgrey/files/sqlgrey.sh.in
+++ b/mail/sqlgrey/files/sqlgrey.sh.in
@@ -18,7 +18,7 @@
. %%RC_SUBR%%
name=sqlgrey
-rcvar=`set_rcvar`
+load_rc_config sqlgrey
command=%%PREFIX%%/sbin/sqlgrey
extra_commands=reload
@@ -34,14 +34,8 @@ stop_postcmd()
# set defaults
sqlgrey_enable=${sqlgrey_enable:-"NO"}
-sqlgrey_pidfile=${sqlgrey_pidfile:-"/var/run/sqlgrey.pid"}
-sqlgrey_listen=${sqlgrey_listen:-"2501"}
sqlgrey_config=${sqlgrey_config:-"/usr/local/%%ETCDIR%%/sqlgrey.conf"}
-sqlgrey_flags=${sqlgrey_flags:-"--pidfile=${sqlgrey_pidfile} \
- --inet=${sqlgrey_listen} --daemonize --user=sqlgrey --group=sqlgrey \
- --configfile=${sqlgrey_config}"}
-
-pidfile="${sqlgrey_pidfile}"
+sqlgrey_flags=${sqlgrey_flags:-"--daemonize --configfile=${sqlgrey_config}"}
load_rc_config $name
run_rc_command "$1"
diff --git a/mail/sqlgrey/pkg-plist b/mail/sqlgrey/pkg-plist
index edf9d64c49df..1c0204d06b5c 100644
--- a/mail/sqlgrey/pkg-plist
+++ b/mail/sqlgrey/pkg-plist
@@ -2,6 +2,8 @@
@unexec [ -e %D/%%ETCDIR%%/clients_fqdn_whitelist.local -a ! -s %D/%%ETCDIR%%/clients_fqdn_whitelist.local ] && rm -f %D/%%ETCDIR%%/clients_fqdn_whitelist.local
@unexec if cmp -s %D/%%ETCDIR%%/clients_ip_whitelist.dist %D/%%ETCDIR%%/clients_ip_whitelist; then rm -f %D/%%ETCDIR%%/clients_ip_whitelist; fi
@unexec [ -e %D/%%ETCDIR%%/clients_ip_whitelist.local -a ! -s %D/%%ETCDIR%%/clients_ip_whitelist.local ] && rm -f %D/%%ETCDIR%%/clients_ip_whitelist.local
+@unexec if cmp -s %D/%%ETCDIR%%/dyn_fqdn.regexp.dist %D/%%ETCDIR%%/dyn_fqdn.regexp; then rm -f %D/%%ETCDIR%%/dyn_fqdn.regexp; fi
+@unexec if cmp -s %D/%%ETCDIR%%/smtp_server.regexp.dist %D/%%ETCDIR%%/smtp_server.regexp; then rm -f %D/%%ETCDIR%%/smtp_server.regexp; fi
@unexec if cmp -s %D/%%ETCDIR%%/sqlgrey.conf.dist %D/%%ETCDIR%%/sqlgrey.conf; then rm -f %D/%%ETCDIR%%/sqlgrey.conf; fi
%%ETCDIR%%/clients_fqdn_whitelist.dist
@exec [ -f %B/clients_fqdn_whitelist ] || cp %B/%f %B/clients_fqdn_whitelist
@@ -9,9 +11,14 @@
%%ETCDIR%%/clients_ip_whitelist.dist
@exec [ -f %B/clients_ip_whitelist ] || cp %B/%f %B/clients_ip_whitelist
@exec [ -f %B/clients_ip_whitelist.local ] || %%TOUCH%% %B/clients_ip_whitelist.local
+%%ETCDIR%%/dyn_fqdn.regexp.dist
+%%ETCDIR%%/smtp_server.regexp.dist
%%ETCDIR%%/sqlgrey.conf.dist
+@exec [ -f %B/dyn_fqdn.regexp.dist ] || cp %B/%f %B/dyn_fqdn.regexp.dist
+@exec [ -f %B/smtp_server.regexp.dist ] || cp %B/%f %B/smtp_server.regexp.dist
@exec [ -f %B/sqlgrey.conf ] || cp %B/%f %B/sqlgrey.conf
+bin/sqlgrey-logstats.pl
sbin/sqlgrey
-sbin/update_sqlgrey_whitelists
+sbin/update_sqlgrey_config
@unexec rmdir %D/%%DATADIR%% 2>/dev/null || true
@unexec rmdir %D/%%ETCDIR%% 2>/dev/null || true