aboutsummaryrefslogtreecommitdiff
path: root/mail/squirrelmail-decode
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2012-11-17 17:44:34 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2012-11-17 17:44:34 +0000
commit68a9f79722313357c397762da226b281e107f968 (patch)
treeed761453aba6a1ba968e64a526a8f9a35ff927f6 /mail/squirrelmail-decode
parent1e09cdca484cf6f41785503eb4080e2d176f39ee (diff)
downloadports-68a9f79722313357c397762da226b281e107f968.tar.gz
ports-68a9f79722313357c397762da226b281e107f968.zip
Add the extra charset decoders from SquirrelMail.
This package contains extra decoding functions. SquirrelMail decoding functions are used to display and convert messages encoded in different character sets. Extra decoding library provides support of some complex Eastern character sets and some rarely used Apple character sets. Current release supports Big5, Windows-874 (cp874, Thai), Windows-949 (UHC, Korean), EUC-CN, EUC-JP, EUC-KR, EUC-TW, GB18030, GB2312, ISO-2022-CN, ISO-2022-JP, ISO-2022-JP-2, ISO-2022-KR, Shift_JIS and various x-mac-* character sets. Extra decoding library can be used in SquirrelMail 1.4.4 or newer. It depends on sq_is8bit() function. In order to optimize decoding of Eastern character sets, PHP installation needs recode (http://www.php.net/recode) or iconv (http://www.php.net/iconv) support. Some decoding functions can use mbstring functions present in php 4.3.0. Mbstring decoding needs sq_mb_list_encodings() function from SquirrelMail 1.5.1 or 1.4.6. Some decoding code that be activated only when $aggressive_decoding variable is set to true. This variable should be enabled only on smaller systems, that don't call aggressive decoding functions very often. Turning on $aggressive_decoding variable by default in packaged SquirrelMail versions is not recommended. WWW: http://www.squirrelmail.org/ Feature safe: yes
Notes
Notes: svn path=/head/; revision=307522
Diffstat (limited to 'mail/squirrelmail-decode')
-rw-r--r--mail/squirrelmail-decode/Makefile36
-rw-r--r--mail/squirrelmail-decode/distinfo2
-rw-r--r--mail/squirrelmail-decode/pkg-descr25
-rw-r--r--mail/squirrelmail-decode/pkg-plist33
4 files changed, 96 insertions, 0 deletions
diff --git a/mail/squirrelmail-decode/Makefile b/mail/squirrelmail-decode/Makefile
new file mode 100644
index 000000000000..420440a8ff7e
--- /dev/null
+++ b/mail/squirrelmail-decode/Makefile
@@ -0,0 +1,36 @@
+# Created by: Adam Weinberger <adamw@FreeBSD.org>
+# $FreeBSD$
+#
+
+PORTNAME= squirrelmail-decode
+PORTVERSION= 1.2
+CATEGORIES= mail www
+MASTER_SITES= SF/squirrelmail/decode/${PORTVERSION}
+DIST_SUBDIR= squirrelmail
+
+MAINTAINER= adamw@FreeBSD.org
+COMMENT= Decoders to display extra character sets in SquirrelMail
+
+RUN_DEPENDS= ${SQUIRRELDIR}/index.php:${PORTSDIR}/mail/squirrelmail
+
+USE_BZIP2= yes
+NO_BUILD= yes
+
+DOCSDIR= ${PREFIX}/share/doc/squirrelmail/decode
+PORTDOCS= *
+
+# if you were using WITHOUT_WWWDIR, use SQUIRRELDIR=${PREFIX}/${PORTNAME}
+SQUIRRELDIR?= ${PREFIX}/www/squirrelmail
+PLIST_SUB= SQUIRRELDIR="${SQUIRRELDIR:S,^${PREFIX}/,,}"
+
+do-install:
+ ${MKDIR} ${SQUIRRELDIR}/functions/decode
+.for DIR in eastasia x-mac
+ cd ${WRKSRC}/${DIR} && ${FIND} . | ${CPIO} -pdmu --quiet ${SQUIRRELDIR}/functions/decode
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.decode ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/mail/squirrelmail-decode/distinfo b/mail/squirrelmail-decode/distinfo
new file mode 100644
index 000000000000..80c9aac61f27
--- /dev/null
+++ b/mail/squirrelmail-decode/distinfo
@@ -0,0 +1,2 @@
+SHA256 (squirrelmail/squirrelmail-decode-1.2.tar.bz2) = 72750301b83ee23fffe32ae40a3dec33ad4f39abf81c5abdd38f235aab3fcb26
+SIZE (squirrelmail/squirrelmail-decode-1.2.tar.bz2) = 333942
diff --git a/mail/squirrelmail-decode/pkg-descr b/mail/squirrelmail-decode/pkg-descr
new file mode 100644
index 000000000000..2269776fc999
--- /dev/null
+++ b/mail/squirrelmail-decode/pkg-descr
@@ -0,0 +1,25 @@
+[from README.decode]:
+This package contains extra decoding functions.
+
+SquirrelMail decoding functions are used to display and convert messages
+encoded in different character sets. Extra decoding library provides support
+of some complex Eastern character sets and some rarely used Apple character
+sets. Current release supports Big5, Windows-874 (cp874, Thai), Windows-949
+(UHC, Korean), EUC-CN, EUC-JP, EUC-KR, EUC-TW, GB18030, GB2312, ISO-2022-CN,
+ISO-2022-JP, ISO-2022-JP-2, ISO-2022-KR, Shift_JIS and various x-mac-*
+character sets.
+
+Extra decoding library can be used in SquirrelMail 1.4.4 or newer. It depends
+on sq_is8bit() function. In order to optimize decoding of Eastern character
+sets, PHP installation needs recode (http://www.php.net/recode) or iconv
+(http://www.php.net/iconv) support. Some decoding functions can use mbstring
+functions present in php 4.3.0. Mbstring decoding needs sq_mb_list_encodings()
+function from SquirrelMail 1.5.1 or 1.4.6.
+
+Some decoding code that be activated only when $aggressive_decoding variable
+is set to true. This variable should be enabled only on smaller systems, that
+don't call aggressive decoding functions very often. Turning on
+$aggressive_decoding variable by default in packaged SquirrelMail versions is
+not recommended.
+
+WWW: http://www.squirrelmail.org/
diff --git a/mail/squirrelmail-decode/pkg-plist b/mail/squirrelmail-decode/pkg-plist
new file mode 100644
index 000000000000..fbcb534a3dfd
--- /dev/null
+++ b/mail/squirrelmail-decode/pkg-plist
@@ -0,0 +1,33 @@
+%%SQUIRRELDIR%%/functions/decode/big5.php
+%%SQUIRRELDIR%%/functions/decode/cp874.php
+%%SQUIRRELDIR%%/functions/decode/cp949.php
+%%SQUIRRELDIR%%/functions/decode/euc_cn.php
+%%SQUIRRELDIR%%/functions/decode/euc_jp.php
+%%SQUIRRELDIR%%/functions/decode/euc_kr.php
+%%SQUIRRELDIR%%/functions/decode/euc_tw.php
+%%SQUIRRELDIR%%/functions/decode/gb18030.php
+%%SQUIRRELDIR%%/functions/decode/gb2312.php
+%%SQUIRRELDIR%%/functions/decode/iso_2022_cn.php
+%%SQUIRRELDIR%%/functions/decode/iso_2022_jp.php
+%%SQUIRRELDIR%%/functions/decode/iso_2022_jp_2.php
+%%SQUIRRELDIR%%/functions/decode/iso_2022_kr.php
+%%SQUIRRELDIR%%/functions/decode/iso_2022_support.php
+%%SQUIRRELDIR%%/functions/decode/shift_jis.php
+%%SQUIRRELDIR%%/functions/decode/x_mac_arabic.php
+%%SQUIRRELDIR%%/functions/decode/x_mac_ce.php
+%%SQUIRRELDIR%%/functions/decode/x_mac_chinsimp.php
+%%SQUIRRELDIR%%/functions/decode/x_mac_chintrad.php
+%%SQUIRRELDIR%%/functions/decode/x_mac_croatian.php
+%%SQUIRRELDIR%%/functions/decode/x_mac_cyrillic.php
+%%SQUIRRELDIR%%/functions/decode/x_mac_devanagari.php
+%%SQUIRRELDIR%%/functions/decode/x_mac_farsi.php
+%%SQUIRRELDIR%%/functions/decode/x_mac_greek.php
+%%SQUIRRELDIR%%/functions/decode/x_mac_gujarati.php
+%%SQUIRRELDIR%%/functions/decode/x_mac_gurmukhi.php
+%%SQUIRRELDIR%%/functions/decode/x_mac_hebrew.php
+%%SQUIRRELDIR%%/functions/decode/x_mac_icelandic.php
+%%SQUIRRELDIR%%/functions/decode/x_mac_roman.php
+%%SQUIRRELDIR%%/functions/decode/x_mac_romanian.php
+%%SQUIRRELDIR%%/functions/decode/x_mac_thai.php
+%%SQUIRRELDIR%%/functions/decode/x_mac_turkish.php
+%%SQUIRRELDIR%%/functions/decode/x_mac_ukrainian.php