aboutsummaryrefslogtreecommitdiff
path: root/mail/squirrelmail-login_auth-plugin
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-04-15 16:44:01 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-04-15 16:44:01 +0000
commit35f06fcd24af52d953cded5f5934c12d46bb7926 (patch)
tree30d5691bbf690c78abb7d342f5ffad68d06665b1 /mail/squirrelmail-login_auth-plugin
parent3f26c432685806af221acb3e07de287f1bdd9d2b (diff)
downloadports-35f06fcd24af52d953cded5f5934c12d46bb7926.tar.gz
ports-35f06fcd24af52d953cded5f5934c12d46bb7926.zip
If you keep SquirrelMail behind a password-protected directory on your web
server and if PHP has access to the username and password, this plugin will bypass the login screen and use the provided username/password. If this plugin enabled and the information isn't present, it doesn't crash or produce error messages. It just doesn't automatically log you in. If the user/pass information does not work for the IMAP server, this still displays the login form, just in case the web server password and IMAP password are not synchronized. WWW: http://www.squirrelmail.org/plugin_view.php?id=34 PR: ports/95752 Submitted by: Stefan Bethke <stb@lassitu.de>
Notes
Notes: svn path=/head/; revision=159624
Diffstat (limited to 'mail/squirrelmail-login_auth-plugin')
-rw-r--r--mail/squirrelmail-login_auth-plugin/Makefile72
-rw-r--r--mail/squirrelmail-login_auth-plugin/distinfo3
-rw-r--r--mail/squirrelmail-login_auth-plugin/pkg-descr11
-rw-r--r--mail/squirrelmail-login_auth-plugin/pkg-plist10
4 files changed, 96 insertions, 0 deletions
diff --git a/mail/squirrelmail-login_auth-plugin/Makefile b/mail/squirrelmail-login_auth-plugin/Makefile
new file mode 100644
index 000000000000..77b71ebe4c3c
--- /dev/null
+++ b/mail/squirrelmail-login_auth-plugin/Makefile
@@ -0,0 +1,72 @@
+# New ports collection makefile for: squirrelmail-wetteronline-plugin
+# Date created: 14 April 2006
+# Whom: Stefan Bethke <stb@lassitu.de>
+#
+# $FreeBSD$
+
+PORTNAME= squirrelmail-${SQUIRREL_PLUGIN_NAME}-plugin
+PORTVERSION= 2.0
+CATEGORIES= mail www
+MASTER_SITES= http://www.squirrelmail.org/plugins/ \
+ http://alkoholix.tallence.de/www.squirrelmail.org/plugins/
+DISTNAME= ${SQUIRREL_PLUGIN_NAME}-${PORTVERSION}-1.4.0
+DIST_SUBDIR= squirrelmail
+
+MAINTAINER= stb@lassitu.de
+COMMENT= Automatically log in user based on HTTP authentication
+
+RUN_DEPENDS= ${SQUIRRELDIR}/index.php:${PORTSDIR}/mail/squirrelmail
+
+SQUIRREL_PLUGIN_NAME= login_auth
+
+.ifdef SQUIRRELDIR
+PLIST_SUB+= SQUIRRELDIR=${SQUIRRELDIR}
+SUB_LIST+= "SQUIRRELDIR=${SQUIRRELDIR}"
+.else
+. ifndef WITHOUT_WWWDIR
+SQUIRRELDIR= ${PREFIX}/www/squirrelmail
+PLIST_SUB+= SQUIRRELDIR=www/squirrelmail
+SUB_LIST+= "SQUIRRELDIR=www/squirrelmail"
+. else
+SQUIRRELDIR= ${PREFIX}/squirrelmail
+PLIST_SUB+= SQUIRRELDIR=squirrelmail
+SUB_LIST+= "SQUIRRELDIR=squirrelmail"
+. endif
+.endif
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+USE_PERL5_BUILD= yes
+USE_PHP= yes
+WANT_PHP_WEB= yes
+
+pre-everything::
+ @${ECHO} ""
+.ifndef WITHOUT_ACTIVATE
+ @${ECHO} "Activating plug-in in SquirrelMail after installation."
+ @${ECHO} "If you don't want to automatically activate the plug-in set"
+ @${ECHO} "WITHOUT_ACTIVATE=yes"
+.else
+ @${ECHO} "NOT Activating plug-in in SquirrelMail after installation."
+ @${ECHO} "If you want to automatically activate the plug-in unset"
+ @${ECHO} "WITHOUT_ACTIVATE"
+.endif
+ @${ECHO} ""
+
+do-install:
+ ${CP} -rp ${WRKSRC}/${SQUIRREL_PLUGIN_NAME} ${SQUIRRELDIR}/plugins
+ ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${SQUIRRELDIR}/plugins/${SQUIRREL_PLUGIN_NAME}
+
+post-install:
+.ifndef WITHOUT_ACTIVATE
+.if exists( ${SQUIRRELDIR}/config/config.php )
+ @${ECHO} "Activating plug-in in SquirrelMail"
+ ${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}
+.endif
+.else
+ @${ECHO} "To activate the plug-in in SquirrelMail use"
+ @${ECHO} "${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}"
+.endif
+ @${ECHO} ""
+
+.include <bsd.port.mk>
diff --git a/mail/squirrelmail-login_auth-plugin/distinfo b/mail/squirrelmail-login_auth-plugin/distinfo
new file mode 100644
index 000000000000..70674128ecf4
--- /dev/null
+++ b/mail/squirrelmail-login_auth-plugin/distinfo
@@ -0,0 +1,3 @@
+MD5 (squirrelmail/login_auth-2.0-1.4.0.tar.gz) = cec2ad5fa53c29e82f58239afe8c2ec2
+SHA256 (squirrelmail/login_auth-2.0-1.4.0.tar.gz) = 619eb5e423234e1a6ce7545605f28e0064147730503897f3fc2109f25a7f8e84
+SIZE (squirrelmail/login_auth-2.0-1.4.0.tar.gz) = 10319
diff --git a/mail/squirrelmail-login_auth-plugin/pkg-descr b/mail/squirrelmail-login_auth-plugin/pkg-descr
new file mode 100644
index 000000000000..6f1df3bf7ccc
--- /dev/null
+++ b/mail/squirrelmail-login_auth-plugin/pkg-descr
@@ -0,0 +1,11 @@
+If you keep SquirrelMail behind a password-protected directory on your web
+server and if PHP has access to the username and password, this plugin will
+bypass the login screen and use the provided username/password.
+
+If this plugin enabled and the information isn't present, it doesn't crash
+or produce error messages. It just doesn't automatically log you in. If the
+user/pass information does not work for the IMAP server, this still displays
+the login form, just in case the web server password and IMAP password are
+not synchronized.
+
+WWW: http://www.squirrelmail.org/plugin_view.php?id=34
diff --git a/mail/squirrelmail-login_auth-plugin/pkg-plist b/mail/squirrelmail-login_auth-plugin/pkg-plist
new file mode 100644
index 000000000000..577d24caccd3
--- /dev/null
+++ b/mail/squirrelmail-login_auth-plugin/pkg-plist
@@ -0,0 +1,10 @@
+@unexec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --remove-plugin login_auth; fi
+%%SQUIRRELDIR%%/plugins/login_auth/COPYING
+%%SQUIRRELDIR%%/plugins/login_auth/INSTALL
+%%SQUIRRELDIR%%/plugins/login_auth/README
+%%SQUIRRELDIR%%/plugins/login_auth/functions.php
+%%SQUIRRELDIR%%/plugins/login_auth/index.php
+%%SQUIRRELDIR%%/plugins/login_auth/setup.php
+%%SQUIRRELDIR%%/plugins/login_auth/version
+@dirrm %%SQUIRRELDIR%%/plugins/login_auth/
+@exec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --install-plugin login_auth; fi