aboutsummaryrefslogtreecommitdiff
path: root/mail/squirrelmail-notify-plugin
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2013-12-08 16:53:57 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2013-12-08 16:53:57 +0000
commitc61905043e9ff73d46dbeb97a6d9703de99d4600 (patch)
treea10c7c003855b79bd2d28f4f3d9dbed60cc28f4f /mail/squirrelmail-notify-plugin
parentd18a180211dda12cd188400e0543bc92af46cf65 (diff)
downloadports-c61905043e9ff73d46dbeb97a6d9703de99d4600.tar.gz
ports-c61905043e9ff73d46dbeb97a6d9703de99d4600.zip
- Convert remaining plugins to bsd.squirrelmail.mk.
- Change the perl5 dependency to install, which it is - Correct path in pkg-message
Notes
Notes: svn path=/head/; revision=335912
Diffstat (limited to 'mail/squirrelmail-notify-plugin')
-rw-r--r--mail/squirrelmail-notify-plugin/Makefile73
1 files changed, 13 insertions, 60 deletions
diff --git a/mail/squirrelmail-notify-plugin/Makefile b/mail/squirrelmail-notify-plugin/Makefile
index ae71aa1ec814..162d64999126 100644
--- a/mail/squirrelmail-notify-plugin/Makefile
+++ b/mail/squirrelmail-notify-plugin/Makefile
@@ -1,72 +1,25 @@
# Created by: Gerrit Beine <gerrit.beine@gmx.de>
# $FreeBSD$
-PORTNAME= squirrelmail-${SQUIRREL_PLUGIN_NAME}-plugin
-PORTVERSION= 1.3
+PORTNAME= notify
+PORTVERSION= 1.3
PORTREVISION= 1
CATEGORIES= mail www
-MASTER_SITES= http://www.squirrelmail.org/plugins/
-DISTNAME= ${SQUIRREL_PLUGIN_NAME}_${PORTVERSION:S/./_/g}
-DIST_SUBDIR= squirrelmail
+MASTER_SITES= http://www.squirrelmail.org/plugins/
+PKGNAMEPREFIX= squirrelmail-
+PKGNAMESUFFIX= -plugin
+DISTNAME= ${PORTNAME}_${PORTVERSION:S/./_/g}
+DIST_SUBDIR= squirrelmail
MAINTAINER= ports@FreeBSD.org
COMMENT= Notify when new mail arrives
-RUN_DEPENDS= ${SQUIRRELDIR}/index.php:${PORTSDIR}/mail/squirrelmail \
- ${SQUIRRELDIR}/plugins/compatibility:${PORTSDIR}/mail/squirrelmail-compatibility-plugin
-
-SQUIRREL_PLUGIN_NAME= notify
-
-.ifdef SQUIRRELDIR
-PLIST_SUB+= SQUIRRELDIR=${SQUIRRELDIR}
-SUB_LIST+= "SQUIRRELDIR=${SQUIRRELDIR}"
-.else
-. ifndef WITHOUT_WWWDIR
-SQUIRRELDIR= ${PREFIX}/www/squirrelmail
-PLIST_SUB+= SQUIRRELDIR=www/squirrelmail
-SUB_LIST+= "SQUIRRELDIR=www/squirrelmail"
-. else
-SQUIRRELDIR= ${PREFIX}/squirrelmail
-PLIST_SUB+= SQUIRRELDIR=squirrelmail
-SUB_LIST+= "SQUIRRELDIR=squirrelmail"
-. endif
-.endif
-
-USES= perl5
-NO_BUILD= yes
-NO_WRKSUBDIR= yes
-USE_PERL5= build
-USE_PHP= yes
-WANT_PHP_WEB= yes
+USES= perl5
+USE_PERL5= install
+USE_SM_COMPAT= yes
NO_STAGE= yes
-pre-everything::
- @${ECHO} ""
-.ifndef WITHOUT_ACTIVATE
- @${ECHO} "Activating plug-in in SquirrelMail after installation."
- @${ECHO} "If you don't want to automatically activate the plug-in set"
- @${ECHO} "WITHOUT_ACTIVATE=yes"
-.else
- @${ECHO} "NOT Activating plug-in in SquirrelMail after installation."
- @${ECHO} "If you want to automatically activate the plug-in unset"
- @${ECHO} "WITHOUT_ACTIVATE"
-.endif
- @${ECHO} ""
-
-do-install:
- ${CP} -rp ${WRKSRC}/${SQUIRREL_PLUGIN_NAME} ${SQUIRRELDIR}/plugins
- ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${SQUIRRELDIR}/plugins/${SQUIRREL_PLUGIN_NAME}
-
-post-install:
-.ifndef WITHOUT_ACTIVATE
-.if exists( ${SQUIRRELDIR}/config/config.php )
- @${ECHO} "Activating plug-in in SquirrelMail"
- ${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}
-.endif
-.else
- @${ECHO} "To activate the plug-in in SquirrelMail use"
- @${ECHO} "${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}"
-.endif
- @${ECHO} ""
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.include "${.CURDIR}/../squirrelmail/bsd.squirrelmail.mk"
+.include <bsd.port.post.mk>