aboutsummaryrefslogtreecommitdiff
path: root/mail/squirrelmail-plugins
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2015-01-24 15:07:39 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2015-01-24 15:07:39 +0000
commit364abe76fd9eef8f21dfc042689643cc3aee11d1 (patch)
treebf67c1bb6ae5b2f8e4074d102338a30cdf8b4cd8 /mail/squirrelmail-plugins
parent7e9d10e043b551b015afc55d516c1f0d1ee30ab2 (diff)
downloadports-364abe76fd9eef8f21dfc042689643cc3aee11d1.tar.gz
ports-364abe76fd9eef8f21dfc042689643cc3aee11d1.zip
Switch some dependencies from a directory name or a file generated by pkg-install
to a package name, as the former can't be attributed to a package
Notes
Notes: svn path=/head/; revision=377795
Diffstat (limited to 'mail/squirrelmail-plugins')
-rw-r--r--mail/squirrelmail-plugins/Makefile44
1 files changed, 22 insertions, 22 deletions
diff --git a/mail/squirrelmail-plugins/Makefile b/mail/squirrelmail-plugins/Makefile
index 73e68dd03aff..338a1fbe3c9a 100644
--- a/mail/squirrelmail-plugins/Makefile
+++ b/mail/squirrelmail-plugins/Makefile
@@ -21,70 +21,70 @@ OPTIONS_DEFINE= BUTTONS CALENDAR LDAPPW LGAUTH LGNOTES MAILFT MLOGIN \
SQLPW TIMEOUT TMDA VLOGIN WEBSEARCH WETTER
BUTTONS_DESC= Custom (spam/ham/etc.) buttons
-BUTTONS_RUN_DEPENDS= ${SQUIRRELDIR}/plugins/spam_buttons:${PORTSDIR}/mail/squirrelmail-spam-buttons-plugin
+BUTTONS_RUN_DEPENDS= squirrelmail-spam-buttons-plugin>0:${PORTSDIR}/mail/squirrelmail-spam-buttons-plugin
CALENDAR_DESC= Shared Calendars plugin
-CALENDAR_RUN_DEPENDS= ${SQUIRRELDIR}/plugins/calendar:${PORTSDIR}/mail/squirrelmail-shared_calendars-plugin
+CALENDAR_RUN_DEPENDS= squirrelmail-shared_calendars-plugin>0:${PORTSDIR}/mail/squirrelmail-shared_calendars-plugin
LDAPPW_DESC= Change LDAP passwords plugin
-LDAPPW_RUN_DEPENDS= ${SQUIRRELDIR}/plugins/change_ldappass:${PORTSDIR}/mail/squirrelmail-change_ldappass-plugin
+LDAPPW_RUN_DEPENDS= squirrelmail-change_ldappass-plugin>0:${PORTSDIR}/mail/squirrelmail-change_ldappass-plugin
LGAUTH_DESC= HTTP-auth based login plugin
-LGAUTH_RUN_DEPENDS= ${SQUIRRELDIR}/plugins/login_auth:${PORTSDIR}/mail/squirrelmail-login_auth-plugin
+LGAUTH_RUN_DEPENDS= squirrelmail-login_auth-plugin>0:${PORTSDIR}/mail/squirrelmail-login_auth-plugin
LGNOTES_DESC= Notes on login screen plugin
-LGNOTES_RUN_DEPENDS= ${SQUIRRELDIR}/plugins/login_notes:${PORTSDIR}/mail/squirrelmail-login_notes-plugin
+LGNOTES_RUN_DEPENDS= squirrelmail-login_notes-plugin>0:${PORTSDIR}/mail/squirrelmail-login_notes-plugin
MAILFT_DESC= E-mail footer plugin
-MAILFT_RUN_DEPENDS= ${SQUIRRELDIR}/plugins/email_footer:${PORTSDIR}/mail/squirrelmail-email_footer-plugin
+MAILFT_RUN_DEPENDS= squirrelmail-email_footer-plugin>0:${PORTSDIR}/mail/squirrelmail-email_footer-plugin
MLOGIN_DESC= Multilogin plugin
-MLOGIN_RUN_DEPENDS= ${SQUIRRELDIR}/plugins/multilogin:${PORTSDIR}/mail/squirrelmail-multilogin-plugin
+MLOGIN_RUN_DEPENDS= squirrelmail-multilogin-plugin>0:${PORTSDIR}/mail/squirrelmail-multilogin-plugin
NOTES_DESC= Notes plugin
-NOTES_RUN_DEPENDS= ${SQUIRRELDIR}/plugins/notes:${PORTSDIR}/mail/squirrelmail-notes-plugin
+NOTES_RUN_DEPENDS= squirrelmail-notes-plugin>0:${PORTSDIR}/mail/squirrelmail-notes-plugin
NOTIFY_DESC= New mail notify plugin
-NOTIFY_RUN_DEPENDS= ${SQUIRRELDIR}/plugins/notify:${PORTSDIR}/mail/squirrelmail-notify-plugin
+NOTIFY_RUN_DEPENDS= squirrelmail-notify-plugin>0:${PORTSDIR}/mail/squirrelmail-notify-plugin
PUPDATE_DESC= Plugin update check plugin
-PUPDATE_RUN_DEPENDS= ${SQUIRRELDIR}/plugins/pupdate:${PORTSDIR}/mail/squirrelmail-pupdate-plugin
+PUPDATE_RUN_DEPENDS= squirrelmail-pupdate-plugin>0:${PORTSDIR}/mail/squirrelmail-pupdate-plugin
PW4GET_DESC= Password forget plugin
-PW4GET_RUN_DEPENDS= ${SQUIRRELDIR}/plugins/password_forget:${PORTSDIR}/mail/squirrelmail-password_forget-plugin
+PW4GET_RUN_DEPENDS= squirrelmail-password_forget-plugin>0:${PORTSDIR}/mail/squirrelmail-password_forget-plugin
QMADMIN_DESC= Qmailadmin login plugin
-QMADMIN_RUN_DEPENDS= ${SQUIRRELDIR}/plugins/qmailadmin_login:${PORTSDIR}/mail/squirrelmail-qmailadmin_login-plugin
+QMADMIN_RUN_DEPENDS= squirrelmail-qmailadmin_login-plugin>0:${PORTSDIR}/mail/squirrelmail-qmailadmin_login-plugin
QUOTA_DESC= Quota usage plugin
-QUOTA_RUN_DEPENDS= ${SQUIRRELDIR}/plugins/quota_usage:${PORTSDIR}/mail/squirrelmail-quota_usage-plugin
+QUOTA_RUN_DEPENDS= squirrelmail-quota_usage-plugin>0:${PORTSDIR}/mail/squirrelmail-quota_usage-plugin
SASQL_DESC= SpamAssassin SQL plugin
-SASQL_RUN_DEPENDS= ${SQUIRRELDIR}/plugins/sasql:${PORTSDIR}/mail/squirrelmail-sasql-plugin
+SASQL_RUN_DEPENDS= squirrelmail-sasql-plugin>0:${PORTSDIR}/mail/squirrelmail-sasql-plugin
SIEVE_DESC= Sieve Mail Filters plugin
-SIEVE_RUN_DEPENDS= ${SQUIRRELDIR}/plugins/avelsieve:${PORTSDIR}/mail/squirrelmail-avelsieve-plugin
+SIEVE_RUN_DEPENDS= squirrelmail-avelsieve-plugin>0:${PORTSDIR}/mail/squirrelmail-avelsieve-plugin
SLOGIN_DESC= SSL login plugin
-SLOGIN_RUN_DEPENDS= ${SQUIRRELDIR}/plugins/secure_login:${PORTSDIR}/mail/squirrelmail-secure_login-plugin
+SLOGIN_RUN_DEPENDS= squirrelmail-secure_login-plugin>0:${PORTSDIR}/mail/squirrelmail-secure_login-plugin
SQLPW_DESC= Change *SQL passwords plugin
-SQLPW_RUN_DEPENDS= ${SQUIRRELDIR}/plugins/change_sqlpass:${PORTSDIR}/mail/squirrelmail-change_sqlpass-plugin
+SQLPW_RUN_DEPENDS= squirrelmail-change-sqlpass-plugin>0:${PORTSDIR}/mail/squirrelmail-change_sqlpass-plugin
TIMEOUT_DESC= User session timeout plugin
-TIMEOUT_RUN_DEPENDS= ${SQUIRRELDIR}/plugins/timeout_user:${PORTSDIR}/mail/squirrelmail-timeout_user-plugin
+TIMEOUT_RUN_DEPENDS= squirrelmail-timeout_user-plugin>0:${PORTSDIR}/mail/squirrelmail-timeout_user-plugin
TMDA_DESC= TMDA plugin
-TMDA_RUN_DEPENDS= ${SQUIRRELDIR}/plugins/tmdatools:${PORTSDIR}/mail/squirrelmail-tmda-plugin
+TMDA_RUN_DEPENDS= squirrelmail-tmda-plugin>0:${PORTSDIR}/mail/squirrelmail-tmda-plugin
VLOGIN_DESC= Multi-site-hosting capabilities plugin
-VLOGIN_RUN_DEPENDS= ${SQUIRRELDIR}/plugins/vlogin:${PORTSDIR}/mail/squirrelmail-vlogin-plugin
+VLOGIN_RUN_DEPENDS= squirrelmail-vlogin-plugin>0:${PORTSDIR}/mail/squirrelmail-vlogin-plugin
WEBSEARCH_DESC= Web search engines plugin
-WEBSEARCH_RUN_DEPENDS= ${SQUIRRELDIR}/plugins/web_search:${PORTSDIR}/mail/squirrelmail-websearch-plugin
+WEBSEARCH_RUN_DEPENDS= squirrelmail-web_search-plugin>0:${PORTSDIR}/mail/squirrelmail-websearch-plugin
WETTER_DESC= Weather in Germany plugin
-WETTER_RUN_DEPENDS= ${SQUIRRELDIR}/plugins/wetteronline:${PORTSDIR}/mail/squirrelmail-wetteronline-plugin
+WETTER_RUN_DEPENDS= squirrelmail-wetteronline-plugin>0:${PORTSDIR}/mail/squirrelmail-wetteronline-plugin
do-install: build
@${DO_NADA}