aboutsummaryrefslogtreecommitdiff
path: root/mail/squirrelmail-pupdate-plugin
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-03-16 12:55:52 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-03-16 12:55:52 +0000
commit1f2c8a158d895f6386784904d8dd2860067a9bd8 (patch)
tree945bbbed35e3dbb33ee154a81cf069b45129ac74 /mail/squirrelmail-pupdate-plugin
parent57c475431ecde378144631ee1a33903441b7f475 (diff)
downloadports-1f2c8a158d895f6386784904d8dd2860067a9bd8.tar.gz
ports-1f2c8a158d895f6386784904d8dd2860067a9bd8.zip
- Fix automatic activation
- Move toward new SM plugin configuration standard - Compat plugin not required, remove reference - Bump PORTREVISION PR: 110310 Submitted by: Thomas Abthorpe <thomas@goodking.ca> (maintainer)
Notes
Notes: svn path=/head/; revision=187509
Diffstat (limited to 'mail/squirrelmail-pupdate-plugin')
-rw-r--r--mail/squirrelmail-pupdate-plugin/Makefile17
-rw-r--r--mail/squirrelmail-pupdate-plugin/pkg-plist4
2 files changed, 13 insertions, 8 deletions
diff --git a/mail/squirrelmail-pupdate-plugin/Makefile b/mail/squirrelmail-pupdate-plugin/Makefile
index 5e7d97141001..14c53f150829 100644
--- a/mail/squirrelmail-pupdate-plugin/Makefile
+++ b/mail/squirrelmail-pupdate-plugin/Makefile
@@ -5,20 +5,22 @@
# $FreeBSD$
#
-PORTNAME= squirrelmail-${SQUIRREL_PLUGIN_NAME}-plugin
+PORTNAME= pupdate
PORTVERSION= 0.7
+PORTREVISION= 1
CATEGORIES= mail www
MASTER_SITES= http://www.squirrelmail.org/plugins/
-DISTNAME= ${SQUIRREL_PLUGIN_NAME}.${PORTVERSION}-1.4.2
+PKGNAMEPREFIX= squirrelmail-
+PKGNAMESUFFIX= -plugin
+DISTNAME= ${PORTNAME}.${PORTVERSION}-1.4.2
DIST_SUBDIR= squirrelmail
MAINTAINER= thomas@goodking.ca
COMMENT= Checks for plugin updates by parsing the SM site
-RUN_DEPENDS= ${SQUIRRELDIR}/index.php:${PORTSDIR}/mail/squirrelmail \
- ${SQUIRRELDIR}/plugins/compatibility:${PORTSDIR}/mail/squirrelmail-compatibility-plugin
+RUN_DEPENDS= ${SQUIRRELDIR}/index.php:${PORTSDIR}/mail/squirrelmail
-SQUIRREL_PLUGIN_NAME= pupdate
+SQUIRREL_PLUGIN_NAME= ${PORTNAME}
.ifdef SQUIRRELDIR
PLIST_SUB+= SQUIRRELDIR=${SQUIRRELDIR}
@@ -34,6 +36,7 @@ PLIST_SUB+= SQUIRRELDIR=squirrelmail
SUB_LIST+= "SQUIRRELDIR=squirrelmail"
.endif
.endif
+PLIST_SUB+= SQUIRREL_PLUGIN_NAME=${SQUIRREL_PLUGIN_NAME}
SUB_FILES= pkg-message
@@ -43,6 +46,8 @@ USE_PERL5_BUILD= yes
USE_PHP= yes
WANT_PHP_WEB= yes
+.include <bsd.port.pre.mk>
+
pre-everything::
@${ECHO} ""
.ifndef WITHOUT_ACTIVATE
@@ -73,4 +78,4 @@ post-install:
@${ECHO} ""
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/mail/squirrelmail-pupdate-plugin/pkg-plist b/mail/squirrelmail-pupdate-plugin/pkg-plist
index 0011274cdf9a..1c1ed7ba1445 100644
--- a/mail/squirrelmail-pupdate-plugin/pkg-plist
+++ b/mail/squirrelmail-pupdate-plugin/pkg-plist
@@ -1,4 +1,4 @@
-@unexec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --remove-plugin pupdate; fi
+@unexec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --remove-plugin %%SQUIRREL_PLUGIN_NAME%%; fi
%%SQUIRRELDIR%%/plugins/pupdate/docs/index.php
%%SQUIRRELDIR%%/plugins/pupdate/docs/INSTALL
%%SQUIRRELDIR%%/plugins/pupdate/docs/README
@@ -17,4 +17,4 @@
@dirrm %%SQUIRRELDIR%%/plugins/pupdate/docs
@dirrm %%SQUIRRELDIR%%/plugins/pupdate/udata
@dirrm %%SQUIRRELDIR%%/plugins/pupdate
-@exec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --install-plugin pupdate; fi
+@exec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --install-plugin %%SQUIRREL_PLUGIN_NAME%%; fi