aboutsummaryrefslogtreecommitdiff
path: root/mail/squirrelmail-wetteronline-plugin
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-03-20 20:53:26 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-03-20 20:53:26 +0000
commitca1122805a296a57894a82753caba070878af89b (patch)
treed9db45f997fcbf37ad33e2183a724a4be6e0a0ed /mail/squirrelmail-wetteronline-plugin
parentdb2517b755d327108c76c9e8bd199a4a9eed4b67 (diff)
downloadports-ca1122805a296a57894a82753caba070878af89b.tar.gz
ports-ca1122805a296a57894a82753caba070878af89b.zip
A little plugin for Squirrelmail showing the current weather
from WetterOnline for the users zip code. Dies ist ein kleines Plugin fur SM welches das aktuelle Wette von WetterOnline anhand der eigenen Postleitzahl anzeigt. WWW: http://www.squirrelmail.org PR: ports/93152 Submitted by: Gerrit Beine <gerrit.beine@gmx.de>
Notes
Notes: svn path=/head/; revision=157793
Diffstat (limited to 'mail/squirrelmail-wetteronline-plugin')
-rw-r--r--mail/squirrelmail-wetteronline-plugin/Makefile72
-rw-r--r--mail/squirrelmail-wetteronline-plugin/distinfo3
-rw-r--r--mail/squirrelmail-wetteronline-plugin/pkg-descr7
-rw-r--r--mail/squirrelmail-wetteronline-plugin/pkg-plist5
4 files changed, 87 insertions, 0 deletions
diff --git a/mail/squirrelmail-wetteronline-plugin/Makefile b/mail/squirrelmail-wetteronline-plugin/Makefile
new file mode 100644
index 000000000000..4cce4e9ad97e
--- /dev/null
+++ b/mail/squirrelmail-wetteronline-plugin/Makefile
@@ -0,0 +1,72 @@
+# New ports collection makefile for: squirrelmail-wetteronline-plugin
+# Date created: 10 Feb 2006
+# Whom: Gerrit Beine <gerrit.beine@gmx.de>
+#
+# $FreeBSD$
+
+PORTNAME= squirrelmail-${SQUIRREL_PLUGIN_NAME}-plugin
+PORTVERSION= 0.1
+CATEGORIES= mail www
+MASTER_SITES= http://www.squirrelmail.org/plugins/
+DISTNAME= ${SQUIRREL_PLUGIN_NAME}-${PORTVERSION}
+DIST_SUBDIR= squirrelmail
+
+MAINTAINER= gerrit.beine@gmx.de
+COMMENT= Plugin for the weather in Germany
+
+RUN_DEPENDS= ${SQUIRRELDIR}/index.php:${PORTSDIR}/mail/squirrelmail \
+ ${SQUIRRELDIR}/plugins/compatibility:${PORTSDIR}/mail/squirrelmail-compatibility-plugin
+
+SQUIRREL_PLUGIN_NAME= wetteronline
+
+.ifdef SQUIRRELDIR
+PLIST_SUB+= SQUIRRELDIR=${SQUIRRELDIR}
+SUB_LIST+= "SQUIRRELDIR=${SQUIRRELDIR}"
+.else
+. ifndef WITHOUT_WWWDIR
+SQUIRRELDIR= ${PREFIX}/www/squirrelmail
+PLIST_SUB+= SQUIRRELDIR=www/squirrelmail
+SUB_LIST+= "SQUIRRELDIR=www/squirrelmail"
+. else
+SQUIRRELDIR= ${PREFIX}/squirrelmail
+PLIST_SUB+= SQUIRRELDIR=squirrelmail
+SUB_LIST+= "SQUIRRELDIR=squirrelmail"
+. endif
+.endif
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+USE_PERL5_BUILD= yes
+USE_PHP= yes
+WANT_PHP_WEB= yes
+
+pre-everything::
+ @${ECHO} ""
+.ifndef WITHOUT_ACTIVATE
+ @${ECHO} "Activating plug-in in SquirrelMail after installation."
+ @${ECHO} "If you don't want to automatically activate the plug-in set"
+ @${ECHO} "WITHOUT_ACTIVATE=yes"
+.else
+ @${ECHO} "NOT Activating plug-in in SquirrelMail after installation."
+ @${ECHO} "If you want to automatically activate the plug-in unset"
+ @${ECHO} "WITHOUT_ACTIVATE"
+.endif
+ @${ECHO} ""
+
+do-install:
+ ${CP} -rp ${WRKSRC}/${SQUIRREL_PLUGIN_NAME} ${SQUIRRELDIR}/plugins
+ ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${SQUIRRELDIR}/plugins/${SQUIRREL_PLUGIN_NAME}
+
+post-install:
+.ifndef WITHOUT_ACTIVATE
+.if exists( ${SQUIRRELDIR}/config/config.php )
+ @${ECHO} "Activating plug-in in SquirrelMail"
+ ${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}
+.endif
+.else
+ @${ECHO} "To activate the plug-in in SquirrelMail use"
+ @${ECHO} "${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}"
+.endif
+ @${ECHO} ""
+
+.include <bsd.port.mk>
diff --git a/mail/squirrelmail-wetteronline-plugin/distinfo b/mail/squirrelmail-wetteronline-plugin/distinfo
new file mode 100644
index 000000000000..189824a92cd6
--- /dev/null
+++ b/mail/squirrelmail-wetteronline-plugin/distinfo
@@ -0,0 +1,3 @@
+MD5 (squirrelmail/wetteronline-0.1.tar.gz) = 69b7558af61aff0b948050b4543bc05e
+SHA256 (squirrelmail/wetteronline-0.1.tar.gz) = 21be41fe959f690e2b505ce1e3be3615d80b3616a5863f354456668d201d6bf1
+SIZE (squirrelmail/wetteronline-0.1.tar.gz) = 1476
diff --git a/mail/squirrelmail-wetteronline-plugin/pkg-descr b/mail/squirrelmail-wetteronline-plugin/pkg-descr
new file mode 100644
index 000000000000..a9f4e48da4bd
--- /dev/null
+++ b/mail/squirrelmail-wetteronline-plugin/pkg-descr
@@ -0,0 +1,7 @@
+A little plugin for Squirrelmail showing the current weather
+from WetterOnline for the users zip code.
+
+Dies ist ein kleines Plugin für SM welches das aktuelle Wette
+von WetterOnline anhand der eigenen Postleitzahl anzeigt.
+
+WWW: http://www.squirrelmail.org
diff --git a/mail/squirrelmail-wetteronline-plugin/pkg-plist b/mail/squirrelmail-wetteronline-plugin/pkg-plist
new file mode 100644
index 000000000000..1e69579c476f
--- /dev/null
+++ b/mail/squirrelmail-wetteronline-plugin/pkg-plist
@@ -0,0 +1,5 @@
+@unexec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --remove-plugin wetteronline; fi
+%%SQUIRRELDIR%%/plugins/wetteronline/README
+%%SQUIRRELDIR%%/plugins/wetteronline/setup.php
+@dirrm %%SQUIRRELDIR%%/plugins/wetteronline/
+@exec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --install-plugin wetteronline; fi