aboutsummaryrefslogtreecommitdiff
path: root/mail/ssmtp
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-06-04 10:32:49 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-06-04 10:32:49 +0000
commit7117487ddb38fee864033b869ed6b65f7094a29c (patch)
tree72a8cb20efc8916ac1fe7ec801ddfe0d2d0136bf /mail/ssmtp
parent1f1a5f1e120cc7ffd0b13ccf1e289a157ca7e5dd (diff)
downloadports-7117487ddb38fee864033b869ed6b65f7094a29c.tar.gz
ports-7117487ddb38fee864033b869ed6b65f7094a29c.zip
Convert to new options framework
Notes
Notes: svn path=/head/; revision=319851
Diffstat (limited to 'mail/ssmtp')
-rw-r--r--mail/ssmtp/Makefile23
1 files changed, 10 insertions, 13 deletions
diff --git a/mail/ssmtp/Makefile b/mail/ssmtp/Makefile
index d3bc977348a1..0f65fce644ae 100644
--- a/mail/ssmtp/Makefile
+++ b/mail/ssmtp/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: ssmtp
-# Date created: 9 Jan 2001
-# Whom: Tomasz Paszkowski <ns88@k.pl>
-#
+# Created by: Tomasz Paszkowski <ns88@k.pl>
# $FreeBSD$
-#
PORTNAME= ssmtp
PORTVERSION= 2.64
@@ -35,26 +31,27 @@ MAILERCONF= /etc/mail/mailer.conf
MAN8= ssmtp.8
MAN5= ssmtp.conf.5
-OPTIONS= LOGFILE "Enable log file" off \
- IPV6 "Enable IPv6 support" on \
- USERPREFS "Enable user defined revaliases" on \
- XORIGIP "Add X-Originating-IP header" on \
+OPTIONS_DEFINE= LOGFILE IPV6 USERPREFS XORIGIP
+OPTIONS_DEFINE= USERPREFS XORIGIP
+LOGFILE_DESC= log file
+USERPREFS_DESC= user defined revaliases
+XORIGIP_DESC= Add X-Originating-IP header
.include <bsd.port.options.mk>
-.if defined(WITH_LOGFILE)
+.if ${PORT_OPTIONS:MLOGFILE}
CONFIGURE_ARGS+= --enable-logfile
.endif
-.if defined(WITH_XORIGIP)
+.if ${PORT_OPTIONS:MXORIGIP}
EXTRA_PATCHES= ${FILESDIR}/remote-addr.patch
.endif
-.if !defined(WITHOUT_IPV6)
+.if ${PORT_OPTIONS:MIPV6}
CONFIGURE_ARGS+= --enable-inet6
.endif
-.if !defined(WITHOUT_USERPREFS)
+.if ${PORT_OPTIONS:MUSERPREFS}
CFLAGS+= -DUSERPREFS
pre-everything::
@${ECHO_CMD} "If you don't want to let your users set their own revalias address"