aboutsummaryrefslogtreecommitdiff
path: root/mail/sylpheed-claws
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2005-05-26 18:49:43 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2005-05-26 18:49:43 +0000
commitd3d611502817df3538ef70a80d245eb4382a6624 (patch)
tree49eecdcca3c644e9454811726c5ff573a28651e8 /mail/sylpheed-claws
parent343f60a7404aac0a2469d3bc44b8cbcedf969e40 (diff)
downloadports-d3d611502817df3538ef70a80d245eb4382a6624.tar.gz
ports-d3d611502817df3538ef70a80d245eb4382a6624.zip
Notes
Diffstat (limited to 'mail/sylpheed-claws')
-rw-r--r--mail/sylpheed-claws/Makefile58
-rw-r--r--mail/sylpheed-claws/distinfo4
-rw-r--r--mail/sylpheed-claws/files/patch-po-Makefile.in.in31
-rw-r--r--mail/sylpheed-claws/pkg-plist15
4 files changed, 38 insertions, 70 deletions
diff --git a/mail/sylpheed-claws/Makefile b/mail/sylpheed-claws/Makefile
index 35209d1be701..5bacabfaed38 100644
--- a/mail/sylpheed-claws/Makefile
+++ b/mail/sylpheed-claws/Makefile
@@ -6,12 +6,11 @@
#
PORTNAME= sylpheed-claws
-PORTVERSION= 1.0.4a
+PORTVERSION= 1.9.11
#PORTREVISION= 1
CATEGORIES= mail news ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= sylpheed-claws
-#DISTNAME= sylpheed-${PORTVERSION}claws
DISTFILES= ${EXTRACT_ONLY} \
${THEMEFILE}
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
@@ -30,20 +29,32 @@ USE_GMAKE= yes
USE_ICONV= yes
USE_X_PREFIX= yes
USE_LIBTOOL_VER=15
-USE_GNOME= gnomehack pkgconfig gtk12
+USE_GNOME= gnomehack pkgconfig gtk20
USE_REINPLACE= yes
WANT_GNOME= yes
MAN1= sylpheed-claws.1
+CONFIGURE_ARGS= --program-suffix="-claws" --enable-ipv6 \
+ --with-libiconv-prefix=${LOCALBASE}
+
+CONFIGURE_ENV= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}" \
+ CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${X11BASE}/lib -L${LOCALBASE}/lib" \
+ OPENSSL_CFLAGS="-I${OPENSSLINC}" \
+ OPENSSL_LIBS="-L${OPENSSLLIB} -lcrypto -lssl" \
+ LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+
.if defined(NOPORTDOCS)
EXTRA_PATCHES= ${FILESDIR}/extra-doc:Makefile.in
.endif
.if !defined(WITHOUT_SSL)
USE_OPENSSL= yes
-CONFIGURE_ARGS= --enable-openssl --with-openssl-includes=${OPENSSLINC} \
+CONFIGURE_ARGS+= --enable-openssl --with-openssl-includes=${OPENSSLINC} \
--with-openssl-libs=${OPENSSLLIB}
+.else
+CONFIGURE_ARGS+= --disable-openssl
.endif
.include <bsd.port.pre.mk>
@@ -66,29 +77,18 @@ PLIST_SUB+= GNOME=""
PLIST_SUB+= GNOME="@comment "
.endif
-CONFIGURE_ARGS+= --program-suffix="-claws" --enable-ipv6
-
-CONFIGURE_ENV= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}" CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
- LIBS="-L${X11BASE}/lib -L${LOCALBASE}/lib ${PTHREAD_LIBS}"
-
.if exists(${LOCALBASE}/include/clamav.h)
WITH_CLAMAV= yes
.endif
.if defined(WITH_CLAMAV) || defined(WITH_ALL)
+CONFIGURE_ARGS+= --enable-clamav
PLIST_SUB+= CLAM_PLUG=""
BUILD_DEPENDS= ${LOCALBASE}/sbin/clamd:${PORTSDIR}/security/clamav
.else
CONFIGURE_ARGS+= --disable-clamav
PLIST_SUB+= CLAM_PLUG="@comment "
.endif
-.if defined(WITH_PIXBUF) || defined(WITH_ALL)
-USE_GNOME+= gdkpixbuf
-CONFIGURE_ARGS+= --disable-imlib
-.else
-USE_GNOME+= imlib
-CONFIGURE_ARGS+= --disable-gdk-pixbuf
-.endif
.if defined(WITH_COMPFACE) || defined(WITH_ALL)
LIB_DEPENDS+= compface.1:${PORTSDIR}/mail/faces
CONFIGURE_ARGS+= --enable-compface
@@ -96,6 +96,7 @@ CONFIGURE_ARGS+= --enable-compface
CONFIGURE_ARGS+= --disable-compface
.endif
.if defined(WITH_JCONV) || defined(WITH_ALL)
+CONFIGURE_ARGS+= --enable-jconv
LIB_DEPENDS+= jconv.0:${PORTSDIR}/japanese/libjconv
.else
CONFIGURE_ARGS+= --disable-jconv
@@ -103,6 +104,8 @@ CONFIGURE_ARGS+= --disable-jconv
.if defined(WITH_ASPELL) || defined(WITH_ALL)
LIB_DEPENDS+= pspell.16:${PORTSDIR}/textproc/aspell
CONFIGURE_ARGS+= --enable-aspell
+.else
+CONFIGURE_ARGS+= --disable-aspell
.endif
.if defined(WITH_JPILOT) || defined(WITH_ALL)
LIB_DEPENDS+= pisock.8:${PORTSDIR}/palm/pilot-link
@@ -114,33 +117,31 @@ CONFIGURE_ARGS+= --disable-jpilot
.if defined(WITH_LDAP) || defined(WITH_ALL)
USE_OPENLDAP= yes
CONFIGURE_ARGS+= --enable-ldap
+.else
+CONFIGURE_ARGS+= --enable-ldap
.endif
.if defined(WITH_SA_PLUG) || defined(WITH_ALL)
RUN_DEPENDS+= spamd:${PORTSDIR}/mail/p5-Mail-SpamAssassin
CONFIGURE_ARGS+= --enable-spamassassin-plugin
PLIST_SUB+= SA_PLUG=""
.else
+CONFIGURE_ARGS+= --disable-spamassassin-plugin
PLIST_SUB+= SA_PLUG="@comment "
.endif
.if defined(WITH_GPGME) || defined(WITH_ALL)
-PLIST_SUB+= GPGME=""
-LIB_DEPENDS+= gpgme03.9:${PORTSDIR}/security/gpgme03
-RUN_DEPENDS+= gpg:${PORTSDIR}/security/gnupg
+PLIST_SUB+= GPGME=""
+CONFIGURE_ARGS+= --enable-pgpmime-plugin
+LIB_DEPENDS+= gpgme03.9:${PORTSDIR}/security/gpgme03
+RUN_DEPENDS+= gpg:${PORTSDIR}/security/gnupg
.else
-PLIST_SUB+= GPGME="@comment "
-CONFIGURE_ARGS+= --disable-pgpmime-plugin
+PLIST_SUB+= GPGME="@comment "
+CONFIGURE_ARGS+= --disable-pgpmime-plugin
.endif
.if defined(WITHOUT_THEMES)
PLIST_SUB+= THEMES="@comment "
.else
PLIST_SUB+= THEMES=""
.endif
-.if defined(WITHOUT_IMAGE)
-PLIST_SUB+= IMAGE="@comment "
-CONFIGURE_ARGS+= --disable-image-viewer-plugin
-.else
-PLIST_SUB+= IMAGE=""
-.endif
pre-everything::
@${ECHO} ""
@@ -148,7 +149,6 @@ pre-everything::
@${ECHO} ""
@${ECHO} " WITH_ALL Enable all options below"
@${ECHO} ""
- @${ECHO} " WITH_PIXBUF Enable GDK Pixbuf support"
@${ECHO} " WITH_COMPFACE Enable compface (X-Face) support"
@${ECHO} " WITH_GPGME Build the pgpmime plugin"
@${ECHO} " WITH_JCONV Enable enhanced charset conversion"
@@ -159,7 +159,6 @@ pre-everything::
@${ECHO} " WITH_CLAMAV Build Clamav antivirus plugin"
@${ECHO} ""
@${ECHO} " WITHOUT_SSL Disable OpenSSL support"
- @${ECHO} " WITHOUT_IMAGE Disable internal image viewer"
@${ECHO} " WITHOUT_THEMES Don't install additional themes"
@${ECHO} ""
@@ -176,7 +175,6 @@ post-patch:
@${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" \
${WRKSRC}/tools/README.sylprint ${WRKSRC}/tools/sylprint.pl
@${REINPLACE_CMD} -e "s|po intl src|po src| ; s:@SYLPHEED_GNOME:#@SYLPHEED_GNOME:g" ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e 's:%%OPENSSL_LIBS%%:"-lssl -lcrypto":g' ${WRKSRC}/configure
@for f in `${FIND} ${WRKSRC}/tools -type f -print`; do \
${REINPLACE_CMD} -e "s|/usr/bin/perl|${PERL}|" $$f; done
# @${LN} -s ${WRKSRC}/po/sylpheed.pot ${WRKSRC}/po/${PORTNAME}.pot
diff --git a/mail/sylpheed-claws/distinfo b/mail/sylpheed-claws/distinfo
index 281941d28904..9fb622220b3a 100644
--- a/mail/sylpheed-claws/distinfo
+++ b/mail/sylpheed-claws/distinfo
@@ -1,4 +1,4 @@
-MD5 (sylpheed-claws-1.0.4a.tar.bz2) = 5179d65225d443c89538249d70dca1ab
-SIZE (sylpheed-claws-1.0.4a.tar.bz2) = 3241041
+MD5 (sylpheed-claws-1.9.11.tar.bz2) = 20e5d1796c45ef93520fb3b6defbf857
+SIZE (sylpheed-claws-1.9.11.tar.bz2) = 3233166
MD5 (sylpheed-iconset-20040929.tar.gz) = d72cf03bf3d13cf9e2785eaca3807707
SIZE (sylpheed-iconset-20040929.tar.gz) = 1298891
diff --git a/mail/sylpheed-claws/files/patch-po-Makefile.in.in b/mail/sylpheed-claws/files/patch-po-Makefile.in.in
deleted file mode 100644
index 007d2a254062..000000000000
--- a/mail/sylpheed-claws/files/patch-po-Makefile.in.in
+++ /dev/null
@@ -1,31 +0,0 @@
---- po/Makefile.in.in.orig Sat Jun 21 20:49:51 2003
-+++ po/Makefile.in.in Sun Jul 27 14:05:49 2003
-@@ -8,7 +8,7 @@
- # Please note that the actual code of GNU gettext is covered by the GNU
- # General Public License and is *not* in the public domain.
-
--PACKAGE = @PACKAGE@
-+PACKAGE = sylpheed
- VERSION = @VERSION@
-
- SHELL = /bin/sh
-@@ -44,7 +44,7 @@
- DUMMYPOFILES = @DUMMYPOFILES@
- DISTFILES.common = Makefile.in.in remove-potcdate.sin \
- $(DISTFILES.common.extra1) $(DISTFILES.common.extra2) $(DISTFILES.common.extra3)
--DISTFILES = $(DISTFILES.common) Makevars POTFILES.in $(DOMAIN).pot stamp-po \
-+DISTFILES = $(DISTFILES.common) Makevars POTFILES.in sylpheed.pot stamp-po \
- $(POFILES) $(GMOFILES) \
- $(DISTFILES.extra1) $(DISTFILES.extra2) $(DISTFILES.extra3)
-
-@@ -158,8 +158,8 @@
- dir=$(localedir)/$$lang/LC_MESSAGES; \
- $(mkinstalldirs) $(DESTDIR)$$dir; \
- if test -r $$cat; then realcat=$$cat; else realcat=$(srcdir)/$$cat; fi; \
-- $(INSTALL_DATA) $$realcat $(DESTDIR)$$dir/$(DOMAIN).mo; \
-- echo "installing $$realcat as $(DESTDIR)$$dir/$(DOMAIN).mo"; \
-+ $(INSTALL_DATA) $$realcat $(DESTDIR)$$dir/$(DOMAIN)-claws.mo; \
-+ echo "installing $$realcat as $(DESTDIR)$$dir/$(DOMAIN)-claws.mo"; \
- for lc in '' $(EXTRA_LOCALE_CATEGORIES); do \
- if test -n "$$lc"; then \
- if (cd $(DESTDIR)$(localedir)/$$lang && LC_ALL=C ls -l -d $$lc 2>/dev/null) | grep ' -> ' >/dev/null; then \
diff --git a/mail/sylpheed-claws/pkg-plist b/mail/sylpheed-claws/pkg-plist
index 874cbde54152..817a8bbc6cc9 100644
--- a/mail/sylpheed-claws/pkg-plist
+++ b/mail/sylpheed-claws/pkg-plist
@@ -1,5 +1,3 @@
-%%DATADIR%%/update-po
-%%DATADIR%%/uudec
bin/sylpheed-claws
bin/sylpheed-switcher
bin/sylprint.pl
@@ -27,7 +25,6 @@ include/sylpheed-claws/codeconv.h
include/sylpheed-claws/common/base64.h
include/sylpheed-claws/common/defs.h
include/sylpheed-claws/common/hooks.h
-include/sylpheed-claws/common/intl.h
include/sylpheed-claws/common/log.h
include/sylpheed-claws/common/md5.h
include/sylpheed-claws/common/mgutils.h
@@ -85,7 +82,6 @@ include/sylpheed-claws/gtk/foldersort.h
include/sylpheed-claws/gtk/gtkaspell.h
include/sylpheed-claws/gtk/gtksctree.h
include/sylpheed-claws/gtk/gtkshruler.h
-include/sylpheed-claws/gtk/gtkstext.h
include/sylpheed-claws/gtk/gtkutils.h
include/sylpheed-claws/gtk/gtkvscrollbutton.h
include/sylpheed-claws/gtk/inputdialog.h
@@ -97,8 +93,10 @@ include/sylpheed-claws/gtk/prefswindow.h
include/sylpheed-claws/gtk/progressdialog.h
include/sylpheed-claws/gtk/quicksearch.h
include/sylpheed-claws/gtk/sslcertwindow.h
+include/sylpheed-claws/gtk/sylpheed-marshal.h
include/sylpheed-claws/headerview.h
include/sylpheed-claws/html.h
+include/sylpheed-claws/image_viewer.h
include/sylpheed-claws/imap.h
include/sylpheed-claws/imap_gtk.h
include/sylpheed-claws/import.h
@@ -151,6 +149,7 @@ include/sylpheed-claws/prefs_filtering_action.h
include/sylpheed-claws/prefs_folder_item.h
include/sylpheed-claws/prefs_fonts.h
include/sylpheed-claws/prefs_gtk.h
+include/sylpheed-claws/prefs_image_viewer.h
include/sylpheed-claws/prefs_matcher.h
include/sylpheed-claws/prefs_msg_colors.h
include/sylpheed-claws/prefs_spelling.h
@@ -181,9 +180,10 @@ include/sylpheed-claws/toolbar.h
include/sylpheed-claws/undo.h
include/sylpheed-claws/unmime.h
include/sylpheed-claws/vcard.h
-libdata/pkgconfig/sylpheed-claws.pc
+include/sylpheed-claws/wizard.h
lib/sylpheed-claws/plugins/dillo_viewer.so
lib/sylpheed-claws/plugins/trayicon.so
+libdata/pkgconfig/sylpheed-claws.pc
@dirrm include/sylpheed-claws/common
@dirrm include/sylpheed-claws/gtk
%%GPGME%%@dirrm include/sylpheed-claws/plugins/pgpmime
@@ -191,7 +191,6 @@ lib/sylpheed-claws/plugins/trayicon.so
@dirrm include/sylpheed-claws
%%CLAM_PLUG%%lib/sylpheed-claws/plugins/clamav_plugin.so
%%CLAM_PLUG%%lib/sylpheed-claws/plugins/clamav_plugin_gtk.so
-%%IMAGE%%lib/sylpheed-claws/plugins/image_viewer.so
%%GPGME%%lib/sylpheed-claws/plugins/pgpmime.so
%%SA_PLUG%%lib/sylpheed-claws/plugins/spamassassin.so
%%SA_PLUG%%lib/sylpheed-claws/plugins/spamassassin_gtk.so
@@ -236,7 +235,6 @@ lib/sylpheed-claws/plugins/trayicon.so
%%PORTDOCS%%%%DOCSDIR%%/manual/de/sylpheed-18.html
%%PORTDOCS%%%%DOCSDIR%%/manual/de/sylpheed-19.html
%%PORTDOCS%%%%DOCSDIR%%/manual/de/sylpheed-2.html
-%%PORTDOCS%%%%DOCSDIR%%/manual/en/sylpheed-22.html
%%PORTDOCS%%%%DOCSDIR%%/manual/de/sylpheed-20.html
%%PORTDOCS%%%%DOCSDIR%%/manual/de/sylpheed-3.html
%%PORTDOCS%%%%DOCSDIR%%/manual/de/sylpheed-4.html
@@ -260,6 +258,7 @@ lib/sylpheed-claws/plugins/trayicon.so
%%PORTDOCS%%%%DOCSDIR%%/manual/en/sylpheed-2.html
%%PORTDOCS%%%%DOCSDIR%%/manual/en/sylpheed-20.html
%%PORTDOCS%%%%DOCSDIR%%/manual/en/sylpheed-21.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/en/sylpheed-22.html
%%PORTDOCS%%%%DOCSDIR%%/manual/en/sylpheed-3.html
%%PORTDOCS%%%%DOCSDIR%%/manual/en/sylpheed-4.html
%%PORTDOCS%%%%DOCSDIR%%/manual/en/sylpheed-5.html
@@ -377,6 +376,8 @@ share/pixmaps/sylpheed-claws.png
%%DATADIR%%/outlook2sylpheed.pl
%%DATADIR%%/tb2sylpheed
%%DATADIR%%/textviewer.sh
+%%DATADIR%%/update-po
+%%DATADIR%%/uudec
%%DATADIR%%/vcard2xml.py
%%THEMES%%%%DATADIR%%/themes/Crystal/.sylpheed_themeinfo
%%THEMES%%%%DATADIR%%/themes/Crystal/close.xpm