aboutsummaryrefslogtreecommitdiff
path: root/mail/sympa
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2014-03-25 20:57:30 +0000
committerChris Rees <crees@FreeBSD.org>2014-03-25 20:57:30 +0000
commit77623ac9de2ab706a08080558bc3db0d853d3854 (patch)
tree8e713b75e14465a967140f510937f8c663946ad8 /mail/sympa
parentf8d56b3f61f92f9aecf84ec626065ae1bae586bf (diff)
downloadports-77623ac9de2ab706a08080558bc3db0d853d3854.tar.gz
ports-77623ac9de2ab706a08080558bc3db0d853d3854.zip
Update to 6.1.20
PR: ports/187573 Submitted by: Geoffroy Desvernay
Notes
Notes: svn path=/head/; revision=349194
Diffstat (limited to 'mail/sympa')
-rw-r--r--mail/sympa/Makefile10
-rw-r--r--mail/sympa/distinfo4
-rw-r--r--mail/sympa/files/patch-Makefile.in30
-rw-r--r--mail/sympa/pkg-plist6
4 files changed, 35 insertions, 15 deletions
diff --git a/mail/sympa/Makefile b/mail/sympa/Makefile
index a13e586b51e4..ae1331b5106d 100644
--- a/mail/sympa/Makefile
+++ b/mail/sympa/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= sympa
-PORTVERSION= 6.1.17
-PORTREVISION= 1
+PORTVERSION= 6.1.20
CATEGORIES= mail
MASTER_SITES= http://www.sympa.org/distribution/ \
http://www.sympa.org/distribution/old/
@@ -127,7 +126,7 @@ post-patch:
-e 's|^\( *bouncedir=\).*$$|\1${DATADIR}/bounce|' \
-e 's|^\( *execcgidir=\).*$$|\1${PREFIX}/libexec/${PORTNAME}|' \
${WRKSRC}/configure
- ${REINPLACE_CMD} -e 's|\(--target.*sympa.conf\)|\1.sample|' \
+ @${REINPLACE_CMD} -e 's|\(--target.*sympa.conf\)|\1.sample|' \
-e 's|/bin/true$$|:|' \
${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's#\$$(DESTDIR)\$$(sampledir)#${STAGEDIR}\$$(sampledir)#g' \
@@ -140,11 +139,12 @@ post-install:
for dir in $$(sort ${WRKSRC}/createddirs); do \
${MKDIR} -m755 ${STAGEDIR}$$dir; \
${TOUCH} ${STAGEDIR}$$dir/.keep; \
- ${ECHO_CMD} "@exec chown ${USERS}:${GROUPS} $${dir#${PREFIX}/}" >> ${TMPPLIST}; \
+ ${ECHO_CMD} "@exec ${CHOWN} ${USERS}:${GROUPS} $${dir#${PREFIX}/}" >> ${TMPPLIST}; \
${ECHO_CMD} "$${dir#${PREFIX}/}/.keep" >> ${TMPPLIST}; \
done; \
for dir in $$(sort -r ${WRKSRC}/createddirs); do \
- ${ECHO_CMD} "@unexec rmdir $$dir" >> ${TMPPLIST}; \
+ ${ECHO_CMD} "@unexec ${RMDIR} $$dir" >> ${TMPPLIST}; \
done
+ ${INSTALL_DATA} ${WRKSRC}/etc_README ${STAGEDIR}/${ETCDIR}
.include <bsd.port.mk>
diff --git a/mail/sympa/distinfo b/mail/sympa/distinfo
index 1125bf1d2327..2404197422d3 100644
--- a/mail/sympa/distinfo
+++ b/mail/sympa/distinfo
@@ -1,2 +1,2 @@
-SHA256 (sympa-6.1.17.tar.gz) = a506ea6e9c88c4a91d22bf146acb06fae5c277e98312b957bdae974739145b79
-SIZE (sympa-6.1.17.tar.gz) = 7881215
+SHA256 (sympa-6.1.20.tar.gz) = b0afe73166e9c3427944bd47bfb07143bfc4a749a468e060370c5fe8c0b75dc5
+SIZE (sympa-6.1.20.tar.gz) = 8267233
diff --git a/mail/sympa/files/patch-Makefile.in b/mail/sympa/files/patch-Makefile.in
index e05b6c10a1c2..dfa50fb50935 100644
--- a/mail/sympa/files/patch-Makefile.in
+++ b/mail/sympa/files/patch-Makefile.in
@@ -2,9 +2,9 @@ Avoid chown before install, to avoid using root.
createddirs is read in Makefile and processed there
---- Makefile.in.orig 2013-02-05 14:57:30.000000000 +0000
-+++ Makefile.in 2014-01-01 20:07:50.489335639 +0000
-@@ -631,12 +631,9 @@
+--- Makefile.in.orig 2014-02-05 15:08:23.000000000 +0100
++++ Makefile.in 2014-03-14 10:42:06.143965800 +0100
+@@ -639,12 +639,7 @@
$(spooldir)/moderation $(spooldir)/expire $(spooldir)/auth \
$(spooldir)/outgoing $(spooldir)/tmp $(spooldir)/task \
$(bouncedir) $(arcdir) $(piddir) $(staticdir) $(sysconfdir); do \
@@ -15,17 +15,35 @@ createddirs is read in Makefile and processed there
- chown $(USER) $(DESTDIR)$$dir || /bin/true; \
- chgrp $(GROUP) $(DESTDIR)$$dir || /bin/true; \
+ echo "$${dir}" >> createddirs; \
-+ \
-+ \
done
installconfig: installdir
-@@ -668,8 +665,6 @@
+@@ -676,27 +671,12 @@
echo "# automatically created file" >> data_structure.version; \
echo "# you should not modify it" >> data_structure.version; \
echo $(VERSION) >> data_structure.version; \
- chown $(USER) data_structure.version || /bin/true; \
- chgrp $(GROUP) data_structure.version || /bin/true; \
fi
+ @for dir in create_list_templates families \
+ global_task_models list_task_models scenari search_filters \
+ mail_tt2 web_tt2; do \
+- if [ ! -d $(DESTDIR)$(sysconfdir)/$$dir ] ; then \
+- echo "Creating $(DESTDIR)$(sysconfdir)/$$dir"; \
+- install -d -m 755 $(DESTDIR)$(sysconfdir)/$$dir; \
+- fi; \
+- chown $(USER) $(DESTDIR)$(sysconfdir)/$$dir || /bin/true; \
+- chgrp $(GROUP) $(DESTDIR)$(sysconfdir)/$$dir || /bin/true; \
++ echo "$(DESTDIR)$(sysconfdir)/$${dir}" >> createddirs; \
+ done
+- @if [ ! -e $(DESTDIR)$(sysconfdir)/README ]; then \
+- echo "Creating $(DESTDIR)$(sysconfdir)/README"; \
+- $(SED) \
+- -e 's|--sysconfdir--|$(sysconfdir)|' \
+- -e 's|--defaultdir--|$(defaultdir)|' \
+- etc_README > $(DESTDIR)$(sysconfdir)/README; \
+- chmod 444 $(DESTDIR)$(sysconfdir)/README; \
+- fi
nextstep:
+ @echo ""
diff --git a/mail/sympa/pkg-plist b/mail/sympa/pkg-plist
index 2695b759139e..957c10e48279 100644
--- a/mail/sympa/pkg-plist
+++ b/mail/sympa/pkg-plist
@@ -38,7 +38,6 @@ libexec/sympa/Upgrade.pm
libexec/sympa/WebAgent.pm
libexec/sympa/admin.pm
libexec/sympa/alias_manager.pl
-libexec/sympa/aliaswrapper
libexec/sympa/arc2webarc.pl
libexec/sympa/archived.pl
libexec/sympa/bounced.pl
@@ -61,6 +60,8 @@ libexec/sympa/mysql_alias_manager.pl
libexec/sympa/p12topem.pl
libexec/sympa/queue
libexec/sympa/report.pm
+libexec/sympa/sympa_newaliases-wrapper
+libexec/sympa/sympa_newaliases.pl
libexec/sympa/sympa.pl
libexec/sympa/sympa_soap_client.pl
libexec/sympa/sympa_soap_server-wrapper.fcgi
@@ -74,7 +75,6 @@ libexec/sympa/time_utils.pm
libexec/sympa/tools.pm
libexec/sympa/tpl2tt2.pl
libexec/sympa/tt2.pm
-libexec/sympa/virtualwrapper
libexec/sympa/wwslib.pm
libexec/sympa/wwsympa-wrapper.fcgi
libexec/sympa/wwsympa.fcgi
@@ -586,3 +586,5 @@ man/man8/sympa.8.gz
@dirrm libexec/sympa/Marc
@dirrm libexec/sympa/HTML
@dirrm libexec/sympa
+@dirrmtry %%DATADIR%%/icons
+@dirrmtry %%DATADIR%%