aboutsummaryrefslogtreecommitdiff
path: root/mail/tpop3d
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2005-03-12 16:29:57 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2005-03-12 16:29:57 +0000
commit0786e76dd7cc2bc72a663fa55861bdc542a340e5 (patch)
treef174b5d8dc07715df494288938dc79f0e70c1683 /mail/tpop3d
parenta2bc1c2c4c0a84265208dc47cf38798043f21256 (diff)
downloadports-0786e76dd7cc2bc72a663fa55861bdc542a340e5.tar.gz
ports-0786e76dd7cc2bc72a663fa55861bdc542a340e5.zip
Second patch form the PR was missed
- Found serious OPTIONS interaction errors. Fixed. PR: ports/78723 Submitted by: Boris Kovalenko <boris@tagnet.ru> (maintainer)
Notes
Notes: svn path=/head/; revision=131028
Diffstat (limited to 'mail/tpop3d')
-rw-r--r--mail/tpop3d/Makefile8
-rw-r--r--mail/tpop3d/files/tpop3d.sh.in2
2 files changed, 8 insertions, 2 deletions
diff --git a/mail/tpop3d/Makefile b/mail/tpop3d/Makefile
index 5e34033075e9..d50a7e41b879 100644
--- a/mail/tpop3d/Makefile
+++ b/mail/tpop3d/Makefile
@@ -14,6 +14,7 @@ MASTER_SITES= http://www.ex-parrot.com/~chris/tpop3d/
MAINTAINER= boris@tagnet.ru
COMMENT= Virtual-domain capable POP3 server supporting MySQL,PgSQL etc auth
+IS_INTERACTIVE= yes
USE_OPENSSL= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
@@ -30,8 +31,13 @@ OPTIONS= MYSQL "Use MySQL authentication" off \
FLATAUTH "Enable /etc/passwd-style authentication" off \
MAILDIR "Compile Maildir support" on
+.include <bsd.port.pre.mk>
+
# MySQL authentication
.if defined(WITH_MYSQL) && !defined(WITHOUT_MYSQL)
+.if defined(WITH_PGSQL) && !defined(WITHOUT_PGSQL)
+IGNORE= MySQL and PgSQL authentication can not be build together
+.endif
USE_MYSQL= yes
DEFAULT_MYSQL_VER= 41
CONFIGURE_ARGS+= --enable-auth-mysql \
@@ -93,4 +99,4 @@ post-install:
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/mail/tpop3d/files/tpop3d.sh.in b/mail/tpop3d/files/tpop3d.sh.in
index 449eacd2d133..b20241c0d0b9 100644
--- a/mail/tpop3d/files/tpop3d.sh.in
+++ b/mail/tpop3d/files/tpop3d.sh.in
@@ -33,7 +33,7 @@ tpop3d_flags=${tpop3d_flags:-""}
load_rc_config $name
command=%%PREFIX%%/sbin/tpop3d
-required_files=%%PREFIX%%/tpop3d.conf
+required_files=%%PREFIX%%/etc/tpop3d.conf
pidfile=/var/run/tpop3d.pid
tpop3d_flags="${tpop3d_flags} -f ${required_files} -p ${pidfile}"