aboutsummaryrefslogtreecommitdiff
path: root/mail/vacation
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-02-16 08:56:01 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-02-16 08:56:01 +0000
commit9baae60769005dc5af0b8f68eb2a6d72d6564716 (patch)
tree57d4725a763a0803fc0efe8f038a0d618034fad5 /mail/vacation
parented2443928881b2b90c1a4e2c3666d33663cd52ff (diff)
downloadports-9baae60769005dc5af0b8f68eb2a6d72d6564716.tar.gz
ports-9baae60769005dc5af0b8f68eb2a6d72d6564716.zip
This is a port of vacation which is an email autoresponder commonly
used when taking a vacation / holiday / leave of absence. WWW: http://www.linux.it/~md/software/ PR: ports/120309 Submitted by: Adam McDougall <mcdouga9 at egr.msu.edu>
Notes
Notes: svn path=/head/; revision=207293
Diffstat (limited to 'mail/vacation')
-rw-r--r--mail/vacation/Makefile40
-rw-r--r--mail/vacation/distinfo3
-rw-r--r--mail/vacation/pkg-descr4
3 files changed, 47 insertions, 0 deletions
diff --git a/mail/vacation/Makefile b/mail/vacation/Makefile
new file mode 100644
index 000000000000..5602daa41219
--- /dev/null
+++ b/mail/vacation/Makefile
@@ -0,0 +1,40 @@
+# ex:ts=8
+# New ports collection makefile for: vacation
+# Date created: 01/30/2008
+# Whom: Adam McDougall <mcdouga9@egr.msu.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= vacation
+PORTVERSION= 3.3.0
+CATEGORIES= mail
+MASTER_SITES= ${MASTER_SITE_DEBIAN}
+MASTER_SITE_SUBDIR= pool/main/v/vacation/
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= mcdouga9@egr.msu.edu
+COMMENT= A email autoresponder, similar to vacation from sendmail
+
+USE_BDB= yes
+CFLAGS+= -L${LOCALBASE}/lib
+
+MAN1= vacation.1
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+PLIST_FILES= bin/vacation
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-ldb|-l${BDB_LIB_NAME}|g' \
+ ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|CFLAGS=|CFLAGS+=|g' \
+ ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|-O2||g' \
+ ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/vacation ${PREFIX}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/vacation.1 ${PREFIX}/man/man1/
+
+.include <bsd.port.mk>
diff --git a/mail/vacation/distinfo b/mail/vacation/distinfo
new file mode 100644
index 000000000000..26e56f5c9775
--- /dev/null
+++ b/mail/vacation/distinfo
@@ -0,0 +1,3 @@
+MD5 (vacation_3.3.0.tar.gz) = 28417eb1c08f7940ca15fe5fc7ffe5b2
+SHA256 (vacation_3.3.0.tar.gz) = 86b3412cacd86101302e153b289c4781cbbf82f50125a4eae155496e7ca0a32b
+SIZE (vacation_3.3.0.tar.gz) = 11037
diff --git a/mail/vacation/pkg-descr b/mail/vacation/pkg-descr
new file mode 100644
index 000000000000..4fed901d3a03
--- /dev/null
+++ b/mail/vacation/pkg-descr
@@ -0,0 +1,4 @@
+This is a port of vacation which is an email autoresponder commonly
+used when taking a vacation / holiday / leave of absence.
+
+WWW: http://www.linux.it/~md/software/