aboutsummaryrefslogtreecommitdiff
path: root/mail/vbsfilter
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2001-08-01 10:47:45 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2001-08-01 10:47:45 +0000
commit1c0cfaec29996431b93a3f25f5065740e01848e1 (patch)
tree941d2ce9b908d976135388ec0c2ebc16d92588b4 /mail/vbsfilter
parentb0ecd8ac69f939e813f3a23e0654cdc876a1e67f (diff)
downloadports-1c0cfaec29996431b93a3f25f5065740e01848e1.tar.gz
ports-1c0cfaec29996431b93a3f25f5065740e01848e1.zip
- Fix build on current, as PTHREAD_CFLAGS generates an empty argument.
cd /tmp/a/ports/mail/vbsfilter/work/vbsfilter-1.3 && cc -O -pipe -Wall -I/usr/local/include "" -L/usr/local/lib -o vbsfilter-1.3 vbsfilter-1.3.c -lmilter -lsmutil "-lc_r" cc: : No such file or directory *** Error code 1 using: ${PTHREAD_CFLAGS:S=""==}
Notes
Notes: svn path=/head/; revision=45697
Diffstat (limited to 'mail/vbsfilter')
-rw-r--r--mail/vbsfilter/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/mail/vbsfilter/Makefile b/mail/vbsfilter/Makefile
index fc3f959ce62f..7ace4829c94d 100644
--- a/mail/vbsfilter/Makefile
+++ b/mail/vbsfilter/Makefile
@@ -18,7 +18,7 @@ MAINTAINER= dinoex@FreeBSD.org
BUILD_DEPENDS= ${LOCALBASE}/lib/libmilter.a:${PORTSDIR}/mail/sendmail
CTARGETS+= vbsfilter-1.3
-CFLAGS+= -Wall -I$(LOCALBASE)/include ${PTHREAD_CFLAGS}
+CFLAGS+= -Wall -I$(LOCALBASE)/include ${PTHREAD_CFLAGS:S=""==}
FLAGS+= ${PTHREAD_LIBS}
LDFLAGS+= -L$(LOCALBASE)/lib
LIBS+= -lmilter -lsmutil