aboutsummaryrefslogtreecommitdiff
path: root/mail/vbsfilter
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2001-10-12 10:13:49 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2001-10-12 10:13:49 +0000
commit3d1ed214aa571a36316f3e78133a59e0ce290463 (patch)
tree8c978340dbc5fb2611109586afba127f15a8e3b0 /mail/vbsfilter
parentc1dd86b94f5d8c8150a6c06e7aa3bd959eed8c3b (diff)
downloadports-3d1ed214aa571a36316f3e78133a59e0ce290463.tar.gz
ports-3d1ed214aa571a36316f3e78133a59e0ce290463.zip
- Detect needed libs on installed sendmail package
8.11.6 and 8.12.1 tested.
Notes
Notes: svn path=/head/; revision=48706
Diffstat (limited to 'mail/vbsfilter')
-rw-r--r--mail/vbsfilter/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/mail/vbsfilter/Makefile b/mail/vbsfilter/Makefile
index 0088ae919e30..bd8f23e423c1 100644
--- a/mail/vbsfilter/Makefile
+++ b/mail/vbsfilter/Makefile
@@ -21,7 +21,14 @@ CTARGETS+= vbsfilter-${PORTVERSION}
CFLAGS+= -Wall -I$(LOCALBASE)/include ${PTHREAD_CFLAGS:S=""==}
FLAGS+= ${PTHREAD_LIBS}
LDFLAGS+= -L$(LOCALBASE)/lib
+
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/include/libmilter/mfdef.h)
+LIBS+= -lmilter -lsm -lsmutil
+.else
LIBS+= -lmilter -lsmutil
+.endif
.if defined(BATCH)
SENDMAIL_WITH_MILTER= yes
@@ -60,4 +67,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/vbsfilter.sh \
${PREFIX}/etc/rc.d/vbsfilter.sh.sample
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>