aboutsummaryrefslogtreecommitdiff
path: root/mail/vbsfilter
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2001-08-13 19:20:39 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2001-08-13 19:20:39 +0000
commitcdce4b7280b4f9c53d297752c7bac8864f2278fe (patch)
tree48d1750a9d712a43623b6d54821690ba8382648e /mail/vbsfilter
parent9e291238c6e74ef53bf1d11d78be6fb34c2477e2 (diff)
downloadports-cdce4b7280b4f9c53d297752c7bac8864f2278fe.tar.gz
ports-cdce4b7280b4f9c53d297752c7bac8864f2278fe.zip
- Update to version 1.7
* August 6 2001 -- vbsfilter-1.7 * Various fixes for the case where headers and/or body are empty. * Patch sent in by Sergiy Zhuk <serge@yahoo-inc.com> * * Update "dangerous extension" list. * Noted by David F. Russell <David.F.Russell@ncmail.net> * * July 25 2001 -- vbsfilter-1.6 * Also recognise 'name=blah' as well as the more usual 'name="blah"'. * Patch sent in by Andrea Adams <andrea@vividimage.com> * * July 9 2001 -- vbsfilter-1.5 * Add support to reject arbitrary extensions. * * March 31 2001 -- vbsfilter-1.4 * Update for sendmail-8.12 *
Notes
Notes: svn path=/head/; revision=46207
Diffstat (limited to 'mail/vbsfilter')
-rw-r--r--mail/vbsfilter/Makefile9
-rw-r--r--mail/vbsfilter/distinfo2
-rw-r--r--mail/vbsfilter/files/patch-vbsfilter.c23
3 files changed, 9 insertions, 25 deletions
diff --git a/mail/vbsfilter/Makefile b/mail/vbsfilter/Makefile
index 7ace4829c94d..0088ae919e30 100644
--- a/mail/vbsfilter/Makefile
+++ b/mail/vbsfilter/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= vbsfilter
-PORTVERSION= 1.3
+PORTVERSION= 1.7
CATEGORIES= mail
MASTER_SITES= http://aeschi.ch.eu.org/milter/
DISTNAME= ${PORTNAME}-${PORTVERSION}
@@ -17,7 +17,7 @@ MAINTAINER= dinoex@FreeBSD.org
BUILD_DEPENDS= ${LOCALBASE}/lib/libmilter.a:${PORTSDIR}/mail/sendmail
-CTARGETS+= vbsfilter-1.3
+CTARGETS+= vbsfilter-${PORTVERSION}
CFLAGS+= -Wall -I$(LOCALBASE)/include ${PTHREAD_CFLAGS:S=""==}
FLAGS+= ${PTHREAD_LIBS}
LDFLAGS+= -L$(LOCALBASE)/lib
@@ -41,7 +41,7 @@ pre-fetch:
do-extract:
@${MKDIR} ${WRKSRC}
- @${CP} ${_DISTDIR}vbsfilter-1.3.c ${WRKSRC}
+ @${CP} ${_DISTDIR}vbsfilter-${PORTVERSION}.c ${WRKSRC}
@${SED} -e "s=%%PREFIX%%=${PREFIX}=" ${FILESDIR}/vbsfilter.sh \
> ${WRKSRC}/vbsfilter.sh
@@ -55,7 +55,8 @@ ${i}:
do-build: ${CTARGETS}
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/vbsfilter-1.3 ${PREFIX}/libexec/vbsfilter
+ ${INSTALL_PROGRAM} ${WRKSRC}/vbsfilter-${PORTVERSION} \
+ ${PREFIX}/libexec/vbsfilter
${INSTALL_DATA} ${WRKSRC}/vbsfilter.sh \
${PREFIX}/etc/rc.d/vbsfilter.sh.sample
diff --git a/mail/vbsfilter/distinfo b/mail/vbsfilter/distinfo
index 8a7f1b542659..2bac03c5b17d 100644
--- a/mail/vbsfilter/distinfo
+++ b/mail/vbsfilter/distinfo
@@ -1 +1 @@
-MD5 (vbsfilter-1.3.c) = da70a84416927d0ba0a0c4e69cc4532e
+MD5 (vbsfilter-1.7.c) = 222402e7aec99ca633955cbffba9318a
diff --git a/mail/vbsfilter/files/patch-vbsfilter.c b/mail/vbsfilter/files/patch-vbsfilter.c
index 01f54df27d6e..06c50df5861c 100644
--- a/mail/vbsfilter/files/patch-vbsfilter.c
+++ b/mail/vbsfilter/files/patch-vbsfilter.c
@@ -1,6 +1,6 @@
---- vbsfilter-1.3.c.neu.orig Wed Feb 14 10:45:06 2001
-+++ vbsfilter-1.3.c Wed Feb 14 12:40:38 2001
-@@ -2,6 +2,10 @@
+--- vbsfilter-1.7.c.orig Mon Aug 13 21:11:36 2001
++++ vbsfilter-1.7.c Mon Aug 13 21:15:05 2001
+@@ -9,6 +9,10 @@
#include <stdio.h>
#include <string.h>
#include <sysexits.h>
@@ -11,20 +11,3 @@
#include "libmilter/mfapi.h"
/*
-@@ -172,7 +176,7 @@
- sfsistat mlfi_body(SMFICTX *ctx, u_char *bodyp, size_t bodylen) {
- struct mlfiPriv *priv = MLFIPRIV;
-
-- priv->body = (char *) realloc(priv->body, priv->len + bodylen);
-+ priv->body = (char *) realloc(priv->body, priv->len + bodylen + 1);
-
- if (!priv->body) {
- /* can't accept this message right now */
-@@ -181,6 +185,7 @@
-
- memcpy((u_char*)(priv->body+priv->len), bodyp, bodylen);
- priv->len += bodylen;
-+ priv->body[priv->len] = 0;
-
- /* continue processing */
- return SMFIS_CONTINUE;