aboutsummaryrefslogtreecommitdiff
path: root/mail/vpopmail-devel
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2002-09-05 14:30:21 +0000
committerPeter Pentchev <roam@FreeBSD.org>2002-09-05 14:30:21 +0000
commitf31f83abe9f9cb6fcc0d407e3b2606ff090e6f16 (patch)
tree9dfd982c78871824bc5e5f16e4ff7227f544365a /mail/vpopmail-devel
parent816feec53e11c190f5db94db9d9baa9a44351653 (diff)
downloadports-f31f83abe9f9cb6fcc0d407e3b2606ff090e6f16.tar.gz
ports-f31f83abe9f9cb6fcc0d407e3b2606ff090e6f16.zip
Notes
Diffstat (limited to 'mail/vpopmail-devel')
-rw-r--r--mail/vpopmail-devel/Makefile13
-rw-r--r--mail/vpopmail-devel/distinfo2
-rw-r--r--mail/vpopmail-devel/files/patch-vchkpw.c11
3 files changed, 12 insertions, 14 deletions
diff --git a/mail/vpopmail-devel/Makefile b/mail/vpopmail-devel/Makefile
index 42fc4d779f1d..7e67388b9bc1 100644
--- a/mail/vpopmail-devel/Makefile
+++ b/mail/vpopmail-devel/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= vpopmail
-PORTVERSION= 5.3.6
-PORTREVISION= 1
+PORTVERSION= 5.3.8
CATEGORIES= mail
MASTER_SITES= http://www.inter7.com/devel/
@@ -49,6 +48,8 @@ CONFIGURE_ARGS= --enable-qmaildir=${QMAIL_DIR} \
# WITH_QMAIL_EXT - enables qmail-like user-* address extesions processing
# WITHOUT_FILE_LOCKING - disable file locking
# WITH_FILE_SYNC - enables immediate synching (may decrease performance)
+# WITHOUT_USERS_BIG_DIR - disables using big directories for users
+# WITHOUT_SEEKABLE - disables vdelivermail's attempt to make its input seekable
#
# Set these to the values you'd prefer
#
@@ -229,6 +230,14 @@ CONFIGURE_ARGS+= --enable-file-sync=y
CONFIGURE_ARGS+= --enable-auth-logging=n
.endif
+.if defined(WITHOUT_USERS_BIG_DIR)
+CONFIGURE_ARGS+= --enable-users-big-dir=n
+.endif
+
+.if defined(WITHOUT_SEEKABLE)
+CONFIGURE_ARGS+= --enable-make-seekable=n
+.endif
+
#
# This port doesn't honour PREFIX, it honours vpopmail's home directory.
# Since we create vpopmail if it doesn't exist, we set it so that it
diff --git a/mail/vpopmail-devel/distinfo b/mail/vpopmail-devel/distinfo
index 43e2e617c5aa..7333521b0c20 100644
--- a/mail/vpopmail-devel/distinfo
+++ b/mail/vpopmail-devel/distinfo
@@ -1 +1 @@
-MD5 (vpopmail-5.3.6.tar.gz) = 00afe01169a2ea4285548528dc7eb2bb
+MD5 (vpopmail-5.3.8.tar.gz) = 60eba65641d863a3aa2bf85b221ac05d
diff --git a/mail/vpopmail-devel/files/patch-vchkpw.c b/mail/vpopmail-devel/files/patch-vchkpw.c
deleted file mode 100644
index 7fb12ce26c91..000000000000
--- a/mail/vpopmail-devel/files/patch-vchkpw.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- vchkpw.c.orig Thu Jun 13 15:05:53 2002
-+++ vchkpw.c Thu Jun 13 15:06:16 2002
-@@ -556,7 +556,7 @@
- pw_gid = pw->pw_gid;
- pw_dir = pw->pw_dir;
- #ifdef POP_AUTH_OPEN_RELAY
-- if ( (strcmp(LocalPort, "25") != 0) && (strcmp(LocalPort, "465") != 0)) {
-+ if ( (LocalPort != 25) && (LocalPort != 465)) {
- open_smtp_relay();
- }
- #endif