aboutsummaryrefslogtreecommitdiff
path: root/mail/vpopmail/Makefile
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2002-11-02 21:33:09 +0000
committerPeter Pentchev <roam@FreeBSD.org>2002-11-02 21:33:09 +0000
commitaa47b1121dc049024db4b375fc8c9b8d0e7ecb33 (patch)
treeaee28ec00f8d32f7a49abb6f9bf9a0c8b3d238da /mail/vpopmail/Makefile
parentbfd5b9cdfbf60c429d574ce589484b8c348aa2d0 (diff)
Notes
Diffstat (limited to 'mail/vpopmail/Makefile')
-rw-r--r--mail/vpopmail/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/mail/vpopmail/Makefile b/mail/vpopmail/Makefile
index 3de3111c0243..5aee22d34f39 100644
--- a/mail/vpopmail/Makefile
+++ b/mail/vpopmail/Makefile
@@ -7,11 +7,10 @@
PORTNAME= vpopmail
PORTVERSION= 5.3.9
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= http://www.inter7.com/devel/
-FORBIDDEN= 'Checksum mismatch, new features investigated'
-
MAINTAINER= roam@FreeBSD.org
BUILD_DEPENDS= ${QMAIL_DIR}/bin/qmail-send:${PORTSDIR}/mail/qmail \
@@ -28,7 +27,7 @@ VCFGFILES?= inc_deps lib_deps tcp.smtp
CONFIGURE_ENV+= VCFGDIR="${VCFGDIR}"
CONFIGURE_ARGS= --enable-qmaildir=${QMAIL_DIR} \
- --enable-tcprules-bin=${LOCALBASE}/bin/tcprules \
+ --enable-tcprules-prog=${LOCALBASE}/bin/tcprules \
--enable-tcpserver-file=${PREFIX}/vpopmail/etc/tcp.smtp
#
@@ -82,6 +81,7 @@ CONFIGURE_ARGS= --enable-qmaildir=${QMAIL_DIR} \
# WITH_MYSQL_READ_SERVER, WITH_MYSQL_READ_USER, WITH_MYSQL_READ_PASSWD
# WITH_MYSQL_UPDATE_SERVER, WITH_MYSQL_UPDATE_USER, WITH_MYSQL_UPDATE_PASSWD
# Those variables, if defined, override WITH_MYSQL_{SERVER,USER,PASSWD}
+# WITH_MYSQL_LIMITS - enable vpopmail handling of .qmailadmin-limits (BROKEN)
#
# Oracle database configuration options
#
@@ -177,6 +177,10 @@ CONFIGURE_ARGS+= --enable-mysql-replication=y
.if defined(WITH_MYSQL_LOG)
CONFIGURE_ARGS+= --enable-mysql-logging=y
.endif
+.if defined(WITH_MYSQL_LIMITS)
+BROKEN= "the MySQL limits code is not usable yet; please unset WITH_MYSQL_LIMITS"
+CONFIGURE_ARGS+= --enable-mysql-limits=y
+.endif
.if defined(WITH_MYSQL_SERVER)
WITH_MYSQL_READ_SERVER?= ${WITH_MYSQL_SERVER}