aboutsummaryrefslogtreecommitdiff
path: root/mail/websieve/Makefile
diff options
context:
space:
mode:
authorOliver Eikemeier <eik@FreeBSD.org>2004-07-19 07:25:30 +0000
committerOliver Eikemeier <eik@FreeBSD.org>2004-07-19 07:25:30 +0000
commit405420ffaadc6f7fb05db239745c5beceddb19f8 (patch)
treeb306d78eb8492026e66249c0edcafcfee49bacc5 /mail/websieve/Makefile
parent2f53f9a14a0af905f490eeb29a392521e1b8dbbc (diff)
downloadports-405420ffaadc6f7fb05db239745c5beceddb19f8.tar.gz
ports-405420ffaadc6f7fb05db239745c5beceddb19f8.zip
Notes
Diffstat (limited to 'mail/websieve/Makefile')
-rw-r--r--mail/websieve/Makefile23
1 files changed, 7 insertions, 16 deletions
diff --git a/mail/websieve/Makefile b/mail/websieve/Makefile
index e19229fe90fb..5f5d73c8b068 100644
--- a/mail/websieve/Makefile
+++ b/mail/websieve/Makefile
@@ -6,15 +6,19 @@
#
PORTNAME= websieve
-PORTVERSION= 0.61
-PORTREVISION= 1
+PORTVERSION= 0.63.a
CATEGORIES= mail
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME?= ${PORTNAME}-${DISTVERSION}
MAINTAINER= eik@FreeBSD.org
COMMENT= Web based Cyrus IMAP user admin client
+DISTVERSION= 063a
+
+.include "options"
+
.if defined(WITH_CYRUS_IMAPD_VER)
.if ${WITH_CYRUS_IMAPD_VER} == 22
RUN_DEPENDS= ${CYRUS_IMAP_PM}:${PORTSDIR}/mail/cyrus-imapd22
@@ -31,7 +35,6 @@ RUN_DEPENDS= ${SITE_PERL}/IMAP/Admin.pm:${PORTSDIR}/mail/p5-IMAP-Admin \
.endif
RUN_DEPENDS+= ${LOCALBASE}/www/cgi-bin:${PORTSDIR}/${APACHE_PORT}
-WRKSRC= ${WRKDIR}/${PORTNAME}
PKGMESSAGE= ${WRKDIR}/pkg-message
USE_REINPLACE= yes
@@ -47,18 +50,6 @@ FUNCLIB_PL= funclib.cyrus
FUNCLIB_PL= funclib.pl
.endif
-# We can not test .if exists(${CYRUS_IMAP_PM}) here
-# because SITE_PERL is defined in <bsd.port.post.mk>
-.if !defined(WITH_CYRUS_IMAPD_VER)
-pre-everything::
- @${ECHO_CMD} "If you want to use the Cyrus IMAP and Sieve perl modules"
- @${ECHO_CMD} "hit Ctrl-C right now and use WITH_CYRUS_IMAPD_VER=22, 21 or 20"
- @${ECHO_CMD}
- @${ECHO_CMD} "The Cyrus perl modules do not support SSL, but better"
- @${ECHO_CMD} "authentication mechanisms than cleartext PLAIN."
- @${ECHO_CMD}
-.endif
-
post-configure:
@${REINPLACE_CMD} -e "s,require[ ]*'\./\([^']*\)',require '${PREFIX}/etc/websieve/\1'," \
${WRKSRC}/websieve.pl