aboutsummaryrefslogtreecommitdiff
path: root/mail/websieve
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-03-12 14:16:52 +0000
committerMathieu Arnold <mat@FreeBSD.org>2015-03-12 14:16:52 +0000
commitfd4f57c36c737fd4dec9ef42941951cf5729e480 (patch)
tree370cd362144670a033baa02ad8d35e76d9e40bdf /mail/websieve
parent58d405b421384403fd4bd739093867faf376acf1 (diff)
downloadports-fd4f57c36c737fd4dec9ef42941951cf5729e480.tar.gz
ports-fd4f57c36c737fd4dec9ef42941951cf5729e480.zip
Cleanup options, use RADIO and SINGLE.
Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=381092
Diffstat (limited to 'mail/websieve')
-rw-r--r--mail/websieve/Makefile53
-rw-r--r--mail/websieve/files/pkg-message.in5
2 files changed, 35 insertions, 23 deletions
diff --git a/mail/websieve/Makefile b/mail/websieve/Makefile
index 8c4bf13eff66..5df4838baa52 100644
--- a/mail/websieve/Makefile
+++ b/mail/websieve/Makefile
@@ -3,14 +3,17 @@
PORTNAME= websieve
PORTVERSION= 0.63.a
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/063a
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${DISTVERSION}
DISTNAME?= ${PORTNAME}-${DISTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Web based Cyrus IMAP user admin client
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/GPL
+
DISTVERSION= 063a
USES= perl5
@@ -18,36 +21,46 @@ USE_PERL5= run
NO_BUILD= yes
-# Oh for the ability to do radio buttons. In this case, just use the
-# highest select version number. If no Cyrus IMAPd versions are
-# selected, use some generic IMAP modules
+OPTIONS_SINGLE= TYPE
+OPTIONS_SINGLE_TYPE= PERL CYRUS
+OPTIONS_RADIO= CYRDEP
+OPTIONS_RADIO_CYRDEP= CYRUS_IMAPD_23 CYRUS_IMAPD_24 CYRUS_IMAPD_25
+OPTIONS_DEFAULT= CYRUS CYRUS_IMAPD_24
+
+TYPE_DESC= Choose which sieve backend to use
+PERL_DESC= Depend on generic Perl modules
+CYRUS_DESC= Depend on Cyrus IMAPd Perl modules
+CYRDEP_DESC= Which version of Cyrus IMAPd to depend on
+CYRUS_IMAPD_23_DESC= Cyrus IMAPd version 2.3.x
+CYRUS_IMAPD_24_DESC= Cyrus IMAPd version 2.4.x
+CYRUS_IMAPD_25_DESC= Cyrus IMAPd version 2.5.x
-OPTIONS_DEFINE= CYRUS_IMAPD_23 CYRUS_IMAPD_24 CYRUS_IMAPD_25
-OPTIONS_DEFAULT= CYRUS_IMAPD_24
+CYRUS_IMAPD_25_RUN_DEPENDS= ${SITE_ARCH}/Cyrus/SIEVE/managesieve.pm:${PORTSDIR}/mail/cyrus-imapd25
+CYRUS_IMAPD_24_RUN_DEPENDS= ${SITE_ARCH}/Cyrus/SIEVE/managesieve.pm:${PORTSDIR}/mail/cyrus-imapd24
+CYRUS_IMAPD_23_RUN_DEPENDS= ${SITE_ARCH}/Cyrus/SIEVE/managesieve.pm:${PORTSDIR}/mail/cyrus-imapd23
-CYRUS_IMAPD_23_DESC= With Cyrus IMAPd version 2.3.x
-CYRUS_IMAPD_24_DESC= With Cyrus IMAPd version 2.4.x
-CYRUS_IMAPD_25_DESC= With Cyrus IMAPd version 2.5.x
+PERL_RUN_DEPENDS= p5-IMAP-Admin>=0:${PORTSDIR}/mail/p5-IMAP-Admin \
+ p5-IMAP-Sieve>=0:${PORTSDIR}/mail/p5-IMAP-Sieve
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MCYRUS_IMAPD_25}
-RUN_DEPENDS+= cyradm:${PORTSDIR}/mail/cyrus-imapd25
-FUNCLIB_PL= funclib.cyrus
-.elif ${PORT_OPTIONS:MCYRUS_IMAPD_24}
-RUN_DEPENDS+= cyradm:${PORTSDIR}/mail/cyrus-imapd24
-FUNCLIB_PL= funclib.cyrus
-.elif ${PORT_OPTIONS:MCYRUS_IMAPD_23}
-RUN_DEPENDS+= cyradm:${PORTSDIR}/mail/cyrus-imapd23
+.if ${PORT_OPTIONS:MCYRUS}
FUNCLIB_PL= funclib.cyrus
.else
-RUN_DEPENDS+= p5-IMAP-Admin>=0:${PORTSDIR}/mail/p5-IMAP-Admin \
- p5-IMAP-Sieve>=0:${PORTSDIR}/mail/p5-IMAP-Sieve
FUNCLIB_PL= funclib.pl
.endif
SUB_FILES= pkg-message
+_check-config: my-check-config
+my-check-config:
+.if ${PORT_OPTIONS:MPERL}
+.if !empty(PORT_OPTIONS:MCYRUS_IMAPD_23) || !empty(PORT_OPTIONS:MCYRUS_IMAPD_24) || !empty(PORT_OPTIONS:MCYRUS_IMAPD_25)
+ @${ECHO_MSG} "====> You cannot select a dependency on cyrus with the PERL option"
+_CHECK_CONFIG_ERROR= true
+.endif
+.endif
+
post-configure:
@${REINPLACE_CMD} -e "s,require[ ]*'\./\([^']*\)',require '${PREFIX}/etc/websieve/\1'," \
${WRKSRC}/websieve.pl
diff --git a/mail/websieve/files/pkg-message.in b/mail/websieve/files/pkg-message.in
index d2d4cb816023..48b069bcc17e 100644
--- a/mail/websieve/files/pkg-message.in
+++ b/mail/websieve/files/pkg-message.in
@@ -12,8 +12,7 @@ your Apache configuration:
Options ExecCGI
AllowOverride none
- Order Deny,Allow
- Deny from all
- Allow from 127.0.0.1 .example.com
+ require ip 127.0.0.1
+ require host .example.com
</Directory>