aboutsummaryrefslogtreecommitdiff
path: root/mail/whoson
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2006-05-13 21:39:05 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2006-05-13 21:39:05 +0000
commita8ff0022918d8dc4396ee209037494ff610854f4 (patch)
tree81a763ba4dec5d7479850eb50ac37ff4e041e080 /mail/whoson
parentcb8c9617bc830200d95f374ced169d8536df6c54 (diff)
downloadports-a8ff0022918d8dc4396ee209037494ff610854f4.tar.gz
ports-a8ff0022918d8dc4396ee209037494ff610854f4.zip
Whoson ("WHO iS ONline") protocol implementaion
Notes
Notes: svn path=/head/; revision=162258
Diffstat (limited to 'mail/whoson')
-rw-r--r--mail/whoson/Makefile38
-rw-r--r--mail/whoson/distinfo3
-rw-r--r--mail/whoson/files/whoson.sh.in29
-rw-r--r--mail/whoson/pkg-descr13
-rw-r--r--mail/whoson/pkg-plist8
5 files changed, 91 insertions, 0 deletions
diff --git a/mail/whoson/Makefile b/mail/whoson/Makefile
new file mode 100644
index 000000000000..2095addc6b9a
--- /dev/null
+++ b/mail/whoson/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: whoson
+# Date created: 14 May 2006
+# Whom: Sergey Matveychuk <sem@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= whoson
+PORTVERSION= 2.03
+CATEGORIES= mail
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= sem@FreeBSD.org
+COMMENT= "WHO iS ONline" protocol implementatino
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --with-config=${PREFIX}/etc/whoson.conf
+INSTALLS_SHLIB= yes
+
+USE_RC_SUBR= whoson.sh
+
+MAN3= whoson.3 wso_login.3 wso_logout.3 wso_query.3 wso_version.3
+MAN5= whoson.conf.5
+MAN8= whoson.8 whosond.8
+
+PORTDOCS= README ChangeLog
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/mail/whoson/distinfo b/mail/whoson/distinfo
new file mode 100644
index 000000000000..d44a8fe62458
--- /dev/null
+++ b/mail/whoson/distinfo
@@ -0,0 +1,3 @@
+MD5 (whoson-2.03.tar.gz) = 9bb91b9e0d5a10574e78aa6647dd7ab9
+SHA256 (whoson-2.03.tar.gz) = c98282844e89d57e619159d78699816e68bdeecf24baf4e34ce049c07606262c
+SIZE (whoson-2.03.tar.gz) = 238133
diff --git a/mail/whoson/files/whoson.sh.in b/mail/whoson/files/whoson.sh.in
new file mode 100644
index 000000000000..aafc8c12035e
--- /dev/null
+++ b/mail/whoson/files/whoson.sh.in
@@ -0,0 +1,29 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: whoson
+# REQUIRE: NETWORKING
+# KEYWORD: shutdown
+
+#
+# Add the following lines to /etc/rc.conf to enable frox:
+#
+#whosond="YES"
+#
+
+. %%RC_SUBR%%
+
+name=whosond
+rcvar=`set_rcvar`
+
+command=%%PREFIX%%/sbin/${name}
+required_files=%%PREFIX%%/etc/whoson.conf
+
+# set defaults
+
+whosond_enable=${whosond_enable:-"NO"}
+
+load_rc_config $name
+run_rc_command "$1"
diff --git a/mail/whoson/pkg-descr b/mail/whoson/pkg-descr
new file mode 100644
index 000000000000..94845425a118
--- /dev/null
+++ b/mail/whoson/pkg-descr
@@ -0,0 +1,13 @@
+This software is supposed to work as a "reference implementation" of the
+suggested "whoson" internet protocol. The protocol is expected to be
+employed on "spam relay protected" mail servers to allow traveling
+customers still send their email via the protected server. For this, a
+realtime database of "temporarily trusted" IP addresses is maintained by
+a special daemon program. The database may be filled by, e.g. POP/IMAP
+servers, and used by SMTP server. Another possible use of the protocol
+is to have the database filled by RADIUS/TACACS server for all dialup
+clients, and SMTP server using it to put the user identity into the
+"Received" header along with the source IP address. The protocol itself
+is defined in a separate document "whoson.txt".
+
+WWW: http://whoson.sourceforge.net
diff --git a/mail/whoson/pkg-plist b/mail/whoson/pkg-plist
new file mode 100644
index 000000000000..17243d363854
--- /dev/null
+++ b/mail/whoson/pkg-plist
@@ -0,0 +1,8 @@
+etc/whoson.conf
+include/whoson.h
+lib/libwhoson.a
+lib/libwhoson.la
+lib/libwhoson.so
+lib/libwhoson.so.0
+sbin/whoson
+sbin/whosond